pthread user => include pthread.b3.mk. Use PTHREAD_* instead of

hard-wired -lpthread. Use sys/wait.h on DragonFly as well.
This commit is contained in:
joerg 2006-01-03 20:54:15 +00:00
parent a485b489e3
commit 77682d00ba
4 changed files with 34 additions and 7 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.9 2005/10/11 12:35:06 adam Exp $
# $NetBSD: Makefile,v 1.10 2006/01/03 20:54:15 joerg Exp $
DISTNAME= libqalculate-0.8.2
PKGNAME= qalculate-0.8.2
@ -24,5 +24,6 @@ UNLIMIT_RESOURCES= datasize
.include "../../math/cln/buildlink3.mk"
.include "../../textproc/intltool/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.6 2005/10/11 12:35:06 adam Exp $
$NetBSD: distinfo,v 1.7 2006/01/03 20:54:15 joerg Exp $
SHA1 (libqalculate-0.8.2.tar.gz) = 70b6c31f2491c1bb1da8b28c98b594a9d76b4152
RMD160 (libqalculate-0.8.2.tar.gz) = 5a97646c249ac696e6334e56770a5c90c463d2f8
Size (libqalculate-0.8.2.tar.gz) = 683579 bytes
SHA1 (patch-aa) = 400dd8d44dc517433ebcf4fbaa8c701414d89340
SHA1 (patch-ab) = b8032c8060283ef27f433d640e571df14772c5ca
SHA1 (patch-aa) = 6d54e5ad2fde952ec96df7638ce73ea47cf684b1
SHA1 (patch-ab) = e3501b7df41fce3c214508f6a125f37ec15f4e99

View file

@ -1,4 +1,4 @@
$NetBSD: patch-aa,v 1.2 2005/08/03 13:36:05 adam Exp $
$NetBSD: patch-aa,v 1.3 2006/01/03 20:54:15 joerg Exp $
--- libqalculate/Calculator.cc.orig 2004-10-18 12:30:49.000000000 +0000
+++ libqalculate/Calculator.cc
@ -6,7 +6,7 @@ $NetBSD: patch-aa,v 1.2 2005/08/03 13:36:05 adam Exp $
#include <sys/types.h>
#include <sys/stat.h>
#include <dirent.h>
+#if defined(__NetBSD__)
+#if defined(__NetBSD__) || defined(__DragonFly__)
+#include <sys/wait.h>
+#else
#include <wait.h>

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ab,v 1.3 2005/10/11 12:35:06 adam Exp $
$NetBSD: patch-ab,v 1.4 2006/01/03 20:54:15 joerg Exp $
--- configure.orig 2005-10-08 22:24:33.000000000 +0000
+++ configure
@ -15,3 +15,29 @@ $NetBSD: patch-ab,v 1.3 2005/10/11 12:35:06 adam Exp $
;;
esac
fi
@@ -21215,13 +21213,13 @@ QALCULATE_AGE=0
-echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
-echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
+echo "$as_me:$LINENO: checking for pthread_create in ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}" >&5
+echo $ECHO_N "checking for pthread_create in ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}... $ECHO_C" >&6
if test "${ac_cv_lib_pthread_pthread_create+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lpthread $LIBS"
+LIBS="${PTHREAD_LDFLAGS} ${PTHREAD_LIBS} $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -21280,7 +21278,7 @@ fi
echo "$as_me:$LINENO: result: $ac_cv_lib_pthread_pthread_create" >&5
echo "${ECHO_T}$ac_cv_lib_pthread_pthread_create" >&6
if test $ac_cv_lib_pthread_pthread_create = yes; then
- LIBS="$LIBS -lpthread"
+ LIBS="$LIBS ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}"
fi