Incorporate patches from Bruce Guenter to fix ezmlm-send argument
construction in ezmlm-confirm, ezmlm-store, and ezmlm-moderate. Will be in the next release. Bump PKGREVISION.
This commit is contained in:
parent
198d0b81b0
commit
777f20508f
6 changed files with 48 additions and 5 deletions
|
@ -1,9 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.12 2005/01/03 02:20:35 schmonz Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2005/01/08 00:15:28 schmonz Exp $
|
||||
#
|
||||
|
||||
.include "../../mail/ezmlm/Makefile.common"
|
||||
|
||||
DISTNAME= ezmlm-idx-0.432
|
||||
PKGREVISION= 1
|
||||
SITES_${DISTNAME}.tar.gz= http://www.ezmlm.org/archive/${PKGVERSION}/
|
||||
|
||||
MAINTAINER= schmonz@NetBSD.org
|
||||
|
|
|
@ -1,8 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.6 2005/01/03 02:20:35 schmonz Exp $
|
||||
$NetBSD: distinfo,v 1.7 2005/01/08 00:15:28 schmonz Exp $
|
||||
|
||||
SHA1 (ezmlm-idx-0.432.tar.gz) = 84f87c831f7cbd4446ec28513e70a2e92a4dd921
|
||||
Size (ezmlm-idx-0.432.tar.gz) = 614423 bytes
|
||||
SHA1 (ezmlm-0.53.tar.gz) = 3a7b618737fed8b774bec69c272d70f4142c1e30
|
||||
Size (ezmlm-0.53.tar.gz) = 62693 bytes
|
||||
SHA1 (patch-aa) = baed20dfa32264db81cd738f0f3bcba66ab1cba2
|
||||
SHA1 (patch-ab) = 7df2115cdfbfe79f03686716d3c21bb70bf80214
|
||||
SHA1 (patch-ab) = b80311e9aefe638e2ecc579c3d703c620e2cb064
|
||||
SHA1 (patch-ac) = cf2ac80a5fa4f56d623d296fdbc7ef0d63afaf3f
|
||||
SHA1 (patch-ad) = 3ef3eaf76329774373e0ddf3089cc9a0252d3a2c
|
||||
SHA1 (patch-ae) = 09975c540b9dbcf5a2b3d907cee3324ad6f28582
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ab,v 1.3 2004/12/29 22:13:56 schmonz Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2005/01/08 00:15:28 schmonz Exp $
|
||||
|
||||
--- BIN.orig 2004-12-29 17:06:27.000000000 -0500
|
||||
--- BIN.orig 2005-01-07 18:53:00.000000000 -0500
|
||||
+++ BIN
|
||||
@@ -22,9 +22,6 @@ c:::755:/:ezmlm-split:
|
||||
c:::755:/:ezmlm-moderate:
|
||||
|
|
13
mail/ezmlm-idx/patches/patch-ac
Normal file
13
mail/ezmlm-idx/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.3 2005/01/08 00:15:28 schmonz Exp $
|
||||
|
||||
--- ezmlm-confirm.c.orig 2004-12-17 11:56:36.000000000 -0500
|
||||
+++ ezmlm-confirm.c
|
||||
@@ -138,7 +138,7 @@ void main(int argc, char **argv)
|
||||
sig_pipeignore();
|
||||
when = now();
|
||||
|
||||
- if (!stralloc_copys(&sendopt," -")) die_nomem();
|
||||
+ if (!stralloc_copys(&sendopt,"-")) die_nomem();
|
||||
while ((opt = getopt(argc,argv,"cCmMrRt:T:vV")) != opteof)
|
||||
switch(opt) { /* pass on ezmlm-send options */
|
||||
case 'c': /* ezmlm-send flags */
|
13
mail/ezmlm-idx/patches/patch-ad
Normal file
13
mail/ezmlm-idx/patches/patch-ad
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.1 2005/01/08 00:15:28 schmonz Exp $
|
||||
|
||||
--- ezmlm-moderate.c.orig 2004-12-23 19:06:13.000000000 -0500
|
||||
+++ ezmlm-moderate.c
|
||||
@@ -204,7 +204,7 @@ char **argv;
|
||||
sig_pipeignore();
|
||||
when = now();
|
||||
|
||||
- if (!stralloc_copys(&sendopt," -")) die_nomem();
|
||||
+ if (!stralloc_copys(&sendopt,"-")) die_nomem();
|
||||
while ((opt = getopt(argc,argv,"cCmMrRt:T:vV")) != opteof)
|
||||
switch(opt) { /* pass on ezmlm-send options */
|
||||
case 'c': /* ezmlm-send flags */
|
13
mail/ezmlm-idx/patches/patch-ae
Normal file
13
mail/ezmlm-idx/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1 2005/01/08 00:15:28 schmonz Exp $
|
||||
|
||||
--- ezmlm-store.c.orig 2004-12-23 19:06:13.000000000 -0500
|
||||
+++ ezmlm-store.c
|
||||
@@ -154,7 +154,7 @@ char **argv;
|
||||
(void) umask(022);
|
||||
sig_pipeignore();
|
||||
|
||||
- if (!stralloc_copys(&sendopt," -")) die_nomem();
|
||||
+ if (!stralloc_copys(&sendopt,"-")) die_nomem();
|
||||
while ((opt = getopt(argc,argv,"bBcCmMpPrRsSvVyY")) != opteof)
|
||||
switch(opt) {
|
||||
case 'b': flagbody = 1; break;
|
Loading…
Reference in a new issue