Fix PR pkg/45408.

Treat getine as like as getopt.

Thank you, obache@.
This commit is contained in:
ryoon 2011-09-27 12:43:20 +00:00
parent 202e47b864
commit 77b234d79a
5 changed files with 50 additions and 13 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2011/09/22 15:16:26 ryoon Exp $
$NetBSD: distinfo,v 1.7 2011/09/27 12:43:20 ryoon Exp $
SHA1 (cvs-1.11.23.tar.bz2) = a51c531eebaff2dfdcc0fb6d94c8c6e509e06d7d
RMD160 (cvs-1.11.23.tar.bz2) = ff8c5c6777f1c12ee9134a3cf59e00c2ebaad279
@ -26,6 +26,8 @@ SHA1 (patch-av) = f638f5bf5489c35c493885af5f7dfd7708660199
SHA1 (patch-ay) = ec49abaa286e6be440a0efd910cf26c86835fe20
SHA1 (patch-az) = 8000247fb946b4ac07261b1dedae4581a29476d7
SHA1 (patch-ba) = 7153e12e5da86effd4285e147f9f534011982e07
SHA1 (patch-lib_getline.c) = 2b21ebe8a9601723a12dfc18f124ed333c93b90b
SHA1 (patch-lib_getline.h) = b1d41a81f63b5dea6dd5754de1dd898ae0d85fcc
SHA1 (patch-config.h.in) = 5a9ba2d2ec2eac8e1a1b4480d5ebe62d72987559
SHA1 (patch-configure) = a264244219f583e072a3ec7c04945eb3b8cc5221
SHA1 (patch-lib_getline.c) = e1bb8ac852abd8a25ea3b84455d09e1b4ba728e5
SHA1 (patch-lib_getline.h) = 1d91f3f22e4e5aad9f8941f88855d4f41ba25dfe
SHA1 (patch-lib_xsize.h) = d16bd33322fb7e3750f425d5ea58fbc3413b910b

View file

@ -0,0 +1,14 @@
$NetBSD: patch-config.h.in,v 1.1 2011/09/27 12:43:21 ryoon Exp $
--- config.h.in.orig 2008-05-07 20:13:06.000000000 +0000
+++ config.h.in
@@ -115,6 +115,9 @@
/* Define to 1 if you have the `gethostname' function. */
#undef HAVE_GETHOSTNAME
+/* Define to 1 if you have the `getline' function. */
+#undef HAVE_GETLINE
+
/* Define to 1 if you have the `getopt' function. */
#undef HAVE_GETOPT

View file

@ -0,0 +1,12 @@
$NetBSD: patch-configure,v 1.1 2011/09/27 12:43:21 ryoon Exp $
--- configure.orig 2008-05-07 20:12:30.000000000 +0000
+++ configure
@@ -8098,6 +8098,7 @@ for ac_func in \
ftime \
geteuid \
getgroups \
+ getline \
getopt \
getpagesize \
getpid \

View file

@ -1,15 +1,22 @@
$NetBSD: patch-lib_getline.c,v 1.1 2011/09/22 15:16:26 ryoon Exp $
$NetBSD: patch-lib_getline.c,v 1.2 2011/09/27 12:43:21 ryoon Exp $
* Avoid getline conflict
--- lib/getline.c.orig 2005-04-04 20:46:05.000000000 +0000
+++ lib/getline.c
@@ -155,7 +155,7 @@ getstr (lineptr, n, stream, terminator,
@@ -154,6 +154,7 @@ getstr (lineptr, n, stream, terminator,
return ret;
}
+#ifndef HAVE_GETLINE
int
-getline (lineptr, n, stream)
+getline_cvs (lineptr, n, stream)
getline (lineptr, n, stream)
char **lineptr;
size_t *n;
FILE *stream;
@@ -162,6 +163,7 @@ getline (lineptr, n, stream)
{
return getstr (lineptr, n, stream, '\n', 0, GETLINE_NO_LIMIT);
}
+#endif
int
getline_safe (lineptr, n, stream, limit)

View file

@ -1,15 +1,17 @@
$NetBSD: patch-lib_getline.h,v 1.1 2011/09/22 15:16:26 ryoon Exp $
$NetBSD: patch-lib_getline.h,v 1.2 2011/09/27 12:43:21 ryoon Exp $
* Avoid getline conflict
--- lib/getline.h.orig 2005-04-04 20:46:05.000000000 +0000
+++ lib/getline.h
@@ -12,7 +12,7 @@
@@ -11,8 +11,10 @@
#define GETLINE_NO_LIMIT -1
+#ifndef HAVE_GETLINE
int
- getline __PROTO ((char **_lineptr, size_t *_n, FILE *_stream));
+ getline_cvs __PROTO ((char **_lineptr, size_t *_n, FILE *_stream));
getline __PROTO ((char **_lineptr, size_t *_n, FILE *_stream));
+#endif
int
getline_safe __PROTO ((char **_lineptr, size_t *_n, FILE *_stream,
int limit));