- move elisp files to separate package

- add okinawa dict

patch from Jun Yamashiro <yamajun AT ofug DOT net>
This commit is contained in:
taya 2004-12-28 05:35:29 +00:00
parent 32800b6ec3
commit 7823040505
4 changed files with 47 additions and 45 deletions

View file

@ -1,13 +1,11 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/12/04 03:57:44 taya Exp $
# $NetBSD: Makefile,v 1.2 2004/12/28 05:35:29 taya Exp $
DISTNAME= anthy-5900
CATEGORIES= inputmethod
MASTER_SITES= http://downloads.sourceforge.jp/anthy/12071/
DISTFILES= ${DISTNAME}.tar.gz
.include "../../inputmethod/anthy/Makefile.common"
PKGREVISION= 1
EXTRACT_ONLY= ${DISTNAME}.tar.gz
MAINTAINER= taya@NetBSD.org
HOMEPAGE= http://anthy.sourceforge.jp/
COMMENT= Kana Kanji conversion system
USE_LIBTOOL= yes
@ -15,28 +13,52 @@ USE_LANGUAGES= c
USE_GNU_TOOLS+= make
GNU_CONFIGURE= yes
EMACS_USE_LEIM= # defined
CONFIGURE_ENV+= EMACS=no
# Global and legacy options
.if defined(USE_2CH_DICT) && ${USE_2CH_DICT} == "yes"
.if defined(USE_2CH_DICT) && !empty(USE_2CH_DICT:M[Yy][Ee][Ss])
PKG_DEFAULT_OPTIONS+= 2ch_dict
.endif
.if defined(USE_OKINAWA_DICT) && !empty(USE_OKINAWA_DICT:M[Yy][Ee][Ss])
PKG_DEFAULT_OPTIONS+= okinawa_dict
.endif
PKG_OPTIONS_VAR= PKG_OPTIONS.anthy
PKG_SUPPORTED_OPTIONS= 2ch_dict
PKG_SUPPORTED_OPTIONS= 2ch_dict okinawa_dict
.include "../../mk/bsd.options.mk"
###
### 2ch dictionary support
### Optional dictionary support
###
.if !empty(PKG_OPTIONS:M2ch_dict)
DISTFILES+= 2ch.t
SITES_2ch.t+= http://omaemona.sourceforge.net/packages/Zisyo/
post-extract:
${CP} ${DISTDIR}/2ch.t ${WRKSRC}/mkanthydic
.endif
.include "../../mk/emacs.mk"
.if !empty(PKG_OPTIONS:Mokinawa_dict)
DISTFILES+= okinawa-20041220.t
SITES_okinawa-20041220.t+= http://www.ofug.net/~yamajun/files/
.endif
post-patch:
.if !empty(PKG_OPTIONS:M2ch_dict)
${CP} ${DISTDIR}/2ch.t ${WRKSRC}/mkanthydic
@printf '/^EXTRA_DICS\ns/$$/ 2ch.t/\nwq\n' | \
ed -s ${WRKSRC}/mkanthydic/Makefile.in
.endif
.if !empty(PKG_OPTIONS:Mokinawa_dict)
${CP} ${DISTDIR}/okinawa-20041220.t ${WRKSRC}/mkanthydic
@printf '/^EXTRA_DICS\ns/$$/ okinawa-20041220.t/\nwq\n' | \
ed -s ${WRKSRC}/mkanthydic/Makefile.in
.endif
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/anthy
${INSTALL_DATA} ${WRKSRC}/doc/DICUTIL ${PREFIX}/share/doc/anthy
${INSTALL_DATA} ${WRKSRC}/doc/ELISP ${PREFIX}/share/doc/anthy
${INSTALL_DATA} ${WRKSRC}/doc/GUIDE.english ${PREFIX}/share/doc/anthy
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/anthy
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/12/04 03:57:44 taya Exp $
@comment $NetBSD: PLIST,v 1.2 2004/12/28 05:35:29 taya Exp $
bin/anthy-agent
bin/anthy-dic-tool
etc/anthy-conf
@ -22,18 +22,10 @@ share/anthy/noun-variant.depword
share/anthy/noun.depword
share/anthy/typetab
share/anthy/v.depword
${EMACS_LISPPREFIX}/anthy/anthy-azik.el
${EMACS_LISPPREFIX}/anthy/anthy-azik.elc
${EMACS_LISPPREFIX}/anthy/anthy-conf.el
${EMACS_LISPPREFIX}/anthy/anthy-conf.elc
${EMACS_LISPPREFIX}/anthy/anthy-dic.el
${EMACS_LISPPREFIX}/anthy/anthy-dic.elc
${EMACS_LISPPREFIX}/anthy/anthy-isearch.el
${EMACS_LISPPREFIX}/anthy/anthy-isearch.elc
${EMACS_LISPPREFIX}/anthy/anthy.el
${EMACS_LISPPREFIX}/anthy/anthy.elc
${EMACS_LISPPREFIX}/anthy/leim-list.el
${EMACS_LISPPREFIX}/anthy/leim-list.elc
@dirrm ${EMACS_LISPPREFIX}/anthy
share/doc/anthy/DICUTIL
share/doc/anthy/ELISP
share/doc/anthy/GUIDE.english
share/doc/anthy/README
@dirrm share/doc/anthy
@dirrm share/anthy
@dirrm include/anthy

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2004/12/04 03:57:44 taya Exp $
$NetBSD: distinfo,v 1.2 2004/12/28 05:35:29 taya Exp $
SHA1 (anthy-5900.tar.gz) = 2f7cc9d4077d733d88859fc643203b68d35b7308
Size (anthy-5900.tar.gz) = 1566783 bytes
SHA1 (2ch.t) = 0118c98c21420aaeee0bf78b5bb99ede723e194b
Size (2ch.t) = 142344 bytes
SHA1 (patch-2ch-dict) = 72a75e1417b05626a4ad4894b5af30d38f7b03bf
SHA1 (2ch.t) = 2160d7b0079e2c1a14093da968f34e7f8dbc07c2
Size (2ch.t) = 142157 bytes
SHA1 (okinawa-20041220.t) = 2dc67628363dfe087dae4a70ef5517c989ed7644
Size (okinawa-20041220.t) = 145992 bytes

View file

@ -1,13 +0,0 @@
$NetBSD: patch-2ch-dict,v 1.1.1.1 2004/12/04 03:57:44 taya Exp $
--- mkanthydic/Makefile.in.orig 2004-04-02 18:19:46.000000000 +0900
+++ mkanthydic/Makefile.in 2004-04-02 18:17:47.000000000 +0900
@@ -99,7 +99,7 @@
# Files
noinst_SCRIPTS =
-EXTRA_DICS = base.t extra.t
+EXTRA_DICS = base.t extra.t 2ch.t
CANNADIC_DIST = gcanna.ctd gcannaf.ctd
INCLUDES = -I$(top_srcdir)/include
# HOKUTODIC_DIST = hokuto.t