news/tin: Update to 2.6.3

-- 2.6.3 release 20231224 "Banff" --

 018) Florian Weimer <fweimer@redhat.com>
      ADD. fix incompatible pointer types
      FIX. aclocal.m4, configure.[in]

 017) Enrik Berkhan <enrik@tin.org>
      ADD. "COMPRESS DEFLATE" support (RFC 8054)
      ADD. ensure that no TLS implementation can activate compression
      ADD. some more error messages for various TLS issues
      ADD. don't use tls_default_ca_cert_file(3) due to a behavioural
           difference between libretls and libressl
      BUG. typo in configure[.in]
      FIX. init.c, main.c, misc.c, nntplib.c, nntps.c, extern.h, autoconf.hin
           aclocal.m4, configure[.in]

 016) Dennis Grevenstein <dennis.grevenstein@gmail.com>
      ADD. EXIT_*-fallback for NEWS-OS 3.3
      FIX. makecfg.c

 015) Dennis Preiser <dennis@d--p.de>
      ADD. do not interpret \n in editor_format
      ADD. mime encode long header-lines (> 998 octets) if !post_8bit_header
           and warn about long unbroken header-lines otherwise
      ADD. configurable display format of attachments
           (page_mime_format, page_uue_format, attachment_format)
      ADD. new options show_art_score, col_score_neg, col_score_pos
      ADD. avoid fopen()/fclose() overhead in subscribe_pattern()
      ADD. allow up to 64k long lines in posted_info_file
      ADD. make -vZ less verbose (skip Reading messages)
           current output now available via -vvZ
      ADD. move strings to lang.c
      ADD. silence some compiler warnings
      ADD. unset of ranges
      ADD. display umlauts in ssl-certs with OpenSSL and GnuTLS and LibreSSL
           if also lybcrypto is available
      BUG. tls_peer_cert_notbefore()/tls_peer_cert_notafter() used with
           LibreSSL without crypto-lib (from OpenSSL) returns time in UTC
           not localtime
      BUG. with several consecutive soft hyphens, every second one is
           displayed despite suppress_soft_hyphens=ON
      BUG. -vZ output was ugly due to one missing and one superfluous newline
      BUG. tagging articles in group and thread level may grabble the
           screen after reading them and returning to that level if
           art_mark_width = 1
      BUG. crafting a f'up to a non existent group lead to a crash
      BUG. changing hide_uue via 'M'enu in pager missed to recook
           the article
      REM. show_info from manuals, unused t_filter->next
      BUG. fix the memleak in read_cmd_line_options(envargs()) if $TINRC is
           set
      BUG. -I$srcdir/libcanlock/include missing in CHECK_DECL_FLAG
      FIX. active.c, art.c, attrib.c, color.c, config.c, cook.c, filter.c
           group.c, inews.c, init.c, keymap.c, lang.c, main.c, misc.c, newsrc.c
           nntplib.c, nntps.c, nrctbl.c, options_menu.c, page.c, pgp.c, post.c
           read.c, refs.c, rfc2046.c, rfc2047.c, save.c, select.c, signal.c
           tags.c, thread.c, xface.c, extern.h, proto.h, tin.h, tinrc.h
           tnntps.h, tincfg.tbl, tin.[15], configure[.in]

 014) Matt Anton <tin@lv223.org>
      ADD. updated French translation
      FIX. fr.po

 013) Urs Janssen <urs@tin.org>
      BUG. "\x" sequences (x != '\0', 'n') in editor_format got
           replaced by "%x"
      BUG. verification_func undefined with HAVE_LIB_GNUTLS but without DEBUG
      BUG. missing HAVE_MEMMOVE / HAVE_BCOPY guards in nntplib.c
      BUG. without including tin.h we can no longer use _Noreturn in makecfg.c
      BUG. txt_translit was included in binary without HAVE_ICONV
      BUG. timeout counter was not reset on reconnect
      BUG. fix uncritical TOCTOU issue in read_newsrc() and
           open_save_filename()
      BUG. use of potentially uninitialized this_resp instead of respnum
           in strfquote() when calling my_strftime()
      BUG. an unknown Content-Transfer-Encoding was correctly treated as
           binary but without updating Content-Type to
           application/octet-stream (RFC2045 6.4)
      ADD. disallow headers without a name or a name start starts with a dot
           when posting
      ADD. -[zZMN] now note unsubscribed cmd-line groups
      ADD. replace stpwatch.h macros avoiding ftime()
      ADD. do not resend HEAD after ERR_GOODBYE response
      ADD. config.guess, config.sub update
      ADD. version checking during configure for SSL/TLS libraries
      ADD. log end of long multiline responses with -D 1 when not using -v
           (for timestamps)
      ADD. reformat code, remove unnecessary assignments and parameters,
           remove DIRSEP, avoid implicit double negative
      ADD. :port suffix in newsauth, newsrctable and -g
      ADD. cmd. execution via ! for x_body
      ADD. missing fchmod fallback code to write_overview()
      ADD. only log sensitive auth data if running verbose (-vD 1)
      ADD. warn if body contains non printable chars in current locale
      ADD. speedup str_trim(), refine valid_msgid()
      ADD. -t timeout cmd.-line option
      ADD. -vvN / -vvM writes the skipped groups (unset batch_save) to the log
      ADD. allow ISO8859* (without hyphen) as mm_charset in
           my_isprint()-fallback when compiling with -DNO_LOCALE
      ADD. validate_charset() if charset name is read from an article
      ADD. show score in "-D 2" filter output if != 0 (instead of only for
           killed articles)
      ADD. add 'f' / 'F' (post a followup (without quotes)) to thread menu
      ADD. add Content-Language (RFC 3282) evaluation (pager only)
      ADD. GLOBAL_TOGGLE_COLOR ('&') to info-pager (help-page ('h'),
           connection-info ('J') and menu ('M')), posting-history ('W') and
           url-menu ('U')
      ADD. GLOBAL_VERSION ('v') to attachment-menu ('V'), posting-history
           ('W') and url-menu ('U')
      ADD. GLOBAL_TOGGLE_INVERSE_VIDEO ('I') to url-menu ('U') and
           posting-history ('W')
      ADD. make date-parsing more fault tolerant
      ADD. quit early if rcdir doesn't exist and can't be created
      ADD. init backup_article_name just one
      ADD. MOTD to connection-info ('J')
      ADD. configure check for libcrypto when using LibreSSL
      FIX. active.c, art.c, auth.c, config.c, cook.c, debug.c, feed.c, filter.c
           group.c, header.c, heapsort.c, help.c, init.c, keymap.c, lang.c
           mail.c, main.c, makecfg.c, memory.c, misc.c, newsrc.c, nntplib.c
           nntps.c, options_menu.c, page.c, pgp.c, post.c, refs.c, rfc2045.c
           rfc2046.c, rfc2047.c, save.c, screen.c, search.c, select.c, signal.c
           string.c, tcurses.c, thread.c, tmpfile.c, xface.c, parsdate.y
           autoconf.h[in], extern.h, keymap.h, proto.h, rfc2046.h, tin.h
           tinrc.h, tin.1, tin.5, Makefile[.in], configure[.in], config.guess
           config.sub

 012) Thomas E. Dickey <dickey@invisible-island.net>
      BUG. HAVE_LIBINTL_H may get set even when unavailable
      ADD. remove tin.h dependency from makecfg.c
      ADD. update configure macros
      ADD. simplify code
      FIX. aclocal.m4, configure[.in], canlock.c, makecfg.c, Makefile.in

 011) Brad Littlejohn <tyketto@sbcglobal.net>
      Urs Janssen <urs@tin.org>
      BUG. still using dropped alias s_close() instead of close() in some
           code path (i.e. without ENABLE_IPV6 and/or with DECNET).
      FIX. nntplib.c

 010) Toomas Soome <tsoome@me.com>
      ADD. updated Estonian translation
      FIX. et.po
This commit is contained in:
micha 2024-01-17 16:07:19 +00:00
parent 8dd1c02c73
commit 784fd93432
3 changed files with 10 additions and 56 deletions

View File

@ -1,12 +1,10 @@
# $NetBSD: Makefile,v 1.105 2023/11/08 13:20:39 wiz Exp $
# $NetBSD: Makefile,v 1.106 2024/01/17 16:07:19 micha Exp $
DISTNAME= tin-2.6.2
PKGREVISION= 3
DISTNAME= tin-2.6.3
CATEGORIES= news
MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/stable/
MASTER_SITES+= http://ftp.funet.fi/pub/unix/news/tin-unoff/
MASTER_SITES+= https://ftp.funet.fi/pub/unix/news/tin-unoff/
MASTER_SITES+= ftp://ftp.lip6.fr/pub/unix/news/readers/tin-unoff/
MASTER_SITES+= ftp://ftp.cuhk.edu.hk/pub/packages/news/tin/stable/
MASTER_SITES+= ftp://sunsite.icm.edu.pl/pub/unix/news/tin/stable/
EXTRACT_SUFX= .tar.xz
@ -43,6 +41,7 @@ CONFIGURE_ARGS+= --disable-mime-strict-charset
CONFIGURE_ARGS+= --with-defaults-dir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --enable-mh-mail-handling
CONFIGURE_ARGS+= --with-coffee
CONFIGURE_ARGS+= --with-zlib
SUBST_CLASSES+= tin
SUBST_STAGE.tin= pre-configure
@ -62,4 +61,6 @@ post-install:
.include "../../converters/uulib/buildlink3.mk"
.include "../../devel/libidn/buildlink3.mk"
.include "../../devel/pcre/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.34 2023/01/25 18:06:41 micha Exp $
$NetBSD: distinfo,v 1.35 2024/01/17 16:07:19 micha Exp $
BLAKE2s (tin-2.6.2.tar.xz) = 632d2a39bc2ce3f23e0949edad87aa4681eb1ab69b68b4a55e7f7521a6341b3a
SHA512 (tin-2.6.2.tar.xz) = 4c9e0edb3268d57fb89d9d53a90e8a5ba73da7c1da63c834224bed0f763502a7c3dd325351d3e57b1ddcb57494a84228cc38f227c49300b759fad8d112b1cac1
Size (tin-2.6.2.tar.xz) = 1598732 bytes
BLAKE2s (tin-2.6.3.tar.xz) = 5e87dd1dca821810d5f8a7af48b1429f354d14d1588358510fabd9c75e113a7e
SHA512 (tin-2.6.3.tar.xz) = e8b474849e3330475e92b7c578ffe2f29f022303be266d39493e58b7227d9a5ee3915812c1806f52358c07f91d6119810498db906d2da7ffe035feba0e340a42
Size (tin-2.6.3.tar.xz) = 1639192 bytes
SHA1 (patch-Makefile) = c5787ae88d070844b43f56e968d2fab00a8613ad
SHA1 (patch-src_Makefile.in) = 11785ab8fb5391d91ff34981bbb77191f228bed5
SHA1 (patch-src_nntplib.c) = 75a14821af4a01b9f0787411edf1370c5af6da63

View File

@ -1,46 +0,0 @@
$NetBSD: patch-src_nntplib.c,v 1.1 2023/01/25 18:06:41 micha Exp $
Adjust s_close() to close() because of move from stdio to own buffer
implementation.
From upstream:
news://news.tin.org/mailman.1265.1672300926.1791.tin-dev@tin.org
--- src/nntplib.c 2022-12-25 11:00:37 +0000
+++ src/nntplib.c 2022-12-29 07:56:58 +0000
@@ -523,7 +523,7 @@
my_fprintf(stderr, _(txt_connection_to), (char *) inet_ntoa(sock_in.sin_addr));
perror("");
# endif /* HAVE_INET_NTOA */
- (void) s_close(s);
+ (void) close(s);
}
if (x < 0) {
@@ -552,7 +552,7 @@
if (connect(s, (struct sockaddr *) &sock_in) < 0) {
save_errno = errno;
perror("connect");
- (void) s_close(s);
+ (void) close(s);
return -save_errno;
}
@@ -571,7 +571,7 @@
if (connect(s, (struct sockaddr *) &sock_in, sizeof(sock_in)) < 0) {
save_errno = errno;
perror("connect");
- (void) s_close(s);
+ (void) close(s);
return -save_errno;
}
@@ -723,7 +723,7 @@
if (connect(s, (struct sockaddr *) &sdn, sizeof(sdn)) < 0) {
nerror("connect");
- s_close(s);
+ close(s);
return -1;
}