Update to orpie-1.5.0 and add DESTDIR support.
ChangeLog: - Complete rewrite of units implementation, allowing user-defined units and physical constants. - Updated included ocamlgsl bindings to 0.6.0. - Square root of a negative value now returns a complex result. - gcd(), lcd(), and mod() now accept real-valued arguments. - Fix for crash in abbrev mode. - Made a minor Makefile change to correct linking errors under Gentoo (maybe others). - Numerous code cleanups. Calculator code has been better separated from interface code. - Support --sysconfdir configure option. (Anyone packaging for the filesystem hierarchy standard will now need to use something like "./configure --prefix=/usr --sysconfdir=/etc".) - Implemented entry of most fundamental physical constants. - Fixed incorrect error message regarding deprecated extended_enter command
This commit is contained in:
parent
2e36f667a2
commit
788109ef92
4 changed files with 17 additions and 36 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.2 2007/04/29 21:51:52 tnn Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2007/09/13 12:10:39 tnn Exp $
|
||||
#
|
||||
|
||||
DISTNAME= orpie-1.4.3
|
||||
DISTNAME= orpie-1.5.0
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://www.eecs.umich.edu/~pelzlpj/orpie/
|
||||
|
||||
|
@ -9,6 +9,7 @@ MAINTAINER= tnn@NetBSD.org
|
|||
HOMEPAGE= http://www.eecs.umich.edu/~pelzlpj/orpie/
|
||||
COMMENT= Curses-based reverse polish notation (RPN) calculator
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
GNU_CONFIGURE= YES
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/04/29 20:01:45 tnn Exp $
|
||||
$NetBSD: distinfo,v 1.2 2007/09/13 12:10:40 tnn Exp $
|
||||
|
||||
SHA1 (orpie-1.4.3.tar.gz) = 068fd06467b20dea54c230933e2ee391cebe2616
|
||||
RMD160 (orpie-1.4.3.tar.gz) = 81a1cf45ea761dd67ca3eae75fa8ff670c2c6989
|
||||
Size (orpie-1.4.3.tar.gz) = 356721 bytes
|
||||
SHA1 (orpie-1.5.0.tar.gz) = f1507b17b5ff545a71b24d1d3130c0fb374202d4
|
||||
RMD160 (orpie-1.5.0.tar.gz) = f3a39c507e6c0b8d7710d0066c48c9c0c31b10ed
|
||||
Size (orpie-1.5.0.tar.gz) = 370669 bytes
|
||||
SHA1 (patch-aa) = 2c2afd826a8efcc31bd015188ed9ca028fdaf199
|
||||
SHA1 (patch-ab) = 32912430fe15b5125f5ae1cbd6131d8d16cd2645
|
||||
SHA1 (patch-ac) = 13c3059b24997214af57f12da90b6cf03c5877ee
|
||||
SHA1 (patch-ac) = ad27b3606d3037bc65046c2a577a1247e2c4c277
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2007/04/29 20:01:45 tnn Exp $
|
||||
|
||||
--- gsl/mlgsl_error.c.orig 2007-04-24 16:06:49.000000000 +0200
|
||||
+++ gsl/mlgsl_error.c
|
||||
@@ -43,7 +43,7 @@ void ml_gsl_raise_exn(int gsl_errno)
|
||||
exn_arg = alloc_small(2, 0);
|
||||
Store_field(exn_arg, 0, Val_int(conv_err_code(gsl_errno)));
|
||||
Store_field(exn_arg, 1, copy_string(ml_gsl_exn_msg));
|
||||
- CAMLreturn(raise_with_arg(*ml_gsl_exn, exn_arg));
|
||||
+ raise_with_arg(*ml_gsl_exn, exn_arg);
|
||||
}
|
||||
|
||||
static void ml_gsl_error_handler(const char *reason, const char *file,
|
|
@ -1,20 +1,14 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2007/04/29 20:01:45 tnn Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2007/09/13 12:10:40 tnn Exp $
|
||||
|
||||
--- Makefile.in.orig 2005-10-30 03:50:43.000000000 +0100
|
||||
--- Makefile.in.orig 2007-09-13 08:35:16.000000000 +0200
|
||||
+++ Makefile.in
|
||||
@@ -148,13 +148,8 @@ version.ml: Makefile
|
||||
|
||||
install-indep:
|
||||
mkdir -p $(BINDIR)
|
||||
- if test "$(prefix)" = "/usr"; then \
|
||||
- mkdir -p $(DESTDIR)/etc; \
|
||||
- install -m 644 orpierc $(DESTDIR)/etc; \
|
||||
- else \
|
||||
- mkdir -p $(DESTDIR)/$(prefix)/etc; \
|
||||
- install -m 644 orpierc $(DESTDIR)/$(prefix)/etc; \
|
||||
- fi
|
||||
+ mkdir -p $(DESTDIR)/$(prefix)/share/examples/orpie; \
|
||||
+ install -m 644 orpierc $(DESTDIR)/$(prefix)/share/examples/orpie; \
|
||||
@@ -151,7 +151,8 @@ install-indep:
|
||||
mkdir -p $(DESTDIR)/$(sysconfdir)
|
||||
mkdir -p $(MANDIR)/man1
|
||||
mkdir -p $(MANDIR)/man5
|
||||
- install -m 644 orpierc $(DESTDIR)/$(sysconfdir)
|
||||
+ mkdir -p $(DESTDIR)$(PREFIX)/share/examples/orpie
|
||||
+ install -m 644 orpierc $(DESTDIR)$(PREFIX)/share/examples/orpie
|
||||
install -m 644 doc/orpie.1 $(MANDIR)/man1/orpie.1
|
||||
install -m 644 doc/orpie-curses-keys.1 $(MANDIR)/man1/orpie-curses-keys.1
|
||||
install -m 644 doc/orpierc.5 $(MANDIR)/man5/orpierc.5
|
||||
|
|
Loading…
Reference in a new issue