Fix rpath. Bump revision.

This commit is contained in:
joerg 2016-03-26 23:45:21 +00:00
parent b59e1a3910
commit 788fdab01d
3 changed files with 34 additions and 5 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.5 2016/02/25 13:37:46 jperkin Exp $
# $NetBSD: Makefile,v 1.6 2016/03/26 23:45:21 joerg Exp $
DISTNAME?= ${MESA_DISTNAME}
PKGNAME= MesaLib7-${MESA_PKGVERSION}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MESA_SITES}
EXTRACT_SUFX= .tar.bz2
@ -29,6 +29,8 @@ CONFLICTS+= xf86driproto<2.0.4
PLIST_VARS= dri nodri
BUILDLINK_PASSTHRU_RPATHDIRS+= ${PREFIX}/MesaLib7/lib
PKGCONFIG_OVERRIDE+= src/mesa/drivers/dri/dri.pc.in
PKGCONFIG_OVERRIDE+= src/mesa/gl.pc.in
PKGCONFIG_OVERRIDE+= src/mesa/osmesa.pc.in

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2015/11/03 21:33:51 agc Exp $
$NetBSD: distinfo,v 1.3 2016/03/26 23:45:21 joerg Exp $
SHA1 (Mesa-7.11.2/MesaLib-7.11.2.tar.bz2) = 5981ac2de8438e5f4a1f3561f2044d700c5f0de9
RMD160 (Mesa-7.11.2/MesaLib-7.11.2.tar.bz2) = 656ded1db6c1f6fdd15a3f2cdee1b895d393bcea
@ -6,7 +6,7 @@ SHA512 (Mesa-7.11.2/MesaLib-7.11.2.tar.bz2) = f9f93aeb5ba3e4f0cdd7041a7bba6cd18d
Size (Mesa-7.11.2/MesaLib-7.11.2.tar.bz2) = 6257280 bytes
SHA1 (patch-af) = da0bd412b81d4b826b6d9b4bb8d98ca1fe0006ba
SHA1 (patch-bin_mklib) = 8c54bf5382541cab9d971b0e0e627035db1af468
SHA1 (patch-configure.ac) = 0e3f9a1f21ba3a50161312683e9a0ad36f9f3e61
SHA1 (patch-configure.ac) = a35dabc387d78282b3eadf3be98380cb84b796d7
SHA1 (patch-include_GL_gl.h) = a97ab309556c78d818d0b8bd867b5f2412c141b0
SHA1 (patch-src_gallium_auxiliary_util_u__atomic.h) = 68ba9694aca506add2aa96a6892a7227481c2c11
SHA1 (patch-src_gallium_include_pipe_p__config.h) = 34f4c2a033dd7a494dd3f51db407002a3388f84e

View file

@ -1,4 +1,4 @@
$NetBSD: patch-configure.ac,v 1.1 2015/04/05 17:01:37 tnn Exp $
$NetBSD: patch-configure.ac,v 1.2 2016/03/26 23:45:21 joerg Exp $
--- configure.ac.orig 2011-10-15 00:43:58.000000000 +0000
+++ configure.ac
@ -11,3 +11,30 @@ $NetBSD: patch-configure.ac,v 1.1 2015/04/05 17:01:37 tnn Exp $
;;
cygwin*)
DEFINES="$DEFINES -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER"
@@ -1430,7 +1432,7 @@ if test "x$enable_glu" = xyes; then
GLU_PC_LIB_PRIV="-lm"
if test "$enable_static" = no; then
GLU_LIB_DEPS="-lm"
- GLU_MESA_DEPS='-l$(GL_LIB)'
+ GLU_MESA_DEPS='$(COMPILER_RPATH_FLAG)$(prefix)/lib -l$(GL_LIB)'
else
GLU_LIB_DEPS=""
GLU_MESA_DEPS=""
@@ -1509,7 +1511,7 @@ if test "x$enable_glw" = xyes; then
# If static, empty GLW_LIB_DEPS and add libs for programs to link
GLW_PC_LIB_PRIV="$GLW_PC_LIB_PRIV"
if test "$enable_static" = no; then
- GLW_MESA_DEPS='-l$(GL_LIB)'
+ GLW_MESA_DEPS='$(COMPILER_RPATH_FLAG)$(prefix)/lib -l$(GL_LIB)'
GLW_LIB_DEPS="$GLW_LIB_DEPS"
else
APP_LIB_DEPS="$APP_LIB_DEPS $GLW_LIB_DEPS"
@@ -1574,7 +1576,7 @@ if test "x$enable_glut" = xyes; then
# If static, empty GLUT_LIB_DEPS and add libs for programs to link
if test "$enable_static" = no; then
- GLUT_MESA_DEPS='-l$(GLU_LIB) -l$(GL_LIB)'
+ GLUT_MESA_DEPS='$(COMPILER_RPATH_FLAG)$(prefix)/lib -l$(GLU_LIB) -l$(GL_LIB)'
else
APP_LIB_DEPS="$APP_LIB_DEPS $GLUT_LIB_DEPS"
GLUT_LIB_DEPS=""