Update pciutils to 3.5.0.
2016-05-19 Martin Mares <mj@ucw.cz> * Released as 3.5.0. * New capabilities decoded: Downstream Port Containment, Precision Time Measurement. Thanks to Keith Busch and Jonathan Yong. * Domain numbers extended to 31 bits. This will be used by the Linux kernel on some machines in near future. * Enhanced allocation regions are now decoded on Linux. * The NetBSD back-end supports PCIe extended configuration space. * Updated pci.ids to the current snapshot of the database.
This commit is contained in:
parent
d686d03275
commit
78a8936b9a
4 changed files with 12 additions and 29 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.29 2016/04/14 23:21:45 khorben Exp $
|
||||
# $NetBSD: Makefile,v 1.30 2016/05/20 04:23:56 msaitoh Exp $
|
||||
|
||||
DISTNAME= pciutils-3.4.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= pciutils-3.5.0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/ \
|
||||
ftp://ftp.kernel.org/pub/software/utils/pciutils/
|
||||
|
|
|
@ -1,11 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.20 2016/02/15 00:51:13 msaitoh Exp $
|
||||
$NetBSD: distinfo,v 1.21 2016/05/20 04:23:56 msaitoh Exp $
|
||||
|
||||
SHA1 (pciutils-3.4.1.tar.gz) = e1d214c27ac11d4b397c607acc16baffff157ddd
|
||||
RMD160 (pciutils-3.4.1.tar.gz) = cc2149d5017e61c48cab1ab3ae7da0c20c79db2b
|
||||
SHA512 (pciutils-3.4.1.tar.gz) = 41c2c05952648ec9eb637c41419d5580c24f6479d90bbc0c0b09ec50cb228c3a2db7bd4afedbc199e8e4e49fe6052f638cb777b09b212ec0ee4b493497f4183e
|
||||
Size (pciutils-3.4.1.tar.gz) = 398904 bytes
|
||||
SHA1 (patch-aa) = f24ba8f6c55ef766abe5aeaa49cb53ceec699dbb
|
||||
SHA1 (pciutils-3.5.0.tar.gz) = 74828d9b81f935bfa9bed32528c5a8c26ab20128
|
||||
RMD160 (pciutils-3.5.0.tar.gz) = 6187a37acb00fa329983e0ff471e7468b9fad018
|
||||
SHA512 (pciutils-3.5.0.tar.gz) = d841da9bf7d7d67d60257c7d42d7ff5e38bc232098b185657a171561b42d08abd4c0a22fbed19e857db08a39ac9fc929dd35e1187e6da02cc8a45a0481051288
|
||||
Size (pciutils-3.5.0.tar.gz) = 412990 bytes
|
||||
SHA1 (patch-aa) = 38975ffa00d8fea74351f6d49bd4c32013f48734
|
||||
SHA1 (patch-ab) = 881db39792c9d72f527438e2b475ac2ea842b536
|
||||
SHA1 (patch-ac) = 4b90e99c051391b9cd3a6c1f5781f41b4a855c29
|
||||
SHA1 (patch-ad) = bfe9069e96fd46798afec73c93ad71db3a0e0e37
|
||||
SHA1 (patch-lib_nbsd_libpci.c) = 1fb1f3bddf939fa9c663f16327fa7d7f39c0d354
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: patch-aa,v 1.13 2016/02/15 00:51:13 msaitoh Exp $
|
||||
|
||||
--- Makefile.orig 2016-01-03 23:19:13.000000000 +0900
|
||||
+++ Makefile 2016-02-12 18:11:55.383839862 +0900
|
||||
--- Makefile.orig 2016-05-20 00:43:00.000000000 +0900
|
||||
+++ Makefile 2016-05-20 13:10:34.284738340 +0900
|
||||
@@ -1,8 +1,7 @@
|
||||
# Makefile for The PCI Utilities
|
||||
# (c) 1998--2016 Martin Mares <mj@ucw.cz>
|
||||
|
@ -10,8 +8,8 @@ $NetBSD: patch-aa,v 1.13 2016/02/15 00:51:13 msaitoh Exp $
|
|||
-CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
|
||||
+CFLAGS=-Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
|
||||
|
||||
VERSION=3.4.1
|
||||
DATE=2016-01-03
|
||||
VERSION=3.5.0
|
||||
DATE=2016-05-19
|
||||
@@ -13,7 +12,7 @@
|
||||
CROSS_COMPILE=
|
||||
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-lib_nbsd_libpci.c,v 1.2 2015/12/29 04:04:31 dholland Exp $
|
||||
|
||||
--- lib/nbsd-libpci.c.orig 2011-01-08 06:04:28.000000000 +0900
|
||||
+++ lib/nbsd-libpci.c 2015-11-12 17:45:08.000000000 +0900
|
||||
@@ -71,7 +71,7 @@ nbsd_read(struct pci_dev *d, int pos, by
|
||||
if (!(len == 1 || len == 2 || len == 4))
|
||||
return pci_generic_block_read(d, pos, buf, len);
|
||||
|
||||
- if (pos >= 256)
|
||||
+ if (pos >= 4096)
|
||||
return 0;
|
||||
|
||||
shift = 8*(pos % 4);
|
Loading…
Reference in a new issue