Don't try to strip scripts while installing. Fixes first half of
PR pkg/4989 by David Brownlee.
This commit is contained in:
parent
64713eaf62
commit
7917618766
1 changed files with 24 additions and 0 deletions
24
devel/cvs/patches/patch-ad
Normal file
24
devel/cvs/patches/patch-ad
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- contrib/Makefile.in.orig Fri Feb 13 17:39:12 1998
|
||||
+++ contrib/Makefile.in Fri Feb 13 17:41:51 1998
|
||||
@@ -43,7 +43,7 @@
|
||||
# Use cp if you don't have install.
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
-INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
+INSTALL_SCRIPT = ${INSTALL} -m 0555
|
||||
|
||||
DISTFILES = \
|
||||
ChangeLog README .cvsignore intro.doc \
|
||||
@@ -89,10 +89,10 @@
|
||||
$(INSTALL_DATA) $(srcdir)/$$f $(libdir)/cvs/contrib/$$f; \
|
||||
done
|
||||
for f in $(CONTRIB_PROGS) ; do\
|
||||
- $(INSTALL_PROGRAM) $$f $(libdir)/cvs/contrib/$$f; \
|
||||
+ $(INSTALL_SCRIPT) $$f $(libdir)/cvs/contrib/$$f; \
|
||||
done
|
||||
for f in $(PROGS) ; do\
|
||||
- $(INSTALL_PROGRAM) $$f $(bindir)/$$f; \
|
||||
+ $(INSTALL_SCRIPT) $$f $(bindir)/$$f; \
|
||||
done
|
||||
.PHONY: install
|
||||
|
Loading…
Reference in a new issue