Update to 2.63. From the changelog:

* Set cookies HttpOnly.
* Typo. Closes: #[497003](http://bugs.debian.org/497003)
* Ignore failure to install files into /etc, in case install is
    running as non-root.
* Work around perl $\_ scoping nonsense that caused breakage when loading
    external plugins.
* style.css: Add missing semicolon. Closes:
    #[497176](http://bugs.debian.org/497176)
* filecheck: Fall back to testing for binary or plain text files
    if no mime type is detected.
* table: Support header=column to make the table header be the first
    column of the data. (AlexandreDupas)
* For fine control over what characters are allowed, unescaped in
    source filenames, the wiki\_file\_chars setting is added. For
    example, set to "-[:alnum:]+/.\_" to disable colons from being
    used in source files (which can cause troubl om Windows).
* po/Makefile: update po files when the pot file has changed.
    Closes: #[497951](http://bugs.debian.org/497951)
* editpage: New core plugin factoring out page editing to allow
    disabling it if desired.
This commit is contained in:
schmonz 2008-09-09 17:19:13 +00:00
parent 2f2c12670a
commit 794d47c6a2
3 changed files with 22 additions and 22 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.18 2008/09/04 15:34:30 schmonz Exp $
# $NetBSD: Makefile,v 1.19 2008/09/09 17:19:13 schmonz Exp $
#
DISTNAME= ikiwiki_2.62.1
DISTNAME= ikiwiki_2.63
PKGNAME= ${DISTNAME:S/_/-/}
CATEGORIES= www textproc
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/i/ikiwiki/}
@ -88,7 +88,7 @@ SUBST_FILES.makefile= Makefile.PL
SUBST_SED.makefile+= -e 's,share/man/man,${PKGMANDIR}/man,g'
PKG_SYSCONFSUBDIR= ${PKGBASE}
EGDIR= $(PREFIX)/share/examples/${PKGBASE}
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
CONF_FILES+= ${EGDIR}/auto.setup ${PKG_SYSCONFDIR}/auto.setup
CONF_FILES+= ${EGDIR}/wikilist ${PKG_SYSCONFDIR}/wikilist

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.9 2008/09/04 15:34:30 schmonz Exp $
$NetBSD: distinfo,v 1.10 2008/09/09 17:19:13 schmonz Exp $
SHA1 (ikiwiki_2.62.1.tar.gz) = a03976b0828bdf2c864116cdd9d850b5212234d8
RMD160 (ikiwiki_2.62.1.tar.gz) = fa9dd64d7308c659e172cd2b1470936d6439e8bb
Size (ikiwiki_2.62.1.tar.gz) = 949723 bytes
SHA1 (patch-aa) = 50987d0a55426b79c88dfa0cb5b30ad370e942a5
SHA1 (ikiwiki_2.63.tar.gz) = f32d28ca58cb79b3a8463bf22cd79b72f2bb052f
RMD160 (ikiwiki_2.63.tar.gz) = 58faa7c63dedce4de1df20610d37da1b461ac0ab
Size (ikiwiki_2.63.tar.gz) = 961932 bytes
SHA1 (patch-aa) = 3bc1bca3c6ef5e986f60e40ce2b61afe0142d7da

View file

@ -1,17 +1,17 @@
$NetBSD: patch-aa,v 1.6 2008/09/04 15:34:30 schmonz Exp $
$NetBSD: patch-aa,v 1.7 2008/09/09 17:19:13 schmonz Exp $
--- Makefile.PL.orig 2008-08-27 15:25:08.000000000 -0400
--- Makefile.PL.orig 2008-09-08 11:51:42.000000000 -0400
+++ Makefile.PL
@@ -50,9 +50,9 @@ extra_clean:
$(MAKE) -C po clean
@@ -95,9 +95,9 @@ extra_install:
# These might fail if a regular user is installing into a home
# directory.
- -install -d $(DESTDIR)/etc/ikiwiki
- -install -m 0644 wikilist $(DESTDIR)/etc/ikiwiki
- -install -m 0644 auto.setup $(DESTDIR)/etc/ikiwiki
+ -install -d $(DESTDIR)$(PREFIX)/share/examples/ikiwiki
+ -install -m 0644 wikilist $(DESTDIR)$(PREFIX)/share/examples/ikiwiki
+ -install -m 0644 auto.setup $(DESTDIR)$(PREFIX)/share/examples/ikiwiki
}
}
extra_install:
- install -d $(DESTDIR)/etc/ikiwiki
- install -m 0644 wikilist $(DESTDIR)/etc/ikiwiki
- install -m 0644 auto.setup $(DESTDIR)/etc/ikiwiki
+ install -d $(DESTDIR)$(PREFIX)/share/examples/ikiwiki
+ install -m 0644 wikilist $(DESTDIR)$(PREFIX)/share/examples/ikiwiki
+ install -m 0644 auto.setup $(DESTDIR)$(PREFIX)/share/examples/ikiwiki
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
for dir in `cd underlays && find . -follow -type d ! -regex '.*\.svn.*'`; do \