Changes 8.3.11:

* Enforce restrictions in plperl using an opmask applied to the whole
  interpreter, instead of using "Safe.pm"
* Prevent PL/Tcl from executing untrustworthy code from pltcl_modules
* Fix possible crash if a cache reset message is received during
  rebuild of a relcache entry
* Apply per-function GUC settings while running the language
  validator for the function
* Do not allow an unprivileged user to reset superuser-only parameter
  settings
* Avoid possible crash during backend shutdown if shutdown occurs
  when a CONTEXT addition would be made to log entries
* Ensure the archiver process responds to changes in archive_command
  as soon as possible
* Update pl/perl's "ppport.h" for modern Perl versions
* Fix assorted memory leaks in pl/python
* Prevent infinite recursion in psql when expanding a variable that
  refers to itself
* Fix psql's \copy to not add spaces around a dot within \copy
  (select ...)
* Fix unnecessary "GIN indexes do not support whole-index scans"
  errors for unsatisfiable queries using "contrib/intarray" operators
* Ensure that "contrib/pgstattuple" functions respond to cancel
  interrupts promptly
* Make server startup deal properly with the case that shmget()
  returns EINVAL for an existing shared memory segment
* Avoid possible crashes in syslogger process on Windows
* Deal more robustly with incomplete time zone information in the
  Windows registry
* Update the set of known Windows time zone names
* Update time zone data files to tzdata release 2010j for DST law
  changes in Argentina, Australian Antarctic, Bangladesh, Mexico,
  Morocco, Pakistan, Palestine, Russia, Syria, Tunisia; also
  historical corrections for Taiwan.
  Also, add PKST (Pakistan Summer Time) to the default set of
  timezone abbreviations.
This commit is contained in:
adam 2010-05-20 12:36:28 +00:00
parent 7a27e9e5e4
commit 795ad22c0f
6 changed files with 38 additions and 14 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.14 2010/04/15 03:25:05 taca Exp $
# $NetBSD: Makefile,v 1.15 2010/05/20 12:36:28 adam Exp $
PKGNAME= postgresql83-client-${BASE_VERS}
PKGREVISION= 1
COMMENT= PostgreSQL database client programs
PKG_DESTDIR_SUPPORT= user-destdir

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.3 2010/01/17 12:02:11 wiz Exp $
# $NetBSD: buildlink3.mk,v 1.4 2010/05/20 12:36:28 adam Exp $
.include "../../mk/bsd.fast.prefs.mk"
@ -11,10 +11,10 @@ BUILDLINK_API_DEPENDS.postgresql83-client+= postgresql83-client>=8.3.0
BUILDLINK_ABI_DEPENDS.postgresql83-client?= postgresql83-client>=8.3.9nb1
BUILDLINK_PKGSRCDIR.postgresql83-client?= ../../databases/postgresql83-client
. if defined(PG_SUBPREFIX) && !empty(PG_SUBPREFIX)
.if defined(PG_SUBPREFIX) && !empty(PG_SUBPREFIX)
BUILDLINK_INCDIRS.postgresql83-client?= ${PG_SUBPREFIX}/include
BUILDLINK_LIBDIRS.postgresql83-client?= ${PG_SUBPREFIX}/lib
. endif
.endif
# This variable contains the libraries need to link most clients.
BUILDLINK_LDADD.postgresql83-client= -lpq ${BUILDLINK_LDADD.gettext}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.10 2010/04/12 09:53:50 adam Exp $
@comment $NetBSD: PLIST,v 1.11 2010/05/20 12:36:28 adam Exp $
${PG_SUBPREFIX}bin/postgres
${PG_SUBPREFIX}bin/postmaster
${PG_SUBPREFIX}lib/postgresql/ascii_and_mic.la
@ -139,6 +139,7 @@ ${PG_SUBPREFIX}share/postgresql/timezone/America/Asuncion
${PG_SUBPREFIX}share/postgresql/timezone/America/Atka
${PG_SUBPREFIX}share/postgresql/timezone/America/Atikokan
${PG_SUBPREFIX}share/postgresql/timezone/America/Bahia
${PG_SUBPREFIX}share/postgresql/timezone/America/Bahia_Banderas
${PG_SUBPREFIX}share/postgresql/timezone/America/Barbados
${PG_SUBPREFIX}share/postgresql/timezone/America/Belem
${PG_SUBPREFIX}share/postgresql/timezone/America/Belize
@ -276,6 +277,7 @@ ${PG_SUBPREFIX}share/postgresql/timezone/America/Yellowknife
${PG_SUBPREFIX}share/postgresql/timezone/Antarctica/Casey
${PG_SUBPREFIX}share/postgresql/timezone/Antarctica/Davis
${PG_SUBPREFIX}share/postgresql/timezone/Antarctica/DumontDUrville
${PG_SUBPREFIX}share/postgresql/timezone/Antarctica/Macquarie
${PG_SUBPREFIX}share/postgresql/timezone/Antarctica/Mawson
${PG_SUBPREFIX}share/postgresql/timezone/Antarctica/McMurdo
${PG_SUBPREFIX}share/postgresql/timezone/Antarctica/Palmer

View file

@ -1,4 +1,11 @@
# $NetBSD: Makefile.common,v 1.11 2010/04/23 16:03:24 adam Exp $
# $NetBSD: Makefile.common,v 1.12 2010/05/20 12:36:28 adam Exp $
#
# used by databases/postgresql83-adminpack/Makefile
# used by databases/postgresql83-client/Makefile
# used by databases/postgresql83-plperl/Makefile
# used by databases/postgresql83-plpython/Makefile
# used by databases/postgresql83-pltcl/Makefile
# used by databases/postgresql83-server/Makefile
#
# This Makefile fragment is included by all PostgreSQL packages built from
# the main sources of the PostgreSQL distribution except jdbc-postgresql.
@ -35,7 +42,7 @@ PATCHDIR?= ${.CURDIR}/../postgresql83/patches
# DIST_VERS version number on the postgresql distfile
# BASE_VERS pkgsrc-mangled version number (convert pl -> .)
# Note: Do not forget jdbc-postgresql83 when updating version
DIST_VERS?= 8.3.10
DIST_VERS?= 8.3.11
BASE_VERS?= ${DIST_VERS}
BUILDLINK_API_DEPENDS.postgresql83-client+= postgresql83-client>=${BASE_VERS}
@ -110,14 +117,14 @@ FILES_SUBST+= PG_PREFIX=${PG_PREFIX:Q}
post-extract:
cp -f ${COMMON_FILESDIR}/Makefile.custom ${WRKSRC}/src/Makefile.custom
cp -f ${COMMON_FILESDIR}/Makefile.libtool ${WRKSRC}/src/Makefile.shlib
.if !empty(USE_LIBLTDL:M[yY][eE][sS])
. if !empty(USE_LIBLTDL:M[yY][eE][sS])
template=${PG_TEMPLATE.${OPSYS}:Q}
cp -f ${COMMON_FILESDIR}/dynloader-ltdl.h \
${WRKSRC}/src/backend/port/dynloader/${PG_TEMPLATE.${OPSYS}:Q}.h
${ECHO} "static int dummy = 0;" \
> ${WRKSRC}/src/backend/port/dynloader/${PG_TEMPLATE.${OPSYS}:Q}.c
fi
.endif
. endif
touch ${WRKSRC}/src/template/dragonfly
cp ${WRKSRC}/src/backend/port/dynloader/freebsd.c \
${WRKSRC}/src/backend/port/dynloader/dragonfly.c

View file

@ -1,11 +1,12 @@
$NetBSD: distinfo,v 1.11 2010/04/12 09:53:50 adam Exp $
$NetBSD: distinfo,v 1.12 2010/05/20 12:36:28 adam Exp $
SHA1 (postgresql-8.3.10.tar.bz2) = 2ad430f4349eb42fbfe21a6a80a493f4068b519e
RMD160 (postgresql-8.3.10.tar.bz2) = 12bb4ac6d0b0e53534582c7e4092bf91092e9345
Size (postgresql-8.3.10.tar.bz2) = 14181794 bytes
SHA1 (postgresql-8.3.11.tar.bz2) = de3d768c66e832336465672de6f33924441bf3f2
RMD160 (postgresql-8.3.11.tar.bz2) = 606f64235b2d48df0a26b46863fc76f94b32abbb
Size (postgresql-8.3.11.tar.bz2) = 14217781 bytes
SHA1 (patch-aa) = aeeeaafb38e75d8e8f6639280e997ba4c905b45f
SHA1 (patch-ab) = 7bf5635b0b93c3c0d33acd4e122e102c92ce7b76
SHA1 (patch-ac) = 8e3a7021fdd01810d4ebcbd20002b28164b22279
SHA1 (patch-ad) = fb75df841bbcc25e840ed9c2fed59232d7189200
SHA1 (patch-af) = fcb43276c1f3349f62acfc37ac0bd6ccaae96f29
SHA1 (patch-ag) = 402d5d211af99efdfa35677299c97e91e14ed85d
SHA1 (patch-ah) = 3640573195f66a46c37d9fca2648d6be39f5593b

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ad,v 1.4 2010/05/20 12:36:28 adam Exp $
--- src/pl/plperl/GNUmakefile.orig 2010-05-20 07:51:50.000000000 +0000
+++ src/pl/plperl/GNUmakefile
@@ -53,9 +53,7 @@ PSQLDIR = $(bindir)
include $(top_srcdir)/src/Makefile.shlib
-all: all-lib
-
-plperl.o: plperl_opmask.h
+all: plperl_opmask.h all-lib
plperl_opmask.h: plperl_opmask.pl
$(PERL) $< $@