Update databases/libzdb to version 3.2.3.
Pkgsrc changes: * More patching of isxxxx() uses to u_char. Upstream changes: Version 3.2.3 ------------- * New: Provide better error reporting if a Connection cannot be obtained from the Connection Pool by introducing the method ConnectionPool_getConnectionOrException(). In C++ the exception thrown now contains the actual cause instead of a generic error. * Fix: In C++ guard against stopping the Connection Pool with active Connections. I.e. all Connections should be returned to the pool before explicitly attempting to stop the pool. This is due to how C++ destructors are called at scope end; if there is a reference to a live Connection object after the pool is stopped it might cause a dealloc sequence problem. * Fix: Issue #50 where unit test 5 could fail for MariaDB because mysql_stmt_affected_rows() only returns actual affected rows, not matched rows which MySQL does. * Fix: plus other minor improvements and fixes
This commit is contained in:
parent
d86dde7761
commit
79ad8d2cc9
3 changed files with 19 additions and 11 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.29 2022/10/28 18:25:00 he Exp $
|
||||
# $NetBSD: Makefile,v 1.30 2022/10/28 18:39:24 he Exp $
|
||||
|
||||
DISTNAME= libzdb-3.2.2
|
||||
PKGREVISION= 8
|
||||
DISTNAME= libzdb-3.2.3
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.tildeslash.com/libzdb/dist/
|
||||
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.10 2022/10/28 18:25:00 he Exp $
|
||||
$NetBSD: distinfo,v 1.11 2022/10/28 18:39:24 he Exp $
|
||||
|
||||
BLAKE2s (libzdb-3.2.2.tar.gz) = 9df58f68d011a948e1de1a90c74665a89cd61d63ebe1b223adfc588e859d6401
|
||||
SHA512 (libzdb-3.2.2.tar.gz) = 1e732f8785322e0369de16a8100c9467e96ad1ca4eee31e8bfc349f4f17d4cc237a691addc060a66e1b46bcfeb99c3aed07b1d5dbe20e70fde4ffbf35dbea2eb
|
||||
Size (libzdb-3.2.2.tar.gz) = 752292 bytes
|
||||
SHA1 (patch-src_system_Time.c) = 24f69ea591ce6865113c1d1a1cb85cf997f7aab0
|
||||
BLAKE2s (libzdb-3.2.3.tar.gz) = 6f8b72d27a90180c4241389852c3bd1f5905c575db6644155810382cfb60ae4c
|
||||
SHA512 (libzdb-3.2.3.tar.gz) = 3cf0641a7aabf91fa9bc7ed93bce6fa3e692cad309086e3f899ede443ffdd84ed20dda38fbc48764733537cdc105ae7e555a23cf7bc9b8f99e233787e0271e29
|
||||
Size (libzdb-3.2.3.tar.gz) = 771263 bytes
|
||||
SHA1 (patch-src_system_Time.c) = e24510cf6acc9f3df4b344a2c3d09f5ebdef729b
|
||||
SHA1 (patch-src_util_Str.c) = 81ff5e539772470a9e03029ef4e0cf48e9751b6e
|
||||
SHA1 (patch-src_zdbpp.h) = c1dcdc7cea4ed55408107cb3e794ba38430ee4ae
|
||||
SHA1 (patch-test_pool.c) = c96b47dc723b7fb7bf5e02cd3cdec49cb66d3656
|
||||
|
|
|
@ -1,10 +1,19 @@
|
|||
$NetBSD: patch-src_system_Time.c,v 1.1 2022/10/28 18:25:01 he Exp $
|
||||
$NetBSD: patch-src_system_Time.c,v 1.2 2022/10/28 18:39:25 he Exp $
|
||||
|
||||
Fix one more pair of isxxxx() uses by casting arg to u_char.
|
||||
Fix uses of isxxxx() by casting arg to u_char.
|
||||
|
||||
--- src/system/Time.c.orig 2020-03-31 22:57:32.000000000 +0000
|
||||
+++ src/system/Time.c
|
||||
@@ -290,9 +290,9 @@ yy10:
|
||||
@@ -147,7 +147,7 @@ static inline int _a2i(const char *a, in
|
||||
}
|
||||
|
||||
static inline int _m2i(const char m[static 3]) {
|
||||
- char month[3] = {[0] = tolower(m[0]), [1] = tolower(m[1]), [2] = tolower(m[2])};
|
||||
+ char month[3] = {[0] = tolower((u_char)m[0]), [1] = tolower((u_char)m[1]), [2] = tolower((u_char)m[2])};
|
||||
static char *months = "janfebmaraprmayjunjulaugsepoctnovdec";
|
||||
for (int i = 0; i < 34; i += 3) {
|
||||
if (memcmp(months + i, month, 3) == 0)
|
||||
@@ -318,9 +318,9 @@ yy9:
|
||||
{ // Timezone: +-HH:MM, +-HH or +-HHMM is offset from UTC in seconds
|
||||
if (have_time) { // Only set timezone if we have parsed time
|
||||
tm.TM_GMTOFF = _a2i(token + 1, 2) * 3600;
|
||||
|
|
Loading…
Reference in a new issue