Update to 20080128 snapshot. Quite a few bugs have been fixed since the
0.14.1 release (which I found to have some annoying bugs/quirks myself, anyway). The ChangeLog is extensive, so check it out for a full list--some important changes follow below. While here, install the provided contrib helper scripts. The bash dependency is OK, as git depends on it anyway. In that spirit, add a dependency on devel/stgit-base, as this is useless without it. Also, install examples in share/examples/stgit as per convention. Refactor --diff-opts handling Lots of commands take a -O/--diff-opts flag, and they all handle it identically. So break that out into a library function. Don't keep old committer when rewriting a commit replace "git repo-config" usage by "git config" This is necessary since "git repo-config" will be removed soon. Fix "stg edit --sign" It worked in 0.14, but was broken some time after the release. Make "stg goto" subdirectory safe This is not specific to "stg goto" -- it affects all commands that use the new infrastructure. (But of those, only goto and coalesce were subdirectory unsafe.) Make "stg commit" fancier Allow the user to commit any patch. Changed behavior: with no parameters, commit one applied patch, not all applied patches -- this is what uncommit does.
This commit is contained in:
parent
5acb5cbde8
commit
79ef95eaca
4 changed files with 80 additions and 25 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.3 2008/01/10 06:35:48 bjs Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2008/01/30 23:03:50 bjs Exp $
|
||||
|
||||
DISTNAME= stgit-0.14.1
|
||||
DISTNAME= stgit-20080128
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://homepage.ntlworld.com/cmarinas/stgit/
|
||||
MASTER_SITES= http://homepage.ntlworld.com/cmarinas/stgit/snapshots/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.procode.org/stgit/
|
||||
|
@ -10,11 +10,28 @@ COMMENT= Stacked GIT
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED?= 24 23
|
||||
PYTHON_PATCH_SCRIPTS= *.py stgit/*.py
|
||||
PYDISTUTILSPKG= yes
|
||||
PYSETUPINSTALLARGS= --prefix=${PREFIX}
|
||||
DEPENDS+= scmgit-base-[0-9]*:../../devel/scmgit-base
|
||||
|
||||
USE_TOOLS+= bash:run
|
||||
|
||||
REPLACE_BASH= contrib/stg-*
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED?=24 23
|
||||
PYTHON_PATCH_SCRIPTS= *.py stgit/*.py
|
||||
PYDISTUTILSPKG= yes
|
||||
PYSETUPINSTALLARGS= --prefix=${PREFIX}
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
|
||||
pre-install:
|
||||
${CHMOD} a-x ${WRKSRC}/contrib/stgbashprompt.sh
|
||||
|
||||
post-install:
|
||||
${RM} ${WRKSRC}/contrib/*.orig && \
|
||||
${INSTALL_SCRIPT_DIR} ${DESTDIR}${PREFIX}/bin && \
|
||||
for fn in ${WRKSRC}/contrib/stg-*; do \
|
||||
${INSTALL_SCRIPT} $$fn ${DESTDIR}${PREFIX}/bin; \
|
||||
done;
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,16 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2008/01/10 06:35:48 bjs Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2008/01/30 23:03:50 bjs Exp $
|
||||
bin/stg
|
||||
bin/stg-cvs
|
||||
bin/stg-dispatch
|
||||
bin/stg-fold-files-from
|
||||
bin/stg-gitk
|
||||
bin/stg-k
|
||||
bin/stg-mdiff
|
||||
bin/stg-show
|
||||
bin/stg-show-old
|
||||
bin/stg-swallow
|
||||
bin/stg-unnew
|
||||
bin/stg-whatchanged
|
||||
${PYSITELIB}/stgit/__init__.py
|
||||
${PYSITELIB}/stgit/__init__.pyc
|
||||
${PYSITELIB}/stgit/__init__.pyo
|
||||
|
@ -9,9 +20,6 @@ ${PYSITELIB}/stgit/basedir.pyo
|
|||
${PYSITELIB}/stgit/commands/__init__.py
|
||||
${PYSITELIB}/stgit/commands/__init__.pyc
|
||||
${PYSITELIB}/stgit/commands/__init__.pyo
|
||||
${PYSITELIB}/stgit/commands/add.py
|
||||
${PYSITELIB}/stgit/commands/add.pyc
|
||||
${PYSITELIB}/stgit/commands/add.pyo
|
||||
${PYSITELIB}/stgit/commands/applied.py
|
||||
${PYSITELIB}/stgit/commands/applied.pyc
|
||||
${PYSITELIB}/stgit/commands/applied.pyo
|
||||
|
@ -24,15 +32,15 @@ ${PYSITELIB}/stgit/commands/clean.pyo
|
|||
${PYSITELIB}/stgit/commands/clone.py
|
||||
${PYSITELIB}/stgit/commands/clone.pyc
|
||||
${PYSITELIB}/stgit/commands/clone.pyo
|
||||
${PYSITELIB}/stgit/commands/coalesce.py
|
||||
${PYSITELIB}/stgit/commands/coalesce.pyc
|
||||
${PYSITELIB}/stgit/commands/coalesce.pyo
|
||||
${PYSITELIB}/stgit/commands/commit.py
|
||||
${PYSITELIB}/stgit/commands/commit.pyc
|
||||
${PYSITELIB}/stgit/commands/commit.pyo
|
||||
${PYSITELIB}/stgit/commands/common.py
|
||||
${PYSITELIB}/stgit/commands/common.pyc
|
||||
${PYSITELIB}/stgit/commands/common.pyo
|
||||
${PYSITELIB}/stgit/commands/copy.py
|
||||
${PYSITELIB}/stgit/commands/copy.pyc
|
||||
${PYSITELIB}/stgit/commands/copy.pyo
|
||||
${PYSITELIB}/stgit/commands/delete.py
|
||||
${PYSITELIB}/stgit/commands/delete.pyc
|
||||
${PYSITELIB}/stgit/commands/delete.pyo
|
||||
|
@ -108,9 +116,6 @@ ${PYSITELIB}/stgit/commands/repair.pyo
|
|||
${PYSITELIB}/stgit/commands/resolved.py
|
||||
${PYSITELIB}/stgit/commands/resolved.pyc
|
||||
${PYSITELIB}/stgit/commands/resolved.pyo
|
||||
${PYSITELIB}/stgit/commands/rm.py
|
||||
${PYSITELIB}/stgit/commands/rm.pyc
|
||||
${PYSITELIB}/stgit/commands/rm.pyo
|
||||
${PYSITELIB}/stgit/commands/series.py
|
||||
${PYSITELIB}/stgit/commands/series.pyc
|
||||
${PYSITELIB}/stgit/commands/series.pyo
|
||||
|
@ -150,6 +155,21 @@ ${PYSITELIB}/stgit/git.pyo
|
|||
${PYSITELIB}/stgit/gitmergeonefile.py
|
||||
${PYSITELIB}/stgit/gitmergeonefile.pyc
|
||||
${PYSITELIB}/stgit/gitmergeonefile.pyo
|
||||
${PYSITELIB}/stgit/lib/__init__.py
|
||||
${PYSITELIB}/stgit/lib/__init__.pyc
|
||||
${PYSITELIB}/stgit/lib/__init__.pyo
|
||||
${PYSITELIB}/stgit/lib/git.py
|
||||
${PYSITELIB}/stgit/lib/git.pyc
|
||||
${PYSITELIB}/stgit/lib/git.pyo
|
||||
${PYSITELIB}/stgit/lib/stack.py
|
||||
${PYSITELIB}/stgit/lib/stack.pyc
|
||||
${PYSITELIB}/stgit/lib/stack.pyo
|
||||
${PYSITELIB}/stgit/lib/stackupgrade.py
|
||||
${PYSITELIB}/stgit/lib/stackupgrade.pyc
|
||||
${PYSITELIB}/stgit/lib/stackupgrade.pyo
|
||||
${PYSITELIB}/stgit/lib/transaction.py
|
||||
${PYSITELIB}/stgit/lib/transaction.pyc
|
||||
${PYSITELIB}/stgit/lib/transaction.pyo
|
||||
${PYSITELIB}/stgit/main.py
|
||||
${PYSITELIB}/stgit/main.pyc
|
||||
${PYSITELIB}/stgit/main.pyo
|
||||
|
@ -171,19 +191,19 @@ ${PYSITELIB}/stgit/utils.pyo
|
|||
${PYSITELIB}/stgit/version.py
|
||||
${PYSITELIB}/stgit/version.pyc
|
||||
${PYSITELIB}/stgit/version.pyo
|
||||
share/stgit/contrib/diffcol.sh
|
||||
share/examples/stgit/gitconfig
|
||||
share/stgit/contrib/stgbashprompt.sh
|
||||
share/stgit/contrib/stgit-completion.bash
|
||||
share/stgit/examples/gitconfig
|
||||
share/stgit/examples/patchdescr.tmpl
|
||||
share/stgit/templates/covermail.tmpl
|
||||
share/stgit/templates/mailattch.tmpl
|
||||
share/stgit/templates/patchexport.tmpl
|
||||
share/stgit/templates/patchmail.tmpl
|
||||
@dirrm share/stgit/templates
|
||||
@dirrm share/stgit/examples
|
||||
@dirrm share/stgit/contrib
|
||||
@dirrm share/stgit
|
||||
@dirrm share/examples/stgit
|
||||
@exec ${MKDIR} %D/share/doc/stgit
|
||||
@dirrm share/doc/stgit
|
||||
@dirrm ${PYSITELIB}/stgit/lib
|
||||
@dirrm ${PYSITELIB}/stgit/commands
|
||||
@dirrm ${PYSITELIB}/stgit
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.3 2008/01/10 06:35:49 bjs Exp $
|
||||
$NetBSD: distinfo,v 1.4 2008/01/30 23:03:50 bjs Exp $
|
||||
|
||||
SHA1 (stgit-0.14.1.tar.gz) = c7375590e58fd9a2a59dfe9031cb9667911af2a8
|
||||
RMD160 (stgit-0.14.1.tar.gz) = e4859b552eacbb16689baa79fd2cabf046c2a504
|
||||
Size (stgit-0.14.1.tar.gz) = 221897 bytes
|
||||
SHA1 (stgit-20080128.tar.gz) = c66576529c03403c5b2604ed400179c585bff89b
|
||||
RMD160 (stgit-20080128.tar.gz) = d1ec1d9b0679745839ae2cb1c8ac01c879d84df5
|
||||
Size (stgit-20080128.tar.gz) = 234891 bytes
|
||||
SHA1 (patch-aa) = 364103963f8e74eee12dbd548b4ed48b349b662f
|
||||
SHA1 (patch-ab) = 423664a988eb1c69c76adc482d74c4e8e227a83f
|
||||
|
|
17
devel/stgit/patches/patch-ab
Normal file
17
devel/stgit/patches/patch-ab
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-ab,v 1.1 2008/01/30 23:03:51 bjs Exp $
|
||||
|
||||
--- setup.py.orig 2007-12-19 18:15:14.000000000 -0500
|
||||
+++ setup.py
|
||||
@@ -59,10 +59,8 @@ setup(name = 'stgit',
|
||||
scripts = ['stg'],
|
||||
packages = ['stgit', 'stgit.commands', 'stgit.lib'],
|
||||
data_files = [('share/stgit/templates', glob.glob('templates/*.tmpl')),
|
||||
- ('share/stgit/examples', glob.glob('examples/*.tmpl')),
|
||||
- ('share/stgit/examples', ['examples/gitconfig']),
|
||||
- ('share/stgit/contrib', ['contrib/diffcol.sh',
|
||||
- 'contrib/stgbashprompt.sh',
|
||||
+ ('share/examples/stgit', ['examples/gitconfig']),
|
||||
+ ('share/stgit/contrib', ['contrib/stgbashprompt.sh',
|
||||
'contrib/stgit-completion.bash']),
|
||||
('share/doc/stgit', glob.glob('doc/*.txt'))]
|
||||
)
|
Loading…
Reference in a new issue