py-matplotlib: updated to 3.1.0

REL: v3.1.0
The first release of the v3.1 series
This version of Matplotlib support Python 3.6+
Highlights of this release include:
 - A helper method for scatter legends
 - Secondary axis support (ex, degrees and radians)
 - A concise date formatter
 - No longer requires a framework build of Python to use OSX backend
 - Major and minor ticks will no longer collide by default
 - A progress callback for animations
 - mplot3D is always registered
 - deprecated mlab functions have been removed
 - Many function calls have become stricter about invalid or ignored input

REL: v3.0.3
The third and last planned bug-fix release of the 3.0 series
* fix several possible memory leaks
* documentation fixes

jquery-ui is no longer bundled in git repo and is downloaded during
the install or sdist process. If you are installing from pypi the
files will be included, but if you are installing from git you will
need internet access the first time you run `pip install .`. The
install process tries to cache the files and will not need internet
access on future installations.

REL: v3.0.2
This is the second bug-fix release for the v3.0 series.
 - Un-breaks basemap which was broken by partially restoring
   private APIs for cartopy.
 - Fixes bug in warning code when used in an embedded context.
 - Fixes crash when using Tk and closing the first open window before showing it
 - Many documentation improvements.
 - Restore a corner case on ColorBar tick usage.
 - Change the default behavior of `matplotlib.use` to silently allow
   more 'safe' switching after auto-discovery, but before starting an event loop.
 - Improvements to bounding box calculations.
 - Provide the correct length for RcParams instances.

REL: v3.0.1
This is the first bug fix release for the 3.0 series which fixes
several
 - Fix failure to import bug when used with backend-fallback on Python
   3.6.7 and 3.7.1
 - Fixed a number of failure to import bugs around finding fonts
 - Fix Qt4 backend
 - Fix bug on OSX that recursively searched current directory for fonts
 - Fix bouncing-rocket on OSX when doing backend fallback and not
   selecting OSX
 - Temporarily restore several private APIs to unbreak cartopy
 - Make pyplot more tolerant of varying signatures in 3rd-party
   sub-classe
 - Improve datetime64 unit handling
 - Fixed several poor interactions with tight_layout

REL: v3.0.0
The first release of the Matplotlib 3.0 series
This is the first version of Matplotlib to only support Python 3.
Highlights of this release include:
 - GUI backend is selected at run-time based on what toolkits are
   installed.  A GUI toolkit will not be selected on a headless
   server.
 - New cyclic color map *twilight*
 - Improvements to automatic layout of titles, ticks, and GridSpec
 - Many bug fixes!
This commit is contained in:
adam 2019-06-16 13:11:34 +00:00
parent 1cafe31332
commit 7a1e9459ed
15 changed files with 71 additions and 311 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.819 2019/06/05 21:21:12 wiz Exp $
# $NetBSD: Makefile,v 1.820 2019/06/16 13:11:34 adam Exp $
#
COMMENT= Graphics tools and libraries
@ -470,8 +470,6 @@ SUBDIR+= py-imagesize
SUBDIR+= py-imaging
SUBDIR+= py-imagingtk
SUBDIR+= py-matplotlib
SUBDIR+= py-matplotlib-gtk2
SUBDIR+= py-matplotlib-tk
SUBDIR+= py-mcomix
SUBDIR+= py-nwdiag
SUBDIR+= py-objgraph

View file

@ -1,10 +0,0 @@
matplotlib is a pure python plotting library designed to bring
publication quality plotting to python with a syntax familiar to
matlab users. A lot progress towards this goal has been made since
the first release of matplotlib, the library does produce high quality
2D plots. All of the plotting commands can be accessed either via a
functional interface familiar to matlab users or an object oriented
interface familiar to python users, and several high resolution output
formats are supported.
Tutorial: https://matplotlib.org/users/tutorials.html

View file

@ -1,40 +0,0 @@
# $NetBSD: Makefile,v 1.69 2018/11/14 22:21:45 kleink Exp $
PKGREVISION= 4
.include "../../graphics/py-matplotlib/Makefile.common"
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/-/-gtk-/}
COMMENT= GTK frontend for matplotlib
MPL_PACKAGES= [setupext.Numpy(),setupext.LibAgg(),setupext.BackendGtkAgg(),setupext.BackendGtk()]
DEPENDS+= ${PYPKGPREFIX}-matplotlib-[0-9]*:../../graphics/py-matplotlib
PYTHON_VERSIONS_ACCEPTED= 27 # py-gtk2
post-patch:
( ${ECHO} "[directories]"; \
${ECHO} "basedirlist=/usr"; \
${ECHO} "[provide_packages]"; \
${ECHO} "pytz = False"; \
${ECHO} "dateutil = False"; \
${ECHO} "[gui_support]"; \
${ECHO} "gtk = True"; \
${ECHO} "tkagg = False"; \
${ECHO} "wxagg = False"; \
${ECHO} "macosx = False" ) > ${WRKSRC}/setup.cfg
post-install:
${RM} -r ${DESTDIR}/${PREFIX}/${PYSITELIB}/${EGG_INFODIR}
do-test:
${ECHO} "backend : GTKAgg" > ${WRKSRC}/matplotlibrc
${RUN} cd ${WRKSRC} && MPLCONFIGDIR=${PWD} \
MATPLOTLIBDATA=${WRKSRC}/lib/matplotlib/mpl-data \
PYTHONPATH=${DESTDIR}${PREFIX}/${PYSITELIB} \
${PYTHONBIN} -c "import matplotlib; matplotlib.test()"
.include "../../lang/python/egg.mk"
.include "../../math/py-numpy/buildlink3.mk"
.include "../../x11/py-gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 2008/12/19 22:39:47 markd Exp $
${PYSITELIB}/matplotlib/backends/_backend_gdk.so
${PYSITELIB}/matplotlib/backends/_gtkagg.so

View file

@ -1,10 +0,0 @@
matplotlib is a pure python plotting library designed to bring
publication quality plotting to python with a syntax familiar to
matlab users. A lot progress towards this goal has been made since
the first release of matplotlib, the library does produce high quality
2D plots. All of the plotting commands can be accessed either via a
functional interface familiar to matlab users or an object oriented
interface familiar to python users, and several high resolution output
formats are supported.
Tutorial: https://matplotlib.org/users/tutorials.html

View file

@ -1,39 +0,0 @@
# $NetBSD: Makefile,v 1.34 2018/07/11 16:19:32 gson Exp $
PKGREVISION= 1
.include "../../graphics/py-matplotlib/Makefile.common"
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/-/-tk-/}
COMMENT= Tk frontend for matplotlib
DEPENDS+= ${PYPKGPREFIX}-matplotlib-[0-9]*:../../graphics/py-matplotlib
DEPENDS+= ${PYPKGPREFIX}-Tk-[0-9]*:../../x11/py-Tk
MPL_PACKAGES= [setupext.Numpy(),setupext.LibAgg(),setupext.BackendTkAgg()]
post-patch:
( ${ECHO} "[directories]"; \
${ECHO} "basedirlist=/usr"; \
${ECHO} "[provide_packages]"; \
${ECHO} "pytz = False"; \
${ECHO} "dateutil = False"; \
${ECHO} "[gui_support]"; \
${ECHO} "gtk = False"; \
${ECHO} "tkagg = True"; \
${ECHO} "wxagg = False"; \
${ECHO} "macosx = False" ) > ${WRKSRC}/setup.cfg
post-install:
${RM} -r ${DESTDIR}/${PREFIX}/${PYSITELIB}/${EGG_INFODIR}
do-test:
${ECHO} "backend : TkAgg" > ${WRKSRC}/matplotlibrc
${RUN} cd ${WRKSRC} && MPLCONFIGDIR=${PWD} \
MATPLOTLIBDATA=${WRKSRC}/lib/matplotlib/mpl-data \
PYTHONPATH=${DESTDIR}${PREFIX}/${PYSITELIB} \
${PYTHONBIN} -c "import matplotlib; matplotlib.test()"
.include "../../lang/python/egg.mk"
.include "../../math/py-numpy/buildlink3.mk"
.include "../../x11/tk/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +0,0 @@
@comment $NetBSD: PLIST,v 1.3 2014/01/21 19:22:08 drochner Exp $
${PYSITELIB}/matplotlib/backends/_tkagg.so

View file

@ -0,0 +1,10 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1 2019/06/16 13:11:34 adam Exp $
MatPlotLib can use additional user interface backends.
For GTK3-base backends, install devel/py-gobject3 and x11/gtk3 packages.
For Qt5-base backends, install x11/py-qt5 package.
For Tk-base backends, install x11/py-Tk package.
===========================================================================

View file

@ -1,52 +1,30 @@
# $NetBSD: Makefile,v 1.53 2018/07/11 16:19:32 gson Exp $
.include "Makefile.common"
# $NetBSD: Makefile,v 1.54 2019/06/16 13:11:34 adam Exp $
DISTNAME= matplotlib-3.1.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
COMMENT= Matlab-style plotting package for Python
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_PYPI:=m/matplotlib/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://matplotlib.org/
COMMENT= Matlab-style plotting package for Python
# LICENSE= see ${WRKSRC}/LICENSE/LICENSE
DEPENDS+= ${PYPKGPREFIX}-Pillow>=3.4:../../graphics/py-Pillow
DEPENDS+= ${PYPKGPREFIX}-cairo-[0-9]*:../../graphics/py-cairo
DEPENDS+= ${PYPKGPREFIX}-cycler>=0.10:../../graphics/py-cycler
DEPENDS+= ${PYPKGPREFIX}-dateutil>=2.1:../../time/py-dateutil
DEPENDS+= ${PYPKGPREFIX}-kiwisolver>=1.0.1:../../math/py-kiwisolver
DEPENDS+= ${PYPKGPREFIX}-pytz>=2008b:../../time/py-pytz
DEPENDS+= ${PYPKGPREFIX}-pyparsing>=2.2.0:../../devel/py-pyparsing
DEPENDS+= ${PYPKGPREFIX}-six>=1.10:../../lang/py-six
TEST_DEPENDS+= ${PYPKGPREFIX}-mock-[0-9]*:../../devel/py-mock
TEST_DEPENDS+= ${PYPKGPREFIX}-nose-[0-9]*:../../devel/py-nose
TEST_DEPENDS+= ${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test
.include "../../lang/python/pyversion.mk"
.if "${PYPKGPREFIX}" == "py27"
DEPENDS+= ${PYPKGPREFIX}-backports.functools_lru_cache-[0-9]*:../../devel/py-backports.functools_lru_cache
DEPENDS+= ${PYPKGPREFIX}-subprocess32-[0-9]*:../../devel/py-subprocess32
.endif
USE_LANGUAGES= c c++
USE_TOOLS+= pkg-config
MPL_PACKAGES= mpl_packages
PYTHON_VERSIONS_INCOMPATIBLE= 27
REPLACE_PYTHON= lib/matplotlib/dates.py
REPLACE_PYTHON+= lib/matplotlib/sankey.py
REPLACE_PYTHON+= lib/mpl_toolkits/mplot3d/art3d.py
REPLACE_PYTHON+= lib/mpl_toolkits/mplot3d/axes3d.py
REPLACE_PYTHON+= lib/mpl_toolkits/mplot3d/axis3d.py
REPLACE_PYTHON+= lib/mpl_toolkits/mplot3d/proj3d.py
PYSETUPTESTTARGET= pytest
post-patch:
( ${ECHO} "[directories]"; \
${ECHO} "basedirlist=/usr"; \
${ECHO} "[gui_support]"; \
${ECHO} "gtk = False"; \
${ECHO} "tkagg = False"; \
${ECHO} "wxagg = False" ) > ${WRKSRC}/setup.cfg
do-test:
${ECHO} "backend : GTKAgg" > ${WRKSRC}/matplotlibrc
${RUN} cd ${WRKSRC} && MPLCONFIGDIR=${PWD} \
MATPLOTLIBDATA=${WRKSRC}/lib/matplotlib/mpl-data \
PYTHONPATH=${DESTDIR}${PREFIX}/${PYSITELIB} \
${PYTHONBIN} -c "import matplotlib; matplotlib.test()"
.include "../../lang/python/application.mk"
.include "../../lang/python/egg.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"

View file

@ -1,25 +0,0 @@
# $NetBSD: Makefile.common,v 1.6 2018/04/14 12:52:56 adam Exp $
# used by graphics/py-matplotlib/Makefile
# used by graphics/py-matplotlib-gtk2/Makefile
# used by graphics/py-matplotlib-tk/Makefile
DISTNAME= matplotlib-2.2.2
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_PYPI:=m/matplotlib/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://matplotlib.org/
# LICENSE= see ${WRKSRC}/LICENSE/LICENSE
DISTINFO_FILE= ${.CURDIR}/../../graphics/py-matplotlib/distinfo
PATCHDIR= ${.CURDIR}/../../graphics/py-matplotlib/patches
USE_LANGUAGES= c c++
USE_TOOLS+= pkg-config
# see patch-setup.py
SUBST_CLASSES+= mplpkgs
SUBST_STAGE.mplpkgs= pre-configure
SUBST_MESSAGE.mplpkgs= Selecting mpl packages.
SUBST_FILES.mplpkgs= setup.py
SUBST_VARS.mplpkgs= MPL_PACKAGES

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.23 2018/04/14 12:52:56 adam Exp $
@comment $NetBSD: PLIST,v 1.24 2019/06/16 13:11:34 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
@ -61,6 +61,9 @@ ${PYSITELIB}/matplotlib/axes/_axes.pyo
${PYSITELIB}/matplotlib/axes/_base.py
${PYSITELIB}/matplotlib/axes/_base.pyc
${PYSITELIB}/matplotlib/axes/_base.pyo
${PYSITELIB}/matplotlib/axes/_secondary_axes.py
${PYSITELIB}/matplotlib/axes/_secondary_axes.pyc
${PYSITELIB}/matplotlib/axes/_secondary_axes.pyo
${PYSITELIB}/matplotlib/axes/_subplots.py
${PYSITELIB}/matplotlib/axes/_subplots.pyc
${PYSITELIB}/matplotlib/axes/_subplots.pyo
@ -80,24 +83,19 @@ ${PYSITELIB}/matplotlib/backends/__init__.py
${PYSITELIB}/matplotlib/backends/__init__.pyc
${PYSITELIB}/matplotlib/backends/__init__.pyo
${PYSITELIB}/matplotlib/backends/_backend_agg.so
${PYSITELIB}/matplotlib/backends/_backend_pdf_ps.py
${PYSITELIB}/matplotlib/backends/_backend_pdf_ps.pyc
${PYSITELIB}/matplotlib/backends/_backend_pdf_ps.pyo
${PYSITELIB}/matplotlib/backends/_backend_tk.py
${PYSITELIB}/matplotlib/backends/_backend_tk.pyc
${PYSITELIB}/matplotlib/backends/_backend_tk.pyo
${PYSITELIB}/matplotlib/backends/_gtk3_compat.py
${PYSITELIB}/matplotlib/backends/_gtk3_compat.pyc
${PYSITELIB}/matplotlib/backends/_gtk3_compat.pyo
${PYSITELIB}/matplotlib/backends/_tkagg.so
${PYSITELIB}/matplotlib/backends/backend_agg.py
${PYSITELIB}/matplotlib/backends/backend_agg.pyc
${PYSITELIB}/matplotlib/backends/backend_agg.pyo
${PYSITELIB}/matplotlib/backends/backend_cairo.py
${PYSITELIB}/matplotlib/backends/backend_cairo.pyc
${PYSITELIB}/matplotlib/backends/backend_cairo.pyo
${PYSITELIB}/matplotlib/backends/backend_gdk.py
${PYSITELIB}/matplotlib/backends/backend_gdk.pyc
${PYSITELIB}/matplotlib/backends/backend_gdk.pyo
${PYSITELIB}/matplotlib/backends/backend_gtk.py
${PYSITELIB}/matplotlib/backends/backend_gtk.pyc
${PYSITELIB}/matplotlib/backends/backend_gtk.pyo
${PYSITELIB}/matplotlib/backends/backend_gtk3.py
${PYSITELIB}/matplotlib/backends/backend_gtk3.pyc
${PYSITELIB}/matplotlib/backends/backend_gtk3.pyo
@ -107,12 +105,6 @@ ${PYSITELIB}/matplotlib/backends/backend_gtk3agg.pyo
${PYSITELIB}/matplotlib/backends/backend_gtk3cairo.py
${PYSITELIB}/matplotlib/backends/backend_gtk3cairo.pyc
${PYSITELIB}/matplotlib/backends/backend_gtk3cairo.pyo
${PYSITELIB}/matplotlib/backends/backend_gtkagg.py
${PYSITELIB}/matplotlib/backends/backend_gtkagg.pyc
${PYSITELIB}/matplotlib/backends/backend_gtkagg.pyo
${PYSITELIB}/matplotlib/backends/backend_gtkcairo.py
${PYSITELIB}/matplotlib/backends/backend_gtkcairo.pyc
${PYSITELIB}/matplotlib/backends/backend_gtkcairo.pyo
${PYSITELIB}/matplotlib/backends/backend_macosx.py
${PYSITELIB}/matplotlib/backends/backend_macosx.pyc
${PYSITELIB}/matplotlib/backends/backend_macosx.pyo
@ -182,6 +174,9 @@ ${PYSITELIB}/matplotlib/backends/qt_compat.pyo
${PYSITELIB}/matplotlib/backends/qt_editor/__init__.py
${PYSITELIB}/matplotlib/backends/qt_editor/__init__.pyc
${PYSITELIB}/matplotlib/backends/qt_editor/__init__.pyo
${PYSITELIB}/matplotlib/backends/qt_editor/_formlayout.py
${PYSITELIB}/matplotlib/backends/qt_editor/_formlayout.pyc
${PYSITELIB}/matplotlib/backends/qt_editor/_formlayout.pyo
${PYSITELIB}/matplotlib/backends/qt_editor/figureoptions.py
${PYSITELIB}/matplotlib/backends/qt_editor/figureoptions.pyc
${PYSITELIB}/matplotlib/backends/qt_editor/figureoptions.pyo
@ -199,23 +194,27 @@ ${PYSITELIB}/matplotlib/backends/web_backend/css/boilerplate.css
${PYSITELIB}/matplotlib/backends/web_backend/css/fbm.css
${PYSITELIB}/matplotlib/backends/web_backend/css/page.css
${PYSITELIB}/matplotlib/backends/web_backend/ipython_inline_figure.html
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_diagonals-thick_18_b81900_40x40.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_diagonals-thick_20_666666_40x40.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_flat_10_000000_40x100.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_glass_100_f6f6f6_1x400.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_glass_100_fdf5ce_1x400.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_glass_65_ffffff_1x400.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_gloss-wave_35_f6a828_500x100.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_highlight-soft_100_eeeeee_1x100.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_highlight-soft_75_ffe45c_1x100.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-icons_222222_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-icons_228ef1_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-icons_ef8c08_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-icons_ffd27a_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-icons_ffffff_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery/css/themes/base/jquery-ui.min.css
${PYSITELIB}/matplotlib/backends/web_backend/jquery/js/jquery-1.11.3.min.js
${PYSITELIB}/matplotlib/backends/web_backend/jquery/js/jquery-ui.min.js
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/AUTHORS.txt
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/LICENSE.txt
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/external/jquery/jquery.js
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_444444_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_555555_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_777620_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_777777_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_cc0000_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_ffffff_256x240.png
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/index.html
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.css
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.js
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.min.css
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.min.js
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.structure.css
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.structure.min.css
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.theme.css
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.theme.min.css
${PYSITELIB}/matplotlib/backends/web_backend/jquery-ui-1.12.1/package.json
${PYSITELIB}/matplotlib/backends/web_backend/jquery/js/jquery.js
${PYSITELIB}/matplotlib/backends/web_backend/jquery/js/jquery.min.js
${PYSITELIB}/matplotlib/backends/web_backend/js/mpl.js
${PYSITELIB}/matplotlib/backends/web_backend/js/mpl_tornado.js
${PYSITELIB}/matplotlib/backends/web_backend/js/nbagg_mpl.js
@ -239,9 +238,6 @@ ${PYSITELIB}/matplotlib/category.pyo
${PYSITELIB}/matplotlib/cbook/__init__.py
${PYSITELIB}/matplotlib/cbook/__init__.pyc
${PYSITELIB}/matplotlib/cbook/__init__.pyo
${PYSITELIB}/matplotlib/cbook/_backports.py
${PYSITELIB}/matplotlib/cbook/_backports.pyc
${PYSITELIB}/matplotlib/cbook/_backports.pyo
${PYSITELIB}/matplotlib/cbook/deprecation.py
${PYSITELIB}/matplotlib/cbook/deprecation.pyc
${PYSITELIB}/matplotlib/cbook/deprecation.pyo
@ -390,6 +386,7 @@ ${PYSITELIB}/matplotlib/mpl-data/fonts/ttf/DejaVuSerif-BoldItalic.ttf
${PYSITELIB}/matplotlib/mpl-data/fonts/ttf/DejaVuSerif-Italic.ttf
${PYSITELIB}/matplotlib/mpl-data/fonts/ttf/DejaVuSerif.ttf
${PYSITELIB}/matplotlib/mpl-data/fonts/ttf/DejaVuSerifDisplay.ttf
${PYSITELIB}/matplotlib/mpl-data/fonts/ttf/LICENSE_DEJAVU
${PYSITELIB}/matplotlib/mpl-data/fonts/ttf/LICENSE_STIX
${PYSITELIB}/matplotlib/mpl-data/fonts/ttf/STIXGeneral.ttf
${PYSITELIB}/matplotlib/mpl-data/fonts/ttf/STIXGeneralBol.ttf
@ -438,6 +435,12 @@ ${PYSITELIB}/matplotlib/mpl-data/images/hand.pdf
${PYSITELIB}/matplotlib/mpl-data/images/hand.png
${PYSITELIB}/matplotlib/mpl-data/images/hand.svg
${PYSITELIB}/matplotlib/mpl-data/images/hand_large.gif
${PYSITELIB}/matplotlib/mpl-data/images/help.pdf
${PYSITELIB}/matplotlib/mpl-data/images/help.png
${PYSITELIB}/matplotlib/mpl-data/images/help.ppm
${PYSITELIB}/matplotlib/mpl-data/images/help.svg
${PYSITELIB}/matplotlib/mpl-data/images/help_large.png
${PYSITELIB}/matplotlib/mpl-data/images/help_large.ppm
${PYSITELIB}/matplotlib/mpl-data/images/home.gif
${PYSITELIB}/matplotlib/mpl-data/images/home.pdf
${PYSITELIB}/matplotlib/mpl-data/images/home.png
@ -492,6 +495,7 @@ ${PYSITELIB}/matplotlib/mpl-data/sample_data/membrane.dat
${PYSITELIB}/matplotlib/mpl-data/sample_data/msft.csv
${PYSITELIB}/matplotlib/mpl-data/sample_data/percent_bachelors_degrees_women_usa.csv
${PYSITELIB}/matplotlib/mpl-data/sample_data/s1045.ima.gz
${PYSITELIB}/matplotlib/mpl-data/sample_data/topobathy.npz
${PYSITELIB}/matplotlib/mpl-data/stylelib/Solarize_Light2.mplstyle
${PYSITELIB}/matplotlib/mpl-data/stylelib/_classic_test.mplstyle
${PYSITELIB}/matplotlib/mpl-data/stylelib/bmh.mplstyle
@ -563,9 +567,6 @@ ${PYSITELIB}/matplotlib/sphinxext/__init__.pyo
${PYSITELIB}/matplotlib/sphinxext/mathmpl.py
${PYSITELIB}/matplotlib/sphinxext/mathmpl.pyc
${PYSITELIB}/matplotlib/sphinxext/mathmpl.pyo
${PYSITELIB}/matplotlib/sphinxext/only_directives.py
${PYSITELIB}/matplotlib/sphinxext/only_directives.pyc
${PYSITELIB}/matplotlib/sphinxext/only_directives.pyo
${PYSITELIB}/matplotlib/sphinxext/plot_directive.py
${PYSITELIB}/matplotlib/sphinxext/plot_directive.pyc
${PYSITELIB}/matplotlib/sphinxext/plot_directive.pyo
@ -590,24 +591,6 @@ ${PYSITELIB}/matplotlib/table.pyo
${PYSITELIB}/matplotlib/testing/__init__.py
${PYSITELIB}/matplotlib/testing/__init__.pyc
${PYSITELIB}/matplotlib/testing/__init__.pyo
${PYSITELIB}/matplotlib/testing/_nose/__init__.py
${PYSITELIB}/matplotlib/testing/_nose/__init__.pyc
${PYSITELIB}/matplotlib/testing/_nose/__init__.pyo
${PYSITELIB}/matplotlib/testing/_nose/decorators.py
${PYSITELIB}/matplotlib/testing/_nose/decorators.pyc
${PYSITELIB}/matplotlib/testing/_nose/decorators.pyo
${PYSITELIB}/matplotlib/testing/_nose/exceptions.py
${PYSITELIB}/matplotlib/testing/_nose/exceptions.pyc
${PYSITELIB}/matplotlib/testing/_nose/exceptions.pyo
${PYSITELIB}/matplotlib/testing/_nose/plugins/__init__.py
${PYSITELIB}/matplotlib/testing/_nose/plugins/__init__.pyc
${PYSITELIB}/matplotlib/testing/_nose/plugins/__init__.pyo
${PYSITELIB}/matplotlib/testing/_nose/plugins/knownfailure.py
${PYSITELIB}/matplotlib/testing/_nose/plugins/knownfailure.pyc
${PYSITELIB}/matplotlib/testing/_nose/plugins/knownfailure.pyo
${PYSITELIB}/matplotlib/testing/_nose/plugins/performgc.py
${PYSITELIB}/matplotlib/testing/_nose/plugins/performgc.pyc
${PYSITELIB}/matplotlib/testing/_nose/plugins/performgc.pyo
${PYSITELIB}/matplotlib/testing/compare.py
${PYSITELIB}/matplotlib/testing/compare.pyc
${PYSITELIB}/matplotlib/testing/compare.pyo
@ -650,9 +633,6 @@ ${PYSITELIB}/matplotlib/testing/jpl_units/UnitDblFormatter.pyo
${PYSITELIB}/matplotlib/testing/jpl_units/__init__.py
${PYSITELIB}/matplotlib/testing/jpl_units/__init__.pyc
${PYSITELIB}/matplotlib/testing/jpl_units/__init__.pyo
${PYSITELIB}/matplotlib/testing/noseclasses.py
${PYSITELIB}/matplotlib/testing/noseclasses.pyc
${PYSITELIB}/matplotlib/testing/noseclasses.pyo
${PYSITELIB}/matplotlib/texmanager.py
${PYSITELIB}/matplotlib/texmanager.pyc
${PYSITELIB}/matplotlib/texmanager.pyo

View file

@ -1,9 +1,6 @@
$NetBSD: distinfo,v 1.31 2018/07/11 16:19:32 gson Exp $
$NetBSD: distinfo,v 1.32 2019/06/16 13:11:34 adam Exp $
SHA1 (matplotlib-2.2.2.tar.gz) = dac0d6b9d7eee31e6240d454cb2ff896215429e4
RMD160 (matplotlib-2.2.2.tar.gz) = ffc08d6f14856079653aece2068b99396ab5f9f4
SHA512 (matplotlib-2.2.2.tar.gz) = 1d21ef821190f22354098f8f0db6449f237acbf3c1419ab3815ecd4e9c6922fd3f00c4a8f60858e319b55b6fb2e8fe2922c0bf8e72b204e7edff0b409cf76320
Size (matplotlib-2.2.2.tar.gz) = 37317332 bytes
SHA1 (patch-setup.py) = 0088019e1296d245021fb592915226618d91495d
SHA1 (patch-src___macosx.m) = 5b46ec15d2f66ae1ee489b6714c2731dd476d50c
SHA1 (patch-src_file__compat.h) = 5785353fb66c1f5036752e2975dc36a65112a0a6
SHA1 (matplotlib-3.1.0.tar.gz) = be6a7c871d15a8e93173c61b6e39421c69dde436
RMD160 (matplotlib-3.1.0.tar.gz) = 5f3befcf719ef1577f55b9fa3e84208bf6fcba9d
SHA512 (matplotlib-3.1.0.tar.gz) = 8402191004f30b9092ea3464a5501de2216893ab6822090638aa7877395c4503702e4673385e1fc5c225dc71c4df3e895435cdc58b145f3e5ef4cb9fa689c5bf
Size (matplotlib-3.1.0.tar.gz) = 37204551 bytes

View file

@ -1,28 +0,0 @@
$NetBSD: patch-setup.py,v 1.3 2017/10/13 09:50:35 adam Exp $
Build only selected packages (see Makefile.common).
--- setup.py.orig 2017-10-07 19:25:46.000000000 +0000
+++ setup.py
@@ -99,12 +99,6 @@ mpl_packages = [
setupext.BackendMacOSX(),
setupext.BackendQt5(),
setupext.BackendQt4(),
- setupext.BackendGtk3Agg(),
- setupext.BackendGtk3Cairo(),
- setupext.BackendGtkAgg(),
- setupext.BackendTkAgg(),
- setupext.BackendWxAgg(),
- setupext.BackendGtk(),
setupext.BackendAgg(),
setupext.BackendCairo(),
setupext.Windowing(),
@@ -180,7 +174,7 @@ if __name__ == '__main__':
required_failed = []
good_packages = []
- for package in mpl_packages:
+ for package in @MPL_PACKAGES@:
if isinstance(package, str):
print_raw('')
print_raw(package.upper())

View file

@ -1,17 +0,0 @@
$NetBSD: patch-src___macosx.m,v 1.1 2017/05/29 20:59:21 adam Exp $
Do not complain about Python.framework and allow working from command-line.
--- src/_macosx.m.orig 2017-05-10 17:14:04.000000000 +0000
+++ src/_macosx.m
@@ -3068,9 +3068,8 @@ static bool verify_framework(void)
switch (activationPolicy) {
case NSApplicationActivationPolicyRegular:
case NSApplicationActivationPolicyAccessory:
- return true;
case NSApplicationActivationPolicyProhibited:
- break;
+ return true;
}
#else
ProcessSerialNumber psn;

View file

@ -1,29 +0,0 @@
$NetBSD: patch-src_file__compat.h,v 1.1 2018/07/11 16:19:32 gson Exp $
Do not call the flush method on a file object opened for reading,
bcause it returns an error on BSD systems, with the end result
that importing matplotlib fails as reported in PR pkg/53425.
--- src/file_compat.h.orig 2018-03-06 04:47:09.000000000 +0000
+++ src/file_compat.h
@@ -60,12 +60,15 @@ static NPY_INLINE FILE *mpl_PyFile_Dup(P
mpl_off_t pos;
FILE *handle;
- /* Flush first to ensure things end up in the file in the correct order */
- ret = PyObject_CallMethod(file, (char *)"flush", (char *)"");
- if (ret == NULL) {
- return NULL;
+ if (mode[0] != 'r') {
+ /* Flush first to ensure things end up in the file in the correct order */
+ ret = PyObject_CallMethod(file, (char *)"flush", (char *)"");
+ if (ret == NULL) {
+ return NULL;
+ }
+ Py_DECREF(ret);
}
- Py_DECREF(ret);
+
fd = PyObject_AsFileDescriptor(file);
if (fd == -1) {
return NULL;