Update to 0.5.2, provided by Sean Doran in pkg/11142, with some minor
cleanup by me. Changes: 'open-source', new char-sets and -operations, new regexp system, some renaming (reduce-* -> *-fold), and lots of bugfixes.
This commit is contained in:
parent
1ee326fda3
commit
7adbff0fdf
13 changed files with 654 additions and 933 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.13 2001/02/17 17:40:20 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.14 2001/02/27 19:37:46 wiz Exp $
|
||||
# FreeBSD Id: Makefile,v 1.4 1997/07/15 15:00:30 cracauer Exp
|
||||
#
|
||||
|
||||
DISTNAME= scsh-0.5.1
|
||||
DISTNAME= scsh-0.5.2
|
||||
CATEGORIES= shells lang
|
||||
MASTER_SITES= ftp://ftp-swiss.ai.mit.edu/pub/su/scsh/
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.2 1998/08/07 13:27:38 agc Exp $
|
||||
$NetBSD: md5,v 1.3 2001/02/27 19:37:47 wiz Exp $
|
||||
|
||||
MD5 (scsh-0.5.1.tar.gz) = 907dfc1202bff6b4aa416d2026dbdd19
|
||||
MD5 (scsh-0.5.2.tar.gz) = 6661518731117eb21eda644aa5babe46
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-sum,v 1.3 2000/05/20 23:05:39 dmcmahill Exp $
|
||||
$NetBSD: patch-sum,v 1.4 2001/02/27 19:37:47 wiz Exp $
|
||||
|
||||
MD5 (patch-aa) = d42deff85c5714ce15cfd5b3cb7f75de
|
||||
MD5 (patch-aa) = 6d6f8801d508b8dc769bf7c5df0a91ce
|
||||
MD5 (patch-ab) = df53020f5f1b12486fc426f92e154a30
|
||||
MD5 (patch-ac) = ac0e044700bea35dd7b88768c10e1e2b
|
||||
MD5 (patch-ad) = 6b90b4233b175d2140f4b357fc665fc3
|
||||
|
@ -8,5 +8,10 @@ MD5 (patch-ae) = 1078379e1bd89f6d63e0b4db95120c46
|
|||
MD5 (patch-af) = d897362062386ea35fabf59bfbd299f3
|
||||
MD5 (patch-ag) = d3e067a90e4b55d2d27bdef28aa8ad97
|
||||
MD5 (patch-ah) = 6eb3bb6e657ad5d802c32062aafc37ab
|
||||
MD5 (patch-ai) = 7157ce97b6c188f58d76be0f634c98d0
|
||||
MD5 (patch-aj) = a760727620116680f16758a4f6e13244
|
||||
MD5 (patch-ai) = 2811a88832b1b432656775bbb997c3e9
|
||||
MD5 (patch-aj) = c996547257b2b8416fe993b928482f9b
|
||||
MD5 (patch-ak) = 0e716a351c534a63dd66f45e073d83a0
|
||||
MD5 (patch-al) = 7073b214382120c8a314be247520bccf
|
||||
MD5 (patch-am) = 568a483d935e57fba1042fbe2597ccb0
|
||||
MD5 (patch-an) = 78611e96bdfe4c0d1ef5087200eb1d69
|
||||
MD5 (patch-ao) = 5ce3c132995a0b5ee9377ef028c7c3a5
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.3 1998/08/07 11:13:54 agc Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2001/02/27 19:37:47 wiz Exp $
|
||||
|
||||
--- Makefile.in.orig Mon Jun 9 03:46:05 1997
|
||||
+++ Makefile.in Sat Feb 7 22:31:02 1998
|
||||
--- Makefile.in.orig Wed Sep 15 16:54:48 1999
|
||||
+++ Makefile.in Sun Oct 1 21:46:02 2000
|
||||
@@ -139,7 +139,7 @@
|
||||
|
||||
# The following is the first rule and therefore the "make" command's
|
||||
|
@ -11,7 +11,17 @@ $NetBSD: patch-aa,v 1.3 1998/08/07 11:13:54 agc Exp $
|
|||
|
||||
# The developers are curious to know. Don't be concerned if this fails.
|
||||
# You may comment these lines out if you wish to be discourteous.
|
||||
@@ -252,6 +252,7 @@
|
||||
@@ -156,6 +156,9 @@
|
||||
.scm.c:
|
||||
$(srcdir)/$(VM) -o $(srcdir)/$(VM) -i $(CIG) < $< > $*.c
|
||||
|
||||
+scsh/rdelim.c:
|
||||
+ $(srcdir)/$(VM) -o $(srcdir)/$(VM) -i $(CIG) < $< > $*.c
|
||||
+
|
||||
# These .h files mediate between the code exported from foo1.c
|
||||
# and imported into foo.scm's stub foo.c.
|
||||
|
||||
@@ -277,6 +280,7 @@
|
||||
$(RM) -r $(LIB).old
|
||||
if [ -d $(LIB) ] ; then mv $(LIB) $(LIB).old ; fi
|
||||
mkdir $(LIB)
|
||||
|
@ -19,7 +29,17 @@ $NetBSD: patch-aa,v 1.3 1998/08/07 11:13:54 agc Exp $
|
|||
mkdir $(LIB)/big
|
||||
mkdir $(LIB)/cig
|
||||
mkdir $(LIB)/doc
|
||||
@@ -279,8 +280,8 @@
|
||||
@@ -286,6 +290,9 @@
|
||||
mkdir $(LIB)/misc
|
||||
mkdir $(LIB)/opt
|
||||
mkdir $(LIB)/scsh
|
||||
+ mkdir $(LIB)/scsh/rx
|
||||
+ mkdir $(LIB)/scsh/lib
|
||||
+ mkdir $(LIB)/scsh/machine
|
||||
mkdir $(LIB)/rts
|
||||
mkdir $(LIB)/vm
|
||||
|
||||
@@ -304,8 +311,8 @@
|
||||
$(INSTALL_DATA) $(srcdir)/scheme48.h $(incdir)/
|
||||
|
||||
install-cig: cig
|
||||
|
@ -30,7 +50,7 @@ $NetBSD: patch-aa,v 1.3 1998/08/07 11:13:54 agc Exp $
|
|||
$(INSTALL_DATA) $(srcdir)/$(LIBCIG) $(LIB)/cig
|
||||
$(INSTALL_DATA) $(srcdir)/cig/libcig.h $(LIB)/cig
|
||||
|
||||
@@ -288,6 +289,7 @@
|
||||
@@ -313,6 +320,7 @@
|
||||
$(LIB)/misc $(LIB)/link $(LIB)/vm $(LIB)/doc
|
||||
for f in $(srcdir)/rts/*num.scm; \
|
||||
do $(INSTALL_DATA) $$f $(LIB)/rts/; done
|
||||
|
@ -38,10 +58,31 @@ $NetBSD: patch-aa,v 1.3 1998/08/07 11:13:54 agc Exp $
|
|||
for f in $(srcdir)/env/*.scm; do $(INSTALL_DATA) $$f $(LIB)/env/; done
|
||||
for f in $(srcdir)/big/*.scm; do $(INSTALL_DATA) $$f $(LIB)/big/; done
|
||||
for f in $(srcdir)/opt/*.scm; do $(INSTALL_DATA) $$f $(LIB)/opt/; done
|
||||
@@ -676,8 +678,8 @@
|
||||
@@ -627,7 +635,8 @@
|
||||
scsh/time.scm \
|
||||
scsh/top.scm \
|
||||
scsh/tty.scm \
|
||||
- scsh/utilities.scm
|
||||
+ scsh/utilities.scm \
|
||||
+ scsh/rx/let-match.scm
|
||||
|
||||
# scsh/dbm.scm db.scm ndbm.scm
|
||||
# static.scm static-heap.scm static1.scm
|
||||
@@ -656,6 +665,7 @@
|
||||
$(srcdir)/scsh/machine/packages.scm \
|
||||
$(srcdir)/scsh/rx/packages.scm \
|
||||
$(srcdir)/scsh/rx/cond-package.scm \
|
||||
+ $(srcdir)/scsh/rx/let-match.scm \
|
||||
$(srcdir)/scsh/scsh-package.scm \
|
||||
$(srcdir)/scsh/lib/string-pack.scm \
|
||||
$(srcdir)/scsh/lib/list-pack.scm \
|
||||
@@ -711,13 +721,20 @@
|
||||
|
||||
install-scsh: scsh
|
||||
$(RM) $(bindir)/$(RUNNABLE)
|
||||
$(INSTALL_PROGRAM) $(srcdir)/scsh/scsh $(bindir)/$(RUNNABLE)
|
||||
$(RM) $(bindir)/$(RUNNABLE)$(EXEEXT)
|
||||
- $(INSTALL_PROGRAM) $(srcdir)/scsh/scsh$(EXEEXT) \
|
||||
+ $(INSTALL_SCRIPT) $(srcdir)/scsh/scsh$(EXEEXT) \
|
||||
$(bindir)/$(RUNNABLE)$(EXEEXT)
|
||||
- $(INSTALL_PROGRAM) $(srcdir)/scsh/scsh.image $(LIB)/scsh.image
|
||||
- $(INSTALL_PROGRAM) $(srcdir)/$(LIBSCSH) $(libdir)/$(LIBSCSH)
|
||||
+ $(INSTALL_SCRIPT) $(srcdir)/scsh/scsh.image $(LIB)/scsh.image
|
||||
|
@ -49,3 +90,13 @@ $NetBSD: patch-aa,v 1.3 1998/08/07 11:13:54 agc Exp $
|
|||
$(RANLIB) $(libdir)/$(LIBSCSH)
|
||||
for f in $(srcdir)/scsh/*.scm; \
|
||||
do $(INSTALL_DATA) $$f $(LIB)/scsh/; done
|
||||
+ for f in $(srcdir)/scsh/lib/*.scm; \
|
||||
+ do $(INSTALL_DATA) $$f $(LIB)/scsh/lib/; done
|
||||
+ for f in $(srcdir)/scsh/rx/*.scm; \
|
||||
+ do $(INSTALL_DATA) $$f $(LIB)/scsh/rx/; done
|
||||
+ for f in $(srcdir)/scsh/machine/*.scm; \
|
||||
+ do $(INSTALL_DATA) $$f $(LIB)/scsh/machine/; done
|
||||
+
|
||||
|
||||
clean-scsh:
|
||||
$(RM) scsh/*.o scsh/regexp/*.o scsh/rx/*.o scsh/machine/*.o
|
||||
|
|
|
@ -1,10 +1,12 @@
|
|||
$NetBSD: patch-ai,v 1.1 2000/05/20 23:05:40 dmcmahill Exp $
|
||||
$NetBSD: patch-ai,v 1.2 2001/02/27 19:37:47 wiz Exp $
|
||||
|
||||
--- configure.in.orig Sat May 20 17:07:20 2000
|
||||
+++ configure.in Sat May 20 17:20:50 2000
|
||||
@@ -292,4 +292,5 @@
|
||||
--- configure.in.orig Tue Feb 27 20:13:07 2001
|
||||
+++ configure.in
|
||||
@@ -291,6 +291,7 @@
|
||||
|
||||
## NetBSD and FreeBSD ( and maybe 386BSD also)
|
||||
*-*-*bsd* )
|
||||
+ LDFLAGS="-Wl,--export-dynamic"
|
||||
dir=bsd
|
||||
SCSH_ELF
|
||||
;;
|
||||
|
|
File diff suppressed because it is too large
Load diff
13
shells/scsh/patches/patch-ak
Normal file
13
shells/scsh/patches/patch-ak
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ak,v 1.1 2001/02/27 19:37:47 wiz Exp $
|
||||
|
||||
--- scsh/lib/string-lib.scm.orig Wed Sep 15 16:28:11 1999
|
||||
+++ scsh/lib/string-lib.scm Sun Oct 1 06:44:22 2000
|
||||
@@ -1139,7 +1139,7 @@
|
||||
; ((< i start) ans))))
|
||||
|
||||
(define (string->list s . maybe-start+end)
|
||||
- (apply string-fold-right s cons '() maybe-start+end))
|
||||
+ (apply string-fold-right cons '() s maybe-start+end))
|
||||
|
||||
|
||||
|
12
shells/scsh/patches/patch-al
Normal file
12
shells/scsh/patches/patch-al
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-al,v 1.1 2001/02/27 19:37:47 wiz Exp $
|
||||
|
||||
--- scsh/rx/packages.scm.orig Sun Oct 1 07:12:16 2000
|
||||
+++ scsh/rx/packages.scm Sun Oct 1 07:12:33 2000
|
||||
@@ -174,6 +174,7 @@
|
||||
:boolean))
|
||||
(sre->regexp (proc (:value) :value))
|
||||
(regexp->sre (proc (:value) :value))
|
||||
+ nonl-chars
|
||||
)))
|
||||
|
||||
|
13
shells/scsh/patches/patch-am
Normal file
13
shells/scsh/patches/patch-am
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-am,v 1.1 2001/02/27 19:37:47 wiz Exp $
|
||||
|
||||
--- scsh/rdelim.scm.orig Sun Oct 1 07:27:57 2000
|
||||
+++ scsh/rdelim.scm Sun Oct 1 07:28:50 2000
|
||||
@@ -192,7 +192,7 @@
|
||||
(values c (- i start)))
|
||||
|
||||
((>= i end) ; Filled the buffer.
|
||||
- (if gobble? (read-char port))
|
||||
+ ; [loses one character at end of full line buffer] (if gobble? (read-char port))
|
||||
(values #f (- i start)))
|
||||
|
||||
(else (string-set! buf i (read-char port))
|
12
shells/scsh/patches/patch-an
Normal file
12
shells/scsh/patches/patch-an
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-an,v 1.1 2001/02/27 19:37:47 wiz Exp $
|
||||
|
||||
--- scsh/scsh-package.scm.orig Sun Oct 1 22:00:10 2000
|
||||
+++ scsh/scsh-package.scm Sun Oct 1 22:01:34 2000
|
||||
@@ -178,6 +178,7 @@
|
||||
|
||||
re-level-0
|
||||
rx-syntax
|
||||
+ let-match-package
|
||||
|
||||
string-lib
|
||||
|
9
shells/scsh/patches/patch-ao
Normal file
9
shells/scsh/patches/patch-ao
Normal file
|
@ -0,0 +1,9 @@
|
|||
$NetBSD: patch-ao,v 1.1 2001/02/27 19:37:48 wiz Exp $
|
||||
|
||||
--- scsh/rdelim.c.orig Thu Oct 5 15:45:04 2000
|
||||
+++ scsh/rdelim.c Thu Oct 5 15:46:20 2000
|
||||
@@ -1,3 +1,4 @@
|
||||
+/* this comment added so that BSD make DTRT after we touch scsh/rdelim.scm */
|
||||
/* This is an Scheme48/C interface file,
|
||||
** automatically generated by cig.
|
||||
*/
|
|
@ -9,15 +9,15 @@ rules.
|
|||
|
||||
Scsh is also a full implementation of R4RS Scheme with some
|
||||
non-standard behavior (required for scripting). As a result, a wide
|
||||
varity of exiting Scheme code can be used.
|
||||
variety of existing Scheme code can be used.
|
||||
|
||||
The underlying Scheme implementation is a virtual machine for compact
|
||||
byte code.
|
||||
|
||||
The name of the installed program is "scsh", the manpage is scsh(1),
|
||||
other documentation is in (/usr/local/)lib/scsh/doc
|
||||
other documentation is in (/usr/pkg/)lib/scsh/doc
|
||||
|
||||
To load slib, install slib into /usr/local/lib/slib and run
|
||||
To load slib, install slib into (/usr/pkg/)lib/slib and run
|
||||
(load "slib-init.scm")
|
||||
in scsh. It requires no additional setup (paths or such).
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 1998/05/09 00:14:24 hubertf Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2001/02/27 19:37:48 wiz Exp $
|
||||
bin/scsh
|
||||
man/man1/scsh.1.gz
|
||||
include/scheme48.h
|
||||
lib/scsh/big/array.scm
|
||||
lib/scsh/big/big-util.scm
|
||||
lib/scsh/big/bigbit.scm
|
||||
|
@ -42,6 +42,7 @@ lib/scsh/doc/scsh-manual/network.tex
|
|||
lib/scsh/doc/scsh-manual/procnotation.tex
|
||||
lib/scsh/doc/scsh-manual/rdelim.tex
|
||||
lib/scsh/doc/scsh-manual/running.tex
|
||||
lib/scsh/doc/scsh-manual/sre.tex
|
||||
lib/scsh/doc/scsh-manual/strings.tex
|
||||
lib/scsh/doc/scsh-manual/syscalls.tex
|
||||
lib/scsh/doc/scsh-manual/test.tex
|
||||
|
@ -128,6 +129,42 @@ lib/scsh/opt/analyze.scm
|
|||
lib/scsh/opt/expand.scm
|
||||
lib/scsh/opt/inline.scm
|
||||
lib/scsh/opt/tst.scm
|
||||
lib/scsh/scsh/rx/cond-package.scm
|
||||
lib/scsh/scsh/rx/let-match.scm
|
||||
lib/scsh/scsh/rx/loadem.scm
|
||||
lib/scsh/scsh/rx/modules.scm
|
||||
lib/scsh/scsh/rx/oldfuns.scm
|
||||
lib/scsh/scsh/rx/packages-old.scm
|
||||
lib/scsh/scsh/rx/packages-old2.scm
|
||||
lib/scsh/scsh/rx/packages.scm
|
||||
lib/scsh/scsh/rx/parse.scm
|
||||
lib/scsh/scsh/rx/posixstr.scm
|
||||
lib/scsh/scsh/rx/re-fold.scm
|
||||
lib/scsh/scsh/rx/re-high.scm
|
||||
lib/scsh/scsh/rx/re-low.scm
|
||||
lib/scsh/scsh/rx/re-subst.scm
|
||||
lib/scsh/scsh/rx/re-syntax.scm
|
||||
lib/scsh/scsh/rx/re.scm
|
||||
lib/scsh/scsh/rx/regress.scm
|
||||
lib/scsh/scsh/rx/rx-lib.scm
|
||||
lib/scsh/scsh/rx/simp.scm
|
||||
lib/scsh/scsh/rx/spencer.scm
|
||||
lib/scsh/scsh/rx/test.scm
|
||||
lib/scsh/scsh/lib/ccp-pack.scm
|
||||
lib/scsh/scsh/lib/ccp.scm
|
||||
lib/scsh/scsh/lib/list-lib.scm
|
||||
lib/scsh/scsh/lib/list-pack.scm
|
||||
lib/scsh/scsh/lib/string-lib.scm
|
||||
lib/scsh/scsh/lib/string-pack.scm
|
||||
lib/scsh/scsh/machine/bufpol.scm
|
||||
lib/scsh/scsh/machine/errno.scm
|
||||
lib/scsh/scsh/machine/fdflags.scm
|
||||
lib/scsh/scsh/machine/netconst.scm
|
||||
lib/scsh/scsh/machine/packages.scm
|
||||
lib/scsh/scsh/machine/signals.scm
|
||||
lib/scsh/scsh/machine/time_dep.scm
|
||||
lib/scsh/scsh/machine/tty-consts.scm
|
||||
lib/scsh/scsh/machine/waitcodes.scm
|
||||
lib/scsh/scsh/awk.scm
|
||||
lib/scsh/scsh/char-set.scm
|
||||
lib/scsh/scsh/db.scm
|
||||
|
@ -153,10 +190,10 @@ lib/scsh/scsh/ndbm.scm
|
|||
lib/scsh/scsh/network.scm
|
||||
lib/scsh/scsh/pty.scm
|
||||
lib/scsh/scsh/newports.scm
|
||||
lib/scsh/scsh/old-static.scm
|
||||
lib/scsh/scsh/oldtop.scm
|
||||
lib/scsh/scsh/procobj.scm
|
||||
lib/scsh/scsh/rdelim.scm
|
||||
lib/scsh/scsh/re.scm
|
||||
lib/scsh/scsh/rw.scm
|
||||
lib/scsh/scsh/scsh-condition.scm
|
||||
lib/scsh/scsh/scsh-interfaces.scm
|
||||
|
@ -167,7 +204,9 @@ lib/scsh/scsh/scsh.scm
|
|||
lib/scsh/scsh/select.scm
|
||||
lib/scsh/scsh/sighandlers.scm
|
||||
lib/scsh/scsh/startup.scm
|
||||
lib/scsh/scsh/static-heap.scm
|
||||
lib/scsh/scsh/static.scm
|
||||
lib/scsh/scsh/static1.scm
|
||||
lib/scsh/scsh/stringcoll.scm
|
||||
lib/scsh/scsh/syntax-helpers.scm
|
||||
lib/scsh/scsh/syntax.scm
|
||||
|
@ -223,6 +262,7 @@ lib/scsh/emacs/cmuscheme48.el
|
|||
lib/scsh/emacs/cmushell.el
|
||||
lib/scsh/emacs/comint.el
|
||||
lib/scsh/emacs/jar-hacks.el
|
||||
man/man1/scsh.1
|
||||
@exec ln -fs %D/lib/scsh/doc %D/share/doc/scsh
|
||||
@unexec rm -f %D/share/doc/scsh
|
||||
@dirrm lib/scsh/emacs
|
||||
|
@ -234,6 +274,9 @@ lib/scsh/emacs/jar-hacks.el
|
|||
@dirrm lib/scsh/link
|
||||
@dirrm lib/scsh/misc
|
||||
@dirrm lib/scsh/opt
|
||||
@dirrm lib/scsh/scsh/rx
|
||||
@dirrm lib/scsh/scsh/lib
|
||||
@dirrm lib/scsh/scsh/machine
|
||||
@dirrm lib/scsh/scsh
|
||||
@dirrm lib/scsh/rts
|
||||
@dirrm lib/scsh/vm
|
||||
|
|
Loading…
Reference in a new issue