removed py-expect
This commit is contained in:
parent
21da2ccdbf
commit
7adda8eda4
11 changed files with 1 additions and 322 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.2908 2019/09/09 12:59:06 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.2909 2019/09/11 10:53:53 adam Exp $
|
||||
#
|
||||
|
||||
COMMENT= Development utilities
|
||||
|
@ -2108,7 +2108,6 @@ SUBDIR+= py-entrypoints
|
|||
SUBDIR+= py-enum34
|
||||
SUBDIR+= py-exam
|
||||
SUBDIR+= py-execnet
|
||||
SUBDIR+= py-expect
|
||||
SUBDIR+= py-expressions
|
||||
SUBDIR+= py-extras
|
||||
SUBDIR+= py-extratools
|
||||
|
|
|
@ -1 +0,0 @@
|
|||
python module providing access to the expect toolkit for program automation
|
|
@ -1,48 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.29 2019/09/02 13:19:39 adam Exp $
|
||||
|
||||
DISTNAME= ExpectPy-1.9b1
|
||||
PKGNAME= ${PYPKGPREFIX}-expect-1.9b1
|
||||
PKGREVISION= 5
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=expectpy/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://sourceforge.net/projects/expectpy/
|
||||
COMMENT= Expect module for Python
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-python=${BUILDLINK_PREFIX.${PYPACKAGE}} \
|
||||
--with-expect=${BUILDLINK_PREFIX.tcl-expect} \
|
||||
--with-tcl --enable-shared
|
||||
CONFIGURE_ENV+= PYTHON=${PYTHONBIN:Q}
|
||||
CONFIGURE_ENV+= PYTH_CONFIGDIR=${BUILDLINK_PREFIX.${PYPACKAGE}}/${PYLIB}/config
|
||||
INSTALL_TARGET= installshared
|
||||
PY_PATCHPLIST= yes
|
||||
PLIST_SUBST+= PYLIB=${PYLIB:Q} PYPKGPREFIX=${PYPKGPREFIX:Q}
|
||||
PYTHON_VERSIONS_ACCEPTED= 27 # not yet ported as of 1.9b1
|
||||
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/${PYPKGPREFIX}-expect
|
||||
EXAMPLESFILES= ask.py glob.py ping.py telnet.py xping.py
|
||||
|
||||
INSTALLATION_DIRS= lib/python${PYVERSSUFFIX}/lib-dynload
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${DESTDIR:Q}${EXAMPLESDIR}
|
||||
.for f in ${EXAMPLESFILES}
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/${f} \
|
||||
${DESTDIR:Q}${EXAMPLESDIR}
|
||||
.endfor
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${OPSYS} == "DragonFly"
|
||||
PTHREAD_AUTO_VARS= yes
|
||||
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.endif
|
||||
|
||||
.include "../../lang/tcl/buildlink3.mk"
|
||||
.include "../../lang/tcl-expect/buildlink3.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,7 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2010/07/21 14:11:16 joerg Exp $
|
||||
${PYLIB}/lib-dynload/ExpectPymodule.la
|
||||
share/examples/${PYPKGPREFIX}-expect/ask.py
|
||||
share/examples/${PYPKGPREFIX}-expect/glob.py
|
||||
share/examples/${PYPKGPREFIX}-expect/ping.py
|
||||
share/examples/${PYPKGPREFIX}-expect/telnet.py
|
||||
share/examples/${PYPKGPREFIX}-expect/xping.py
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.11 2015/11/03 03:29:07 agc Exp $
|
||||
|
||||
SHA1 (ExpectPy-1.9b1.tar.gz) = f43fcd53901f327dc8acf0650dbfe45b274a8d7d
|
||||
RMD160 (ExpectPy-1.9b1.tar.gz) = d0e586a987db1c6eb22008519483081f7278be20
|
||||
SHA512 (ExpectPy-1.9b1.tar.gz) = 3babcf0b9b2fec56e10e8192489b80bcd86a50f3c0edbef38cace1017bcf4d8d55ac0bf7509ae9bf2db8c03ac13d2568e9f5d5e6a69250b13b56261ee88a002a
|
||||
Size (ExpectPy-1.9b1.tar.gz) = 149580 bytes
|
||||
SHA1 (patch-ab) = 67a2cf831973fa39b83aea61142c0682de60cd27
|
||||
SHA1 (patch-ac) = 0ff7162129a84fbc913a8b1240209387b922c2a8
|
||||
SHA1 (patch-ad) = d2809ac63abb65ad59586cc35ffcda1b70088bcb
|
||||
SHA1 (patch-ae) = 0f5190724d3b17e7b7f06f6408e1c9e7a3e66868
|
||||
SHA1 (patch-af) = 9ed0f60061d91a04788f8ad6974edc7e4d2e411b
|
||||
SHA1 (patch-ag) = 7e43133aeebee5c63716aefba8fd4e0d4b1ff6ce
|
|
@ -1,57 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2013/10/27 20:17:40 markd Exp $
|
||||
|
||||
--- configure.orig 2000-11-05 18:07:38.000000000 +0000
|
||||
+++ configure
|
||||
@@ -1357,7 +1357,7 @@ echo "$ac_t""$PYTH_vers" 1>&6
|
||||
# _multiply_ the python version major version by one thousand, but minor
|
||||
# version is only multiplied by one hundred (not really, but for m.n.p
|
||||
# version numbers, it works)
|
||||
-PYTH_versnum=`echo $PYTH_vers | sed 's/b[0-9]//' |
|
||||
+PYTH_versnum=`echo $PYTH_vers | sed 's/b[0-9]//;s/p/\./' |
|
||||
sed 's/^[0-9]\./0&/;s/\.\([0-9]\)\./.0\1./g;s/\.\([0-9]\)$/\.0\1/;s/\.//g' |
|
||||
sed 's/^\(....\)$/\100/'`
|
||||
|
||||
@@ -1395,20 +1395,20 @@ echo "$ac_t""$EXP_vers" 1>&6
|
||||
|
||||
echo $ac_n "checking Expect library location""... $ac_c" 1>&6
|
||||
echo "configure:1398: checking Expect library location" >&5
|
||||
-if test -n "${EXP_LIB}"; then
|
||||
- if test x${enable_forcea:+X} = xX -a -f "${EXP_LIB}"; then
|
||||
- :
|
||||
- elif test x${enable_forcea:+X} = xX; then
|
||||
- { echo "configure: error: Cannot find Expect library" 1>&2; exit 1; }
|
||||
- else
|
||||
- f="${EXP_LIBDIR}/lib${EXP_LIB}.*"
|
||||
- if test "`echo $f`" = "$f"; then
|
||||
- { echo "configure: error: Cannot find Expect library" 1>&2; exit 1; }
|
||||
- fi
|
||||
- fi
|
||||
-else
|
||||
- EXP_LIB="expect${EXP_VERS}"
|
||||
-fi
|
||||
+#if test -n "${EXP_LIB}"; then
|
||||
+# if test x${enable_forcea:+X} = xX -a -f "${EXP_LIB}"; then
|
||||
+# :
|
||||
+# elif test x${enable_forcea:+X} = xX; then
|
||||
+# { echo "configure: error: Cannot find Expect library" 1>&2; exit 1; }
|
||||
+# else
|
||||
+# f="${EXP_LIBDIR}/lib${EXP_LIB}.*"
|
||||
+# if test "`echo $f`" = "$f"; then
|
||||
+# { echo "configure: error: Cannot find Expect library" 1>&2; exit 1; }
|
||||
+# fi
|
||||
+# fi
|
||||
+#else
|
||||
+ EXP_LIB="expect`echo ${EXP_VERS} | sed -e 's,\.,,'`"
|
||||
+#fi
|
||||
echo "$ac_t""$EXP_LIB" 1>&6
|
||||
|
||||
|
||||
@@ -1542,7 +1542,7 @@ case ${EXP_VERS} in
|
||||
esac
|
||||
case ${EXP_VERS} in
|
||||
5.31*|5.32*)
|
||||
- if ! -f $with_expect/expect_cf.h ; then
|
||||
+ if [ ! -f $with_expect/include/expect.h ] ; then
|
||||
{ echo "configure: error: Must build with Expect's source tree" 1>&2; exit 1; }
|
||||
fi
|
||||
;;
|
|
@ -1,24 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2001/03/21 23:36:07 jwise Exp $
|
||||
--- explib/exp_clib.c.orig Wed Mar 21 12:00:27 2001
|
||||
+++ explib/exp_clib.c Wed Mar 21 11:59:49 2001
|
||||
@@ -7,7 +7,10 @@
|
||||
would appreciate credit if this program or parts of it are used.
|
||||
*/
|
||||
|
||||
-#include "expect_cf.h"
|
||||
+#define TRUE 1
|
||||
+#define FALSE 0
|
||||
+
|
||||
+/* #include "expect_cf.h" */
|
||||
#include <stdio.h>
|
||||
#include <setjmp.h>
|
||||
#ifdef HAVE_INTTYPES_H
|
||||
@@ -634,7 +637,7 @@
|
||||
*/
|
||||
|
||||
#include "expect.h"
|
||||
-#include "exp_int.h"
|
||||
+/* #include "exp_int.h" */
|
||||
|
||||
/* exp_glob.c - expect functions for doing glob
|
||||
*
|
|
@ -1,56 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.3 2010/07/21 14:11:16 joerg Exp $
|
||||
--- Makefile.in.orig 2000-10-20 14:06:30.000000000 +0200
|
||||
+++ Makefile.in
|
||||
@@ -29,8 +29,8 @@ PYTHLIB = @PYTH_LIBDIR@/config
|
||||
PYTHCNFG = @PYTH_CONFIG@
|
||||
PYCNF = @PYCNF@
|
||||
|
||||
-CC = @CC@
|
||||
-LD = $(CC)
|
||||
+CC = ${LIBTOOL} --mode=compile @CC@
|
||||
+LD = ${LIBTOOL} --mode=link @CC@
|
||||
RANLIB = @RANLIB@
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
@@ -38,14 +38,14 @@ RM = @RM@ -f
|
||||
LN_S = @LN_S@
|
||||
LDEXE = @LDEXE@
|
||||
|
||||
-SO = @SO@
|
||||
-LDSHARED = @LDSHARED@
|
||||
-CCSHARED = @CCSHARED@
|
||||
+SO = .la
|
||||
+LDSHARED = ${LIBTOOL} --mode=link @CC@
|
||||
+CCSHARED = ${LIBTOOL} --mode=compile @CC@
|
||||
|
||||
FRC =
|
||||
CPPFLAGS = -I. -I$(srcdir) @CPPFLAGS@
|
||||
CFLAGS = @CFLAGS@
|
||||
-LDFLAGS = @LDFLAGS@
|
||||
+LDFLAGS = @LDFLAGS@ -module -rpath ${INSTLIBDIR}
|
||||
LIBS = $(EXPLIB) @LIBS@
|
||||
INSTLIBDIR = @PYTH_SHLIBDIR@
|
||||
|
||||
@@ -109,8 +109,8 @@ python: $(MODNAME)module.a pyconfig.o $(
|
||||
$(LDEXE) $(LDFLAGS) -o $@ $(PYTH_OBJS) pyconfig.o \
|
||||
$(MODNAME)module.a $(EXPSUBLIB).a $(LIBS)
|
||||
|
||||
-$(MODNAME)module$(SO): $(OBJS:.o=.os) $(EXPSUBLIB).as
|
||||
- $(LDSHARED) $(LDFLAGS) -o $@ $(OBJS:.o=.os) $(EXPSUBLIB).as $(LIBS)
|
||||
+$(MODNAME)module$(SO): $(OBJS) $(EXPSUBLIB).a
|
||||
+ $(LDSHARED) $(LDFLAGS) -o $@ $(OBJS:.o=.lo) $(EXPSUBLIB).la $(LIBS)
|
||||
$(MODNAME)module.a: $(OBJS)
|
||||
$(AR) $(ARFLAGS) $@ $(OBJS)
|
||||
$(RANLIB) $@
|
||||
@@ -141,9 +141,9 @@ explib/libexplib.a explib/libexplib.as e
|
||||
install:
|
||||
@echo Use either installbin or installshared
|
||||
installbin: python
|
||||
- $(INSTALL_PROGRAM) python $(exec_prefix)/bin/python.exppy
|
||||
+ $(INSTALL_PROGRAM) python $(DESTDIR)$(exec_prefix)/bin/python.exppy
|
||||
installshared: $(MODNAME)module$(SO)
|
||||
- $(INSTALL_PROGRAM) $(MODNAME)module$(SO) $(INSTLIBDIR)
|
||||
+ ${LIBTOOL} --mode=install $(BSD_INSTALL_LIB) $(MODNAME)module$(SO) $(DESTDIR)$(INSTLIBDIR)
|
||||
uninstall:
|
||||
|
||||
clean::
|
|
@ -1,23 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.2 2002/01/19 15:03:37 drochner Exp $
|
||||
|
||||
--- explib/Makefile.in.orig Sat Nov 4 14:27:16 2000
|
||||
+++ explib/Makefile.in Sat Jan 19 15:58:50 2002
|
||||
@@ -13,15 +13,15 @@
|
||||
OBJS = exp_clib.o $(EXPLIB_REGEXP)
|
||||
DUMMYOBJS= dummy.o
|
||||
|
||||
-TARGET = libexplib.a libexplib.as
|
||||
+TARGET = libexplib.a
|
||||
all: $(TARGET)
|
||||
|
||||
libexplib.a: $(OBJS)
|
||||
- ar r $@ $(OBJS)
|
||||
+ ${LD} -o libexplib.la $(OBJS:.o=.lo)
|
||||
libexplib.as: $(OBJS:.o=.os)
|
||||
ar r $@ $(OBJS:.o=.os)
|
||||
libdummy.a: $(DUMMYOBJS)
|
||||
- ar r $@ $(DUMMYOBJS)
|
||||
+ ${LD} -o libdummy.la $(DUMMYOBJS:.o=.lo)
|
||||
libdummy.as: $(DUMMYOBJS:.o=.os)
|
||||
ar r $@ $(DUMMYOBJS:.o=.os)
|
||||
|
|
@ -1,71 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.2 2013/10/27 20:17:40 markd Exp $
|
||||
--- expvers.py.~1~ Fri Jun 14 13:09:31 2002
|
||||
+++ expvers.py Fri Jun 14 13:36:32 2002
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
import sys
|
||||
import posix
|
||||
-import strop
|
||||
+import string
|
||||
|
||||
def exists(path):
|
||||
try:
|
||||
@@ -27,12 +27,12 @@ def is_executable(path):
|
||||
def pathjoin(dir, base):
|
||||
return '%s/%s' % (dir, base)
|
||||
def pathsplit(path):
|
||||
- p = strop.rfind(path, '/')
|
||||
+ p = string.rfind(path, '/')
|
||||
if p >= 0:
|
||||
return (path[:p], path[p+1:])
|
||||
return ('', path)
|
||||
def splitext(path):
|
||||
- p = strop.rfind(path, '.')
|
||||
+ p = string.rfind(path, '.')
|
||||
if p >= 0:
|
||||
return (path[:p], path[p:])
|
||||
return (path, '')
|
||||
@@ -64,21 +64,21 @@ def ticks(*cmdargs):
|
||||
wpid = None
|
||||
while wpid != pid:
|
||||
(wpid, wstat) = posix.wait()
|
||||
- v = strop.join(l)[:-1]
|
||||
+ v = string.join(l)[:-1]
|
||||
if wstat:
|
||||
raise RuntimeError, v
|
||||
return v
|
||||
|
||||
def expect_expr(*args):
|
||||
global expect_prog
|
||||
- cmd = 'puts [%s]' % strop.join(map(str, args))
|
||||
+ cmd = 'puts [%s]' % string.join(map(str, args))
|
||||
result = ticks(expect_prog, '-c', cmd)
|
||||
return result
|
||||
|
||||
def get_version(prog):
|
||||
version = expect_expr('exp_version')
|
||||
- if strop.count(version, '.') > 1:
|
||||
- p = strop.rfind(version, '.')
|
||||
+ if string.count(version, '.') > 1:
|
||||
+ p = string.rfind(version, '.')
|
||||
return (version[:p], version)
|
||||
else:
|
||||
return (version, version)
|
||||
@@ -105,7 +105,7 @@
|
||||
raise SystemExit, "Cannot find expect interpreter"
|
||||
del d
|
||||
basevers, fullvers = get_version(expect_prog)
|
||||
- libdir = pathjoin(basedir, pathjoin('lib', 'expect' + basevers))
|
||||
+ libdir = pathjoin(basedir, pathjoin('lib', pathjoin('tcl', 'expect' + basevers)))
|
||||
del f
|
||||
|
||||
else:
|
||||
@@ -115,7 +115,7 @@ else:
|
||||
elif posix.environ.has_key('EXPECT'):
|
||||
expect_prog = posix.environ['EXPECT']
|
||||
else:
|
||||
- path = strop.split(posix.environ['PATH'], ':')
|
||||
+ path = string.split(posix.environ['PATH'], ':')
|
||||
for dir in path:
|
||||
f = pathjoin(dir, 'expect')
|
||||
if is_executable(f):
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.1 2007/10/10 18:09:31 rillig Exp $
|
||||
|
||||
--- expect.c.orig 2000-11-04 01:35:57.000000000 +0000
|
||||
+++ expect.c 2007-10-10 18:07:13.000000000 +0000
|
||||
@@ -1412,6 +1412,8 @@ ExpSet_reset(self, args)
|
||||
return Py_None;
|
||||
}
|
||||
|
||||
+static PyObject *ExpSet_getattr(ExpSetObject *, char *);
|
||||
+
|
||||
/* Convert the registered Expect variables to a Python dictionary.
|
||||
Changing the dictionary will not affect the Expect variables.
|
||||
*/
|
||||
@@ -1421,7 +1423,6 @@ ExpSet_todict(self, args)
|
||||
PyObject *args;
|
||||
{ struct pyexp_variable_map *var;
|
||||
PyObject *dict, *item;
|
||||
- static PyObject *ExpSet_getattr(ExpSetObject *, char *);
|
||||
|
||||
if ((dict = PyDict_New()) == NULL)
|
||||
return NULL;
|
Loading…
Reference in a new issue