Update to 0.9.91.5:

[2007/08/26] nspluginwrapper 0.9.91.5

Fix a memory leak in NPP_Destroy()
Fix DiamondX XEmbed example plugin
Fix focus problems (Debian bug #435912)
Add support for 64-bit plugins (Martin Stransky)
Add support for newer NPAPI 0.17 functions and variables
Add support for broken 64-bit Konqueror versions (run-time detect)

[2007/04/03] nspluginwrapper 0.9.91.4

Dont try to wrap native plugins
Fix build on NetBSD (David Brownlee)
Fix build on DragonFlyBSD (Steve OHara-Smith)
Fix build on Linux systems with SSP enabled by default (Kristian Hermansen)
This commit is contained in:
xtraeme 2007-09-09 17:06:03 +00:00
parent 9fab7c8c35
commit 7addc357ab
6 changed files with 9 additions and 163 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.6 2007/07/31 17:59:28 jlam Exp $
# $NetBSD: Makefile,v 1.7 2007/09/09 17:06:03 xtraeme Exp $
#
DISTNAME= nspluginwrapper-0.9.91.3
PKGREVISION= 1
DISTNAME= nspluginwrapper-0.9.91.5
CATEGORIES= www
MASTER_SITES= http://gwenole.beauchesne.info/projects/nspluginwrapper/files/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,12 +1,8 @@
$NetBSD: distinfo,v 1.2 2007/04/02 22:38:44 abs Exp $
$NetBSD: distinfo,v 1.3 2007/09/09 17:06:03 xtraeme Exp $
SHA1 (nspluginwrapper-0.9.91.3.tar.bz2) = bcd1e1a2260de022c6d5bc2bff802c8d381805d2
RMD160 (nspluginwrapper-0.9.91.3.tar.bz2) = 660d928b508c342003f9ff3483ce8b8d25919e90
Size (nspluginwrapper-0.9.91.3.tar.bz2) = 257648 bytes
SHA1 (nspluginwrapper-i386-0.9.91.3-1.x86_64.rpm) = 7e242b356f417d6e60cb00eaec1b214010737c11
RMD160 (nspluginwrapper-i386-0.9.91.3-1.x86_64.rpm) = 62835a2d318363fe97ca79842f2caebbd0f9b94a
Size (nspluginwrapper-i386-0.9.91.3-1.x86_64.rpm) = 50757 bytes
SHA1 (patch-aa) = 188cc6c7c4c60196db7634daa1fe5dd1fe2eb87f
SHA1 (patch-ab) = 84082438c3cdac30de337137e06a707223ef85ce
SHA1 (patch-ac) = d3960bc25f49db5d36f7781e0dfbe8b795744ae9
SHA1 (patch-ad) = 806cc69b99b1f087724469693f0a853f8f479184
SHA1 (nspluginwrapper-0.9.91.5.tar.bz2) = f5f0126741fec8db2340e6f58d7390cd8c9ca862
RMD160 (nspluginwrapper-0.9.91.5.tar.bz2) = 8f88f3f3e5703f02130c1c3bb3627e07eb7eb7ca
Size (nspluginwrapper-0.9.91.5.tar.bz2) = 273331 bytes
SHA1 (nspluginwrapper-i386-0.9.91.5-1.x86_64.rpm) = 079e7399517a1a6c8434106c68b37d65b818f2f9
RMD160 (nspluginwrapper-i386-0.9.91.5-1.x86_64.rpm) = df86533ccda904c7c1f59172a3619d683ca6976b
Size (nspluginwrapper-i386-0.9.91.5-1.x86_64.rpm) = 52386 bytes

View file

@ -1,53 +0,0 @@
$NetBSD: patch-aa,v 1.2 2007/04/02 22:38:44 abs Exp $
--- configure.orig 2007-03-04 15:01:22.000000000 +0000
+++ configure
@@ -108,6 +108,9 @@ case "$opt" in
--with-cxx=*)
cxx=`echo $opt | cut -d '=' -f 2`
;;
+--x11=*)
+ x_base_dirs=`echo $opt | cut -d '=' -f 2`
+ ;;
esac
done
@@ -278,11 +281,15 @@ EOF
rm -f $TMPC $TMPE
fi
+if test -z "$x_base_dirs"; then
+ x_base_dirs="
+ /usr
+ /usr/X11R6
+ /usr/local/X11R6
+ $prefix
+ "
+fi
# check for X11 base dir
-x_base_dirs='
-/usr
-/usr/X11R6
-/usr/local/X11R6'
for dir in $x_base_dirs; do
x_include_dir="$dir/include"
if test -f $x_include_dir/X11/Intrinsic.h; then
@@ -415,6 +422,7 @@ echo " --with-lib64=NAME use
echo " --with-biarch build both 32-bit and 64-bit components at once"
echo " --with-cc=CC use C compiler CC [$cc]"
echo " --with-cxx=CXX use C++ compiler CXX [$cxx]"
+echo " --x11=PREFIX use X11 dir"
echo ""
echo "NOTE: The object files are built at the place where configure is launched"
exit 1
@@ -458,6 +466,10 @@ if test "$host_os" = "linux"; then
echo "OS=linux" >> $config_mak
echo "#define HOST_LINUX 1" >> $config_h
echo "#define HOST_OS \"linux\"" >> $config_h
+elif test "$host_os" = "dragonfly"; then
+ echo "OS=dragonfly" >> $config_mak
+ echo "#define HOST_DRAGONFLY 1" >> $config_h
+ echo "#define HOST_OS \"dragonfly\"" >> $config_h
elif test "$host_os" = "freebsd"; then
echo "OS=freebsd" >> $config_mak
echo "#define HOST_FREEBSD 1" >> $config_h

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2007/03/22 22:33:45 abs Exp $
--- src/npw-wrapper.c.orig 2007-03-04 15:01:22.000000000 +0000
+++ src/npw-wrapper.c
@@ -25,6 +25,7 @@
#include <string.h>
#include <limits.h>
#include <errno.h>
+#include <signal.h>
#include <unistd.h>
#include <pthread.h>
#include <semaphore.h>

View file

@ -1,33 +0,0 @@
$NetBSD: patch-ac,v 1.1 2007/04/02 22:38:44 abs Exp $
--- ./src/npw-config.c.orig 2007-04-01 16:28:47.000000000 +0100
+++ ./src/npw-config.c
@@ -124,6 +124,14 @@ static const char *get_system_mozilla_pl
};
dirs = freebsd_dirs;
}
+#elif defined(__DragonFly__)
+ {
+ static const char *dragonfly_dirs[] = {
+ "/usr/pkg/" LIB "/mozilla/plugins",
+ "/usr/pkg/" LIB "/firefox/plugins",
+ };
+ dirs = dragonfly_dirs;
+ }
#elif defined(__NetBSD__)
{
static const char *netbsd_dirs[] = {
@@ -206,6 +214,13 @@ static const char **get_mozilla_plugin_d
"/usr/local/lib/npapi/linux-flashplugin",
"/usr/X11R6/Adobe/Acrobat7.0/ENU/Browser/intellinux",
#endif
+#if defined(__DragonFly__)
+ "/usr/pkg/lib/netscape/plugins",
+ "/usr/pkg/lib/firefox/plugins",
+ "/usr/pkg/lib/RealPlayer/mozilla",
+ "/usr/pkg/Acrobat5/Browsers/intellinux",
+ "/usr/pkg/Acrobat7/Browser/intellinux",
+#endif
#if defined(__NetBSD__)
"/usr/pkg/lib/netscape/plugins",
"/usr/pkg/lib/firefox/plugins",

View file

@ -1,51 +0,0 @@
$NetBSD: patch-ad,v 1.1 2007/04/02 22:38:44 abs Exp $
--- Makefile.orig 2007-03-04 15:01:22.000000000 +0000
+++ Makefile
@@ -46,6 +46,9 @@ X_LDFLAGS = -L$(x11prefix)/$(lib64) -lX1
ifeq ($(OS),netbsd)
X_LDFLAGS += -Wl,--rpath,$(x11prefix)/$(lib64)
endif
+ifeq ($(OS),dragonfly)
+X_LDFLAGS += -Wl,--rpath,$(x11prefix)/$(lib64)
+endif
ARCH_32 = $(ARCH)
ifeq ($(biarch), yes)
@@ -78,7 +81,11 @@ npwrapper_RAWSRCS = npw-wrapper.c npw-rp
npwrapper_SOURCES = $(npwrapper_RAWSRCS:%.c=$(SRC_PATH)/src/%.c)
npwrapper_OBJECTS = $(npwrapper_RAWSRCS:%.c=npwrapper-%.os)
npwrapper_CFLAGS = $(CFLAGS) $(X_CFLAGS) $(MOZILLA_CFLAGS) $(GLIB_CFLAGS)
+ifeq ($(OS),dragonfly)
+npwrapper_LDFLAGS = $(X_LDFLAGS) -pthread
+else
npwrapper_LDFLAGS = $(X_LDFLAGS) -lpthread
+endif
npwrapper_LDFLAGS += $(GLIB_LDFLAGS)
npviewer_PROGRAM = npviewer.bin
@@ -97,7 +104,11 @@ npviewer_CFLAGS += $(GTK_CFLAGS)
npviewer_LDFLAGS = $(GTK_LDFLAGS) $(X_LDFLAGS)
endif
npviewer_CFLAGS += $(MOZILLA_CFLAGS)
+ifeq ($(OS),dragonfly)
+npviewer_LDFLAGS += $(libdl_LDFLAGS) -pthread
+else
npviewer_LDFLAGS += $(libdl_LDFLAGS) -lpthread
+endif
ifeq ($(TARGET_ARCH),i386)
npviewer_MAPFILE = $(SRC_PATH)/src/npw-viewer.map
endif
@@ -128,6 +139,12 @@ ifeq ($(OS),netbsd)
# XXX use the ELF decoder for native plugins too?
npconfig_LDFLAGS += -lpthread
endif
+ifeq ($(OS),dragonfly)
+# We will try to dlopen() the native plugin library. If that lib is
+# linked against libpthread, then so must our program too.
+# XXX use the ELF decoder for native plugins too?
+npconfig_LDFLAGS += -pthread
+endif
nploader_PROGRAM = npviewer
nploader_RAWSRCS = npw-viewer.sh