Fix readline.h problem on 1.6 (tested with 1.5.3 also). Looked at by

hubertf.
This commit is contained in:
cjep 2002-06-10 06:49:08 +00:00
parent 0d97371805
commit 7b5f4e1f52
4 changed files with 7 additions and 26 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2001/09/27 23:18:31 jlam Exp $ # $NetBSD: Makefile,v 1.7 2002/06/10 06:49:08 cjep Exp $
# #
DISTNAME= sftp-0.5 DISTNAME= sftp-0.5
@ -20,4 +20,5 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/sftp.1 ${PREFIX}/man/man1/sftp.1 ${INSTALL_MAN} ${WRKSRC}/sftp.1 ${PREFIX}/man/man1/sftp.1
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/README.sftp ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/README.sftp
.include "../../devel/readline/buildlink.mk"
.include "../../mk/bsd.pkg.mk" .include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.2 2001/04/21 11:23:32 wiz Exp $ $NetBSD: distinfo,v 1.3 2002/06/10 06:49:08 cjep Exp $
SHA1 (sftp-0.5.tar.gz) = e75571e46eda19da1b42fdd5d642822b3e302b84 SHA1 (sftp-0.5.tar.gz) = e75571e46eda19da1b42fdd5d642822b3e302b84
Size (sftp-0.5.tar.gz) = 26072 bytes Size (sftp-0.5.tar.gz) = 26072 bytes
SHA1 (patch-aa) = ae15d542a80aa1715027db38c248bcec94017901 SHA1 (patch-aa) = 1806fd8d4ddbf34d67aa139689aadf41b3e1bb3d
SHA1 (patch-ab) = 59750348382485ed043e2a0738bb4553bf31b812

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.1 1999/12/27 23:53:44 hubertf Exp $ $NetBSD: patch-aa,v 1.2 2002/06/10 06:49:09 cjep Exp $
--- Makefile.in.orig Tue Dec 28 00:40:39 1999 --- Makefile.in.orig Thu Nov 18 01:14:12 1999
+++ Makefile.in Tue Dec 28 00:42:39 1999 +++ Makefile.in
@@ -1,6 +1,6 @@ @@ -1,6 +1,6 @@
CC = @CC@ CC = @CC@
CFLAGS = @CFLAGS@ CFLAGS = @CFLAGS@

View file

@ -1,19 +0,0 @@
$NetBSD: patch-ab,v 1.1 1999/12/27 23:53:45 hubertf Exp $
--- sftp.c.orig Tue Dec 28 00:36:29 1999
+++ sftp.c Tue Dec 28 00:39:46 1999
@@ -19,10 +19,14 @@
#include <sys/socket.h>
#include <sys/wait.h>
+#ifdef __NetBSD__
+#include <readline.h>
+#else /* __NetBSD__ */
#ifdef HAVE_LIBREADLINE
#include <readline/readline.h>
#include <readline/history.h>
#endif
+#endif /* __NetBSD__ */
#include "sftp.h"