py-gnupg: updated to 0.4.8
Switch to python-gnupg. This module allows easy access to GnuPG’s key management, encryption and signature functionality from Python programs. It is intended for use with Python 2.4 or greater.
This commit is contained in:
parent
0ca1969a41
commit
7b60c388ad
5 changed files with 38 additions and 22 deletions
|
@ -1,3 +1,2 @@
|
|||
GnuPGInterface is a Python module to interface with GnuPG. It
|
||||
concentrates on interacting with GnuPG via filehandles, providing
|
||||
access to control GnuPG via versatile and extensible means.
|
||||
This module allows easy access to GnuPG's key management, encryption and
|
||||
signature functionality from Python programs.
|
||||
|
|
|
@ -1,21 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.29 2022/01/10 09:11:20 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.30 2022/01/11 08:45:10 adam Exp $
|
||||
|
||||
DISTNAME= GnuPGInterface-0.3.2
|
||||
PKGNAME= ${PYPKGPREFIX}-gnupg-0.3.2
|
||||
PKGREVISION= 3
|
||||
DISTNAME= python-gnupg-0.4.8
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/^python-//}
|
||||
CATEGORIES= security python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=py-gnupg/}
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=p/python-gnupg/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://py-gnupg.sourceforge.net/
|
||||
COMMENT= Python module for GnuPG interface
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
HOMEPAGE= https://docs.red-dove.com/python-gnupg/
|
||||
COMMENT= Wrapper for the Gnu Privacy Guard
|
||||
LICENSE= modified-bsd
|
||||
|
||||
DEPENDS+= gnupg>=1.0.0:../../security/gnupg
|
||||
DEPENDS+= gnupg2>=2.2.0:../../security/gnupg2
|
||||
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2022/01/10 09:11:20 wiz Exp $
|
||||
${PYSITELIB}/GnuPGInterface.py
|
||||
${PYSITELIB}/GnuPGInterface.pyc
|
||||
${PYSITELIB}/GnuPGInterface.pyo
|
||||
@comment $NetBSD: PLIST,v 1.6 2022/01/11 08:45:10 adam Exp $
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
||||
${PYSITELIB}/gnupg.py
|
||||
${PYSITELIB}/gnupg.pyc
|
||||
${PYSITELIB}/gnupg.pyo
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.5 2021/10/26 11:17:45 nia Exp $
|
||||
$NetBSD: distinfo,v 1.6 2022/01/11 08:45:10 adam Exp $
|
||||
|
||||
BLAKE2s (GnuPGInterface-0.3.2.tar.gz) = 5e97aad503e659e7b9b75dfee7fb8249d1835e6105772726b01e6a883308be80
|
||||
SHA512 (GnuPGInterface-0.3.2.tar.gz) = 46c91f2391a1efd472fe08bc6abd71ec17a45dc9e051999d91ccc73da86b64094ef7d0fe3df12b2f58d714146f77fc2183944efa3aa604d8cff05a348ec19386
|
||||
Size (GnuPGInterface-0.3.2.tar.gz) = 19875 bytes
|
||||
BLAKE2s (python-gnupg-0.4.8.tar.gz) = 2b6712647f4c788ff128d3bbd19d6e15f9ef889b38c2a55363050440128478be
|
||||
SHA512 (python-gnupg-0.4.8.tar.gz) = fcaa121a356595328a26e8184280f859dfc2771b9692dcf28db2d9b0fdddc77d4c1238665a8e419758ec17320616e7741aacd3638e37d449b86fe5555beef1f6
|
||||
Size (python-gnupg-0.4.8.tar.gz) = 58696 bytes
|
||||
SHA1 (patch-gnupg.py) = e19fdeda942f17869f068709cd826d9ea5992bf9
|
||||
|
|
15
security/py-gnupg/patches/patch-gnupg.py
Normal file
15
security/py-gnupg/patches/patch-gnupg.py
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-gnupg.py,v 1.1 2022/01/11 08:45:11 adam Exp $
|
||||
|
||||
Look for gpg2 executable.
|
||||
|
||||
--- gnupg.py.orig 2022-01-11 08:31:14.000000000 +0000
|
||||
+++ gnupg.py
|
||||
@@ -832,7 +832,7 @@ class GPG(object):
|
||||
}
|
||||
|
||||
"Encapsulate access to the gpg executable"
|
||||
- def __init__(self, gpgbinary='gpg', gnupghome=None, verbose=False,
|
||||
+ def __init__(self, gpgbinary='gpg2', gnupghome=None, verbose=False,
|
||||
use_agent=False, keyring=None, options=None,
|
||||
secret_keyring=None):
|
||||
"""Initialize a GPG process wrapper. Options are:
|
Loading…
Reference in a new issue