fluxconf: remove package

The wm/fluxconf package has been dead upstream for over a decade, fails
to build with default pkgsrc settings in most environments (it has of
course continually bit-rotted), and is also actively harmful for users
in some contexts. It doesn't support the current config format that
Fluxbox 1.3 uses, so it will actually corrupt config files.

As discussed on pkgsrc-users:
http://mail-index.netbsd.org/pkgsrc-users/2020/01/14/msg030221.html
This commit is contained in:
gutteridge 2020-01-27 22:58:05 +00:00
parent 69b5f36b19
commit 7b7d808a43
7 changed files with 1 additions and 101 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.145 2020/01/08 12:52:13 nia Exp $
# $NetBSD: Makefile,v 1.146 2020/01/27 22:58:05 gutteridge Exp $
#
COMMENT= X11 window managers, configuration tools, and themes
@ -36,7 +36,6 @@ SUBDIR+= echinus
SUBDIR+= enlightenment16
SUBDIR+= evilwm
SUBDIR+= fluxbox
SUBDIR+= fluxconf
SUBDIR+= fluxter
SUBDIR+= flwm
SUBDIR+= fvwm

View file

@ -1,8 +0,0 @@
fluxconf is a tiny GTK based configuration tool for the fluxbox window manager.
It allows basic manipulation of the window manager behaviour:
o Slit configuration
o Window placement
o Focus model
o Workspace configuration
o Keys configuration

View file

@ -1,31 +0,0 @@
# $NetBSD: Makefile,v 1.39 2019/12/21 23:48:26 joerg Exp $
#
DISTNAME= fluxconf-0.9.9
PKGREVISION= 30
CATEGORIES= wm
MASTER_SITES= http://devaux.fabien.free.fr/flux/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://devaux.fabien.free.fr/flux/
COMMENT= GTK based configuration tool for the fluxbox window manager
DEPENDS+= fluxbox-[0-9]*:../../wm/fluxbox
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --datadir=${PREFIX}/${PKGLOCALEDIR}
USE_PKGLOCALEDIR= yes
USE_TOOLS+= msgfmt pkg-config
.include "../../mk/compiler.mk"
.if !empty(PKGSRC_COMPILER:Mclang)
_WRAP_EXTRA_ARGS.CC+= -Wno-error=invalid-source-encoding -Wno-error=format-security -Wno-error=self-assign -Wno-error=deprecated-declarations
CWRAPPERS_APPEND.cc+= -Wno-error=invalid-source-encoding -Wno-error=format-security -Wno-error=self-assign -Wno-error=deprecated-declarations
.elif !empty(PKGSRC_COMPILER:Mgcc)
_WRAP_EXTRA_ARGS.CC+= -Wno-error=unused-but-set-parameter -Wno-error=unused-but-set-variable
CWRAPPERS_APPEND.cc+= -Wno-error=unused-but-set-parameter -Wno-error=unused-but-set-variable
.endif
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2006/04/15 09:39:39 xtraeme Exp $
bin/fluxbare
bin/fluxconf
bin/fluxkeys
bin/fluxmenu
${PKGLOCALEDIR}/locale/fi/LC_MESSAGES/fluxconf.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/fluxconf.mo

View file

@ -1,8 +0,0 @@
$NetBSD: distinfo,v 1.4 2015/11/02 23:42:52 agc Exp $
SHA1 (fluxconf-0.9.9.tar.gz) = c9e262d21b4badfcebccb0f500af10c854bda9eb
RMD160 (fluxconf-0.9.9.tar.gz) = 0e9e29292d6679f0a43d6fb4d091015f66e4cf20
SHA512 (fluxconf-0.9.9.tar.gz) = c40789ee1bf84964c25b1293ad9e8bf331674a11c2dca922c8280950bea9ffce2357db51dfc2879623a60be84dda32e784238be2b2fa0cebfb4c2a3b4b316b2a
Size (fluxconf-0.9.9.tar.gz) = 234276 bytes
SHA1 (patch-aa) = b30a016ed61e64672240f9eb392244839c9adad9
SHA1 (patch-ab) = 0314ff3610c6ba9c0feab523bd2d3d13a9c6970a

View file

@ -1,23 +0,0 @@
$NetBSD: patch-aa,v 1.2 2007/11/04 15:46:58 rillig Exp $
--- src/fluxconf.c.orig 2004-12-08 17:58:37.000000000 +0100
+++ src/fluxconf.c 2007-11-04 16:45:55.000000000 +0100
@@ -263,7 +263,8 @@ int fluxconf(int argc, char **argv, char
GdkFont *head;
GtkTooltips *tip;
GList *items = NULL;
- char *initpath, *buf, **config;
+ char *initpath, *buf;
+ char **config;
FILE *file;
#ifndef GTK2
@@ -316,7 +317,7 @@ int fluxconf(int argc, char **argv, char
if (y < QCM_START)
s[y].val = atoi(config[i - 1] + msgsLen + 2); /* < 7 are spinboxes */
else if (y > QCM_START - 1 && y < QCM_STOP) { /* TRUE or FALSE */
- if (toupper(config[i - 1][msgsLen + 2]) == 'F')
+ if (toupper((unsigned char)(config[i - 1][msgsLen + 2])) == 'F')
s[y].val = 0;
else
s[y].val = 1;

View file

@ -1,22 +0,0 @@
$NetBSD: patch-ab,v 1.1 2009/07/07 19:52:56 joerg Exp $
--- src/Makefile.in.orig 2009-07-07 21:50:26.000000000 +0200
+++ src/Makefile.in
@@ -645,12 +645,12 @@ uninstall-info: uninstall-info-recursive
#fluxkeys: fluxconf
# ln -sf fluxconf fluxkeys
install-exec-hook:
- @ln -sf $(bindir)/fluxconf $(bindir)/fluxkeys
- @ln -sf $(bindir)/fluxconf $(bindir)/fluxbare
- @if ldd fluxconf |grep pango > /dev/null ; then ln -sf $(bindir)/fluxconf $(bindir)/fluxmenu; fi
+ @ln -sf ${DESTDIR}$(bindir)/fluxconf ${DESTDIR}$(bindir)/fluxkeys
+ @ln -sf ${DESTDIR}$(bindir)/fluxconf ${DESTDIR}$(bindir)/fluxbare
+ @if ldd fluxconf |grep pango > /dev/null ; then ln -sf ${DESTDIR}$(bindir)/fluxconf ${DESTDIR}$(bindir)/fluxmenu; fi
@for lan in ${ALL_LANG} ; do \
- ${mkinstalldirs} $(datadir)/locale/$$lan/LC_MESSAGES; \
- ${INSTALL} -m444 $(top_srcdir)/po/$$lan.mo $(datadir)/locale/$$lan/LC_MESSAGES/fluxconf.mo ;\
+ ${mkinstalldirs} ${DESTDIR}$(datadir)/locale/$$lan/LC_MESSAGES; \
+ ${INSTALL} -m444 $(top_srcdir)/po/$$lan.mo ${DESTDIR}$(datadir)/locale/$$lan/LC_MESSAGES/fluxconf.mo ;\
done ;
uninstall-local: