capstone py-capstone: updated to 5.0.1

Version 5.0.1

[ARM] Fix VFP feature check
Restore the ARM register naming from v4.
Use OS independent printf formatting.
Cherry-pick from next for v5.0.1
Add Python bindings for WASM
Sync Python bindings for x86, m68k, and mos65xx
Add Python bindings for SH
Update Python binding constants
Fixing TriCore disasm instructions
allow absolute CMAKE_INSTALL_*DIR

Version 5.0

[workflows] Remove deprecated image versions
Fix capstone_test.c
Support repz prefix on X86 ret instructions
fix for msvc static lib, dll build error and warnings
use calloc for cs_insn instead of malloc
Fix access bug for TEST op
Update Cython bindings
Use Intel register syntax for Tricore
Add # prefix to tricore imm operand
Revert "Mark cs_* as thread local to avoid race condition in multithreads"
Replace strncpy with memcpy to fix compiler warning.
Remove outdated and irrelevant TODO
This commit is contained in:
adam 2024-02-07 09:46:36 +00:00
parent 1d64a11501
commit 7b96b0d584
8 changed files with 87 additions and 48 deletions

View File

@ -1,11 +1,10 @@
# $NetBSD: Makefile.common,v 1.5 2020/08/18 20:20:46 riastradh Exp $
# $NetBSD: Makefile.common,v 1.6 2024/02/07 09:46:36 adam Exp $
#
# used by devel/py-capstone/Makefile
DISTNAME= capstone-4.0.2
DISTNAME= capstone-5.0.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=aquynh/}
GITHUB_TAG= 4.0.2
MASTER_SITES= ${MASTER_SITE_GITHUB:=capstone-engine/}
HOMEPAGE= https://www.capstone-engine.org/

View File

@ -1,20 +1,27 @@
@comment $NetBSD: PLIST,v 1.3 2020/08/18 20:20:46 riastradh Exp $
@comment $NetBSD: PLIST,v 1.4 2024/02/07 09:46:36 adam Exp $
bin/cstool
include/capstone/arm.h
include/capstone/arm64.h
include/capstone/bpf.h
include/capstone/capstone.h
include/capstone/evm.h
include/capstone/m680x.h
include/capstone/m68k.h
include/capstone/mips.h
include/capstone/mos65xx.h
include/capstone/platform.h
include/capstone/ppc.h
include/capstone/riscv.h
include/capstone/sh.h
include/capstone/sparc.h
include/capstone/systemz.h
include/capstone/tms320c64x.h
include/capstone/tricore.h
include/capstone/wasm.h
include/capstone/x86.h
include/capstone/xcore.h
lib/libcapstone.a
lib/libcapstone.so
lib/libcapstone.so.4
lib/libcapstone.so.5
lib/pkgconfig/capstone.pc

View File

@ -1,11 +1,10 @@
$NetBSD: distinfo,v 1.17 2022/03/26 19:25:51 tnn Exp $
$NetBSD: distinfo,v 1.18 2024/02/07 09:46:36 adam Exp $
BLAKE2s (capstone-4.0.2.tar.gz) = d3767b622f0a91b3f38a24817097975ecbf4126b3118b6059dfa4a8b12d01f61
SHA512 (capstone-4.0.2.tar.gz) = 7f93534517307b737422a8825b66b2a1f3e1cca2049465d60ab12595940154aaf843ba40ed348fce58de58b990c19a0caef289060eb72898cb008a88c470970e
Size (capstone-4.0.2.tar.gz) = 3439542 bytes
BLAKE2s (capstone-5.0.1.tar.gz) = a66f1354f655e31dd8cd4bbb4db933aea7f9c5914700568da6d76952c89bfe52
SHA512 (capstone-5.0.1.tar.gz) = 350aba77ce2d96b5c25764913591ba80e4497177ae0a8b2c820c6755ee8310848fbfc54e7ccac27fafc2dbc6778118ad92c53d1b5cb601d4fa146dec7d7e11e5
Size (capstone-5.0.1.tar.gz) = 7654195 bytes
SHA1 (patch-Makefile) = a96441309efa54cb8ec1beacb44891f981b0db3e
SHA1 (patch-bindings_python_capstone_____init____.py) = ea410a99d4cd4ee0a109a7225b739971472c387d
SHA1 (patch-bindings_python_setup.py) = aebe4104ece594a7432961dd07c5d739da70f963
SHA1 (patch-bindings_python_setup.py) = f65d5a7a3d7e34867dd9981bc8db1ba1f5dc1ad6
SHA1 (patch-cstool_Makefile) = 68dd0a175d0e2270e2813f784cae5ca9f89a3a05
SHA1 (patch-cstool_getopt.h) = 662a70f1718654935ae0bfa32e79fc7fe3ef7fcb
SHA1 (patch-suite_fuzz_driverbin.c) = c7ddd8ea65d8aea357ba086d6a57e0412fa2c193
SHA1 (patch-suite_fuzz_driverbin.c) = 17a0876c475ad7782d0ccb362aadbd7633dfe778

View File

@ -1,12 +1,12 @@
$NetBSD: patch-bindings_python_setup.py,v 1.2 2020/08/18 20:20:46 riastradh Exp $
$NetBSD: patch-bindings_python_setup.py,v 1.3 2024/02/07 09:46:36 adam Exp $
--- bindings/python/setup.py.orig 2020-05-08 10:03:30.000000000 +0000
--- bindings/python/setup.py.orig 2023-08-22 16:03:55.000000000 +0000
+++ bindings/python/setup.py
@@ -140,14 +140,6 @@ def build_libraries():
# Do not build tests & static library
os.system('cmake -DCMAKE_BUILD_TYPE=RELEASE -DCAPSTONE_BUILD_TESTS=0 -DCAPSTONE_BUILD_STATIC=0 -G "NMake Makefiles" ..')
os.system("nmake")
- else: # Unix incl. cygwin
@@ -144,14 +144,6 @@ def build_libraries():
# Only build capstone.dll
os.system('cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=ON -DCAPSTONE_BUILD_TESTS=OFF -DCAPSTONE_BUILD_CSTOOL=OFF -G "NMake Makefiles" ..')
os.system("cmake --build .")
- else: # Unix incl. cygwin
- os.system("CAPSTONE_BUILD_CORE_ONLY=yes bash ./make.sh")
-
- shutil.copy(VERSIONED_LIBRARY_FILE, os.path.join(LIBS_DIR, LIBRARY_FILE))

View File

@ -1,15 +0,0 @@
$NetBSD: patch-cstool_getopt.h,v 1.1 2022/03/26 19:25:51 tnn Exp $
Use the standard optarg prototype.
--- cstool/getopt.h.orig 2020-05-08 10:03:30.000000000 +0000
+++ cstool/getopt.h
@@ -6,7 +6,7 @@ int opterr = 1, /* if error message shou
optind = 1, /* index into parent argv vector */
optopt, /* character checked for validity */
optreset; /* reset getopt */
-const char *optarg; /* argument associated with option */
+extern char *optarg; /* argument associated with option */
#define BADCH (int)'?'
#define BADARG (int)':'

View File

@ -1,10 +1,10 @@
$NetBSD: patch-suite_fuzz_driverbin.c,v 1.1 2022/03/26 19:25:51 tnn Exp $
$NetBSD: patch-suite_fuzz_driverbin.c,v 1.2 2024/02/07 09:46:36 adam Exp $
no d_type / DT_REG on SunOS, skip check.
--- suite/fuzz/driverbin.c.orig 2020-05-08 10:03:30.000000000 +0000
--- suite/fuzz/driverbin.c.orig 2023-08-22 16:03:55.000000000 +0000
+++ suite/fuzz/driverbin.c
@@ -34,9 +34,11 @@ int main(int argc, char** argv)
@@ -35,9 +35,11 @@ int main(int argc, char** argv)
while((dir = readdir(d)) != NULL) {
//opens the file, get its size, and reads it into a buffer
@ -13,6 +13,6 @@ no d_type / DT_REG on SunOS, skip check.
continue;
}
+#endif
printf("Running %s\n", dir->d_name);
printf("Running file %s ", dir->d_name);
fflush(stdout);
fp = fopen(dir->d_name, "rb");

View File

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.6 2022/01/04 20:52:55 wiz Exp $
# $NetBSD: Makefile,v 1.7 2024/02/07 09:46:36 adam Exp $
.include "../../devel/capstone/Makefile.common"
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 2
CATEGORIES+= python
MAINTAINER= pkgsrc-users@NetBSD.org
@ -13,6 +12,13 @@ LICENSE= modified-bsd
WRKSRC= ${WRKDIR}/capstone-${GITHUB_TAG}
PYSETUPSUBDIR= bindings/python
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27
.include "../../devel/capstone/buildlink3.mk"
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,9 +1,10 @@
@comment $NetBSD: PLIST,v 1.4 2020/08/18 20:20:46 riastradh Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/${EGG_INFODIR}/zip-safe
@comment $NetBSD: PLIST,v 1.5 2024/02/07 09:46:36 adam Exp $
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE.TXT
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/${WHEEL_INFODIR}/zip-safe
${PYSITELIB}/capstone/__init__.py
${PYSITELIB}/capstone/__init__.pyc
${PYSITELIB}/capstone/__init__.pyo
@ -19,6 +20,12 @@ ${PYSITELIB}/capstone/arm64_const.pyo
${PYSITELIB}/capstone/arm_const.py
${PYSITELIB}/capstone/arm_const.pyc
${PYSITELIB}/capstone/arm_const.pyo
${PYSITELIB}/capstone/bpf.py
${PYSITELIB}/capstone/bpf.pyc
${PYSITELIB}/capstone/bpf.pyo
${PYSITELIB}/capstone/bpf_const.py
${PYSITELIB}/capstone/bpf_const.pyc
${PYSITELIB}/capstone/bpf_const.pyo
${PYSITELIB}/capstone/evm.py
${PYSITELIB}/capstone/evm.pyc
${PYSITELIB}/capstone/evm.pyo
@ -27,16 +34,22 @@ ${PYSITELIB}/capstone/evm_const.pyc
${PYSITELIB}/capstone/evm_const.pyo
${PYSITELIB}/capstone/include/capstone/arm.h
${PYSITELIB}/capstone/include/capstone/arm64.h
${PYSITELIB}/capstone/include/capstone/bpf.h
${PYSITELIB}/capstone/include/capstone/capstone.h
${PYSITELIB}/capstone/include/capstone/evm.h
${PYSITELIB}/capstone/include/capstone/m680x.h
${PYSITELIB}/capstone/include/capstone/m68k.h
${PYSITELIB}/capstone/include/capstone/mips.h
${PYSITELIB}/capstone/include/capstone/mos65xx.h
${PYSITELIB}/capstone/include/capstone/platform.h
${PYSITELIB}/capstone/include/capstone/ppc.h
${PYSITELIB}/capstone/include/capstone/riscv.h
${PYSITELIB}/capstone/include/capstone/sh.h
${PYSITELIB}/capstone/include/capstone/sparc.h
${PYSITELIB}/capstone/include/capstone/systemz.h
${PYSITELIB}/capstone/include/capstone/tms320c64x.h
${PYSITELIB}/capstone/include/capstone/tricore.h
${PYSITELIB}/capstone/include/capstone/wasm.h
${PYSITELIB}/capstone/include/capstone/x86.h
${PYSITELIB}/capstone/include/capstone/xcore.h
${PYSITELIB}/capstone/m680x.py
@ -57,12 +70,30 @@ ${PYSITELIB}/capstone/mips.pyo
${PYSITELIB}/capstone/mips_const.py
${PYSITELIB}/capstone/mips_const.pyc
${PYSITELIB}/capstone/mips_const.pyo
${PYSITELIB}/capstone/mos65xx.py
${PYSITELIB}/capstone/mos65xx.pyc
${PYSITELIB}/capstone/mos65xx.pyo
${PYSITELIB}/capstone/mos65xx_const.py
${PYSITELIB}/capstone/mos65xx_const.pyc
${PYSITELIB}/capstone/mos65xx_const.pyo
${PYSITELIB}/capstone/ppc.py
${PYSITELIB}/capstone/ppc.pyc
${PYSITELIB}/capstone/ppc.pyo
${PYSITELIB}/capstone/ppc_const.py
${PYSITELIB}/capstone/ppc_const.pyc
${PYSITELIB}/capstone/ppc_const.pyo
${PYSITELIB}/capstone/riscv.py
${PYSITELIB}/capstone/riscv.pyc
${PYSITELIB}/capstone/riscv.pyo
${PYSITELIB}/capstone/riscv_const.py
${PYSITELIB}/capstone/riscv_const.pyc
${PYSITELIB}/capstone/riscv_const.pyo
${PYSITELIB}/capstone/sh.py
${PYSITELIB}/capstone/sh.pyc
${PYSITELIB}/capstone/sh.pyo
${PYSITELIB}/capstone/sh_const.py
${PYSITELIB}/capstone/sh_const.pyc
${PYSITELIB}/capstone/sh_const.pyo
${PYSITELIB}/capstone/sparc.py
${PYSITELIB}/capstone/sparc.pyc
${PYSITELIB}/capstone/sparc.pyo
@ -81,6 +112,18 @@ ${PYSITELIB}/capstone/tms320c64x.pyo
${PYSITELIB}/capstone/tms320c64x_const.py
${PYSITELIB}/capstone/tms320c64x_const.pyc
${PYSITELIB}/capstone/tms320c64x_const.pyo
${PYSITELIB}/capstone/tricore.py
${PYSITELIB}/capstone/tricore.pyc
${PYSITELIB}/capstone/tricore.pyo
${PYSITELIB}/capstone/tricore_const.py
${PYSITELIB}/capstone/tricore_const.pyc
${PYSITELIB}/capstone/tricore_const.pyo
${PYSITELIB}/capstone/wasm.py
${PYSITELIB}/capstone/wasm.pyc
${PYSITELIB}/capstone/wasm.pyo
${PYSITELIB}/capstone/wasm_const.py
${PYSITELIB}/capstone/wasm_const.pyc
${PYSITELIB}/capstone/wasm_const.pyo
${PYSITELIB}/capstone/x86.py
${PYSITELIB}/capstone/x86.pyc
${PYSITELIB}/capstone/x86.pyo