Add a patch from Jed Davis posted to port-xen which allows xend to be

gracefully restarted. See
http://mail-index.netbsd.org/port-xen/2005/08/17/0003.html
for details.
Bump PKGREVISION.
This commit is contained in:
bouyer 2005-08-19 13:06:31 +00:00
parent 364925692e
commit 7b992b3f63
3 changed files with 21 additions and 2 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.16 2005/08/06 17:43:14 bouyer Exp $
# $NetBSD: Makefile,v 1.17 2005/08/19 13:06:31 bouyer Exp $
#
DISTNAME= xen-2.0.7-src
PKGNAME= xentools20-2.0.7
PKGREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/
EXTRACT_SUFX= .tgz

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.9 2005/08/06 17:43:14 bouyer Exp $
$NetBSD: distinfo,v 1.10 2005/08/19 13:06:31 bouyer Exp $
SHA1 (xen-2.0.7-src.tgz) = 5317100e1e062961e3fee398fccbf023eb8f0337
RMD160 (xen-2.0.7-src.tgz) = db99fb49e592df7229d4d361c48bab1d23a1d725
@ -18,3 +18,4 @@ SHA1 (patch-am) = 7392057d2da107e935775627afe2498a81903f71
SHA1 (patch-aq) = 96ac4caaa268069ee02962a917f85753515747be
SHA1 (patch-as) = 333da168af43dae9a4e8695409cbd006e7fcf097
SHA1 (patch-at) = 0964bc7dd23ff6fcd596d6a8564d9e3033f34563
SHA1 (patch-au) = a5eb7b34d43f57a3e1d4644e98ec571f30c56f5e

View file

@ -0,0 +1,17 @@
$NetBSD: patch-au,v 1.1 2005/08/19 13:06:31 bouyer Exp $
--- python/xen/xend/XendDomain.py.orig 2005-08-13 01:54:56.000000000 -0400
+++ python/xen/xend/XendDomain.py 2005-08-13 01:55:17.000000000 -0400
@@ -147,7 +147,10 @@
domid = str(d['dom'])
doms[domid] = d
dlist = []
- for config in self.domain_db.values():
+ domkeys = map(int, self.domain_db.keys())
+ domkeys.sort()
+ for domkey in domkeys:
+ config = self.domain_db.get(str(domkey))
domid = str(sxp.child_value(config, 'id'))
if domid in doms:
d_dom = self._new_domain(config, doms[domid])