Update to 2.0.2:
----- 2.0.2 ----- * Fix NameError during installation with Python implementations (e.g. Jython) not containing parser module. * Fix NameError in ``sdist:re_finder``. ----- 2.0.1 ----- * Issue #124: Fixed error in list detection in upload_docs. --- 2.0 --- * Issue #121: Exempt lib2to3 pickled grammars from DirectorySandbox. * Issue #41: Dropped support for Python 2.4 and Python 2.5. Clients requiring setuptools for those versions of Python should use setuptools 1.x. * Removed ``setuptools.command.easy_install.HAS_USER_SITE``. Clients expecting this boolean variable should use ``site.ENABLE_USER_SITE`` instead. * Removed ``pkg_resources.ImpWrapper``. Clients that expected this class should use ``pkgutil.ImpImporter`` instead. ----- 1.4.2 ----- * Issue #116: Correct TypeError when reading a local package index on Python 3. ----- 1.4.1 ----- * Issue #114: Use ``sys.getfilesystemencoding`` for decoding config in ``bdist_wininst`` distributions. * Issue #105 and Issue #113: Establish a more robust technique for determining the terminal encoding:: 1. Try ``getpreferredencoding`` 2. If that returns US_ASCII or None, try the encoding from ``getdefaultlocale``. If that encoding was a "fallback" because Python could not figure it out from the environment or OS, encoding remains unresolved. 3. If the encoding is resolved, then make sure Python actually implements the encoding. 4. On the event of an error or unknown codec, revert to fallbacks (UTF-8 on Darwin, ASCII on everything else). 5. On the encoding is 'mac-roman' on Darwin, use UTF-8 as 'mac-roman' was a bug on older Python releases. On a side note, it would seem that the encoding only matters for when SVN does not yet support ``--xml`` and when getting repository and svn version numbers. The ``--xml`` technique should yield UTF-8 according to some messages on the SVN mailing lists. So if the version numbers are always 7-bit ASCII clean, it may be best to only support the file parsing methods for legacy SVN releases and support for SVN without the subprocess command would simple go away as support for the older SVNs does. --- 1.4 --- * Issue #27: ``easy_install`` will now use credentials from .pypirc if present for connecting to the package index. * Pull Request #21: Omit unwanted newlines in ``package_index._encode_auth`` when the username/password pair length indicates wrapping. ----- 1.3.2 ----- * Issue #99: Fix filename encoding issues in SVN support. ----- 1.3.1 ----- * Remove exuberant warning in SVN support when SVN is not used.
This commit is contained in:
parent
0e34807d3e
commit
7bace04a8c
4 changed files with 22 additions and 37 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.36 2013/11/04 21:33:08 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.37 2014/01/06 14:42:34 wiz Exp $
|
||||
|
||||
EGG_VERSION= 1.3
|
||||
EGG_VERSION= 2.0.2
|
||||
DISTNAME= setuptools-${EGG_VERSION}
|
||||
EGG_NAME= setuptools-${EGG_VERSION}
|
||||
PKGNAME= ${PYPKGPREFIX}-setuptools-${EGG_VERSION}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.13 2013/11/03 15:59:41 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.14 2014/01/06 14:42:34 wiz Exp $
|
||||
bin/easy_install-${PYVERSSUFFIX}
|
||||
${PYSITELIB}/_markerlib/__init__.py
|
||||
${PYSITELIB}/_markerlib/__init__.pyc
|
||||
|
@ -22,21 +22,6 @@ ${PYSITELIB}/${EGG_INFODIR}/zip-safe
|
|||
${PYSITELIB}/setuptools/__init__.py
|
||||
${PYSITELIB}/setuptools/__init__.pyc
|
||||
${PYSITELIB}/setuptools/__init__.pyo
|
||||
${PYSITELIB}/setuptools/_backport/__init__.py
|
||||
${PYSITELIB}/setuptools/_backport/__init__.pyc
|
||||
${PYSITELIB}/setuptools/_backport/__init__.pyo
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/__init__.py
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/__init__.pyc
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/__init__.pyo
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/_sha.py
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/_sha.pyc
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/_sha.pyo
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/_sha256.py
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/_sha256.pyc
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/_sha256.pyo
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/_sha512.py
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/_sha512.pyc
|
||||
${PYSITELIB}/setuptools/_backport/hashlib/_sha512.pyo
|
||||
${PYSITELIB}/setuptools/archive_util.py
|
||||
${PYSITELIB}/setuptools/archive_util.pyc
|
||||
${PYSITELIB}/setuptools/archive_util.pyo
|
||||
|
@ -100,9 +85,6 @@ ${PYSITELIB}/setuptools/command/setopt.pyo
|
|||
${PYSITELIB}/setuptools/command/test.py
|
||||
${PYSITELIB}/setuptools/command/test.pyc
|
||||
${PYSITELIB}/setuptools/command/test.pyo
|
||||
${PYSITELIB}/setuptools/command/upload.py
|
||||
${PYSITELIB}/setuptools/command/upload.pyc
|
||||
${PYSITELIB}/setuptools/command/upload.pyo
|
||||
${PYSITELIB}/setuptools/command/upload_docs.py
|
||||
${PYSITELIB}/setuptools/command/upload_docs.pyc
|
||||
${PYSITELIB}/setuptools/command/upload_docs.pyo
|
||||
|
@ -118,18 +100,21 @@ ${PYSITELIB}/setuptools/dist.pyo
|
|||
${PYSITELIB}/setuptools/extension.py
|
||||
${PYSITELIB}/setuptools/extension.pyc
|
||||
${PYSITELIB}/setuptools/extension.pyo
|
||||
${PYSITELIB}/setuptools/lib2to3_ex.py
|
||||
${PYSITELIB}/setuptools/lib2to3_ex.pyc
|
||||
${PYSITELIB}/setuptools/lib2to3_ex.pyo
|
||||
${PYSITELIB}/setuptools/package_index.py
|
||||
${PYSITELIB}/setuptools/package_index.pyc
|
||||
${PYSITELIB}/setuptools/package_index.pyo
|
||||
${PYSITELIB}/setuptools/py24compat.py
|
||||
${PYSITELIB}/setuptools/py24compat.pyc
|
||||
${PYSITELIB}/setuptools/py24compat.pyo
|
||||
${PYSITELIB}/setuptools/py26compat.py
|
||||
${PYSITELIB}/setuptools/py26compat.pyc
|
||||
${PYSITELIB}/setuptools/py26compat.pyo
|
||||
${PYSITELIB}/setuptools/py27compat.py
|
||||
${PYSITELIB}/setuptools/py27compat.pyc
|
||||
${PYSITELIB}/setuptools/py27compat.pyo
|
||||
${PYSITELIB}/setuptools/py31compat.py
|
||||
${PYSITELIB}/setuptools/py31compat.pyc
|
||||
${PYSITELIB}/setuptools/py31compat.pyo
|
||||
${PYSITELIB}/setuptools/sandbox.py
|
||||
${PYSITELIB}/setuptools/sandbox.pyc
|
||||
${PYSITELIB}/setuptools/sandbox.pyo
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.18 2013/11/04 21:33:08 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.19 2014/01/06 14:42:34 wiz Exp $
|
||||
|
||||
SHA1 (setuptools-1.3.tar.gz) = faadca24f78488ad1a29f59bbeff9de26aa8e937
|
||||
RMD160 (setuptools-1.3.tar.gz) = 9bc88e91242cdefc21ff362a7cc102490d257a62
|
||||
Size (setuptools-1.3.tar.gz) = 692383 bytes
|
||||
SHA1 (patch-setup.py) = 8072ebce17d029f7efc1c05528d1e5c0d0f40800
|
||||
SHA1 (setuptools-2.0.2.tar.gz) = 1fce2214eed97c62811ccb85af45ba1c7f16c576
|
||||
RMD160 (setuptools-2.0.2.tar.gz) = 663ab3ef99a38a2fd5b47fc206bf75ef75d6c352
|
||||
Size (setuptools-2.0.2.tar.gz) = 784218 bytes
|
||||
SHA1 (patch-setup.py) = be1078e5e2b6e9ec8c859c2c6e2a4a44fe3c2840
|
||||
|
|
|
@ -1,16 +1,16 @@
|
|||
$NetBSD: patch-setup.py,v 1.1 2013/07/04 06:43:13 wiz Exp $
|
||||
$NetBSD: patch-setup.py,v 1.2 2014/01/06 14:42:34 wiz Exp $
|
||||
|
||||
Do not install easy_install without python version suffix to allow
|
||||
parallel installation of this package for multiple python versions.
|
||||
|
||||
--- setup.py.orig 2013-07-02 15:45:46.000000000 +0000
|
||||
--- setup.py.orig 2013-12-13 16:31:50.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -54,7 +54,7 @@ from setuptools.command.test import test
|
||||
|
||||
@@ -30,7 +30,7 @@ from setuptools.command.test import test
|
||||
scripts = []
|
||||
|
||||
-console_scripts = ["easy_install = setuptools.command.easy_install:main"]
|
||||
+console_scripts = []
|
||||
def _gen_console_scripts():
|
||||
- yield "easy_install = setuptools.command.easy_install:main"
|
||||
+ yield ""
|
||||
|
||||
# Gentoo distributions manage the python-version-specific scripts themselves,
|
||||
# so they define an environment variable to suppress the creation of the
|
||||
# Gentoo distributions manage the python-version-specific scripts
|
||||
# themselves, so those platforms define an environment variable to
|
||||
|
|
Loading…
Reference in a new issue