Initial import of puzzles-8605, a collection of small one-player
puzzle games by Simon Tatham. This package contains a collection of small computer programs which implement one-player puzzle games. All of them run natively on Unix (GTK), on Windows, and on Mac OS X; they can also be played on the web, as Java applets. Simon Tatham wrote this collection because he thought there should be more small desktop toys available: little games you can pop up in a window and play for two or three minutes while you take a break from whatever else you were doing. And he was also annoyed that every time he found a good game on (say) Unix, it wasn't available the next time he was sitting at a Windows machine, or vice versa; so he arranged that everything in my personal puzzle collection will happily run on both those platforms and more. When he finds (or perhaps invent) further puzzle games that he likes, they'll be added to this collection and will immediately be available on both platforms. And if anyone feels like writing any other front ends - Mac OS pre-10, PocketPC, or whatever it might be - then all the games in this framework will immediately become available on another platform as well.
This commit is contained in:
parent
6126fb06df
commit
7bb75c84a4
5 changed files with 119 additions and 0 deletions
19
games/puzzles/DESCR
Normal file
19
games/puzzles/DESCR
Normal file
|
@ -0,0 +1,19 @@
|
|||
This package contains a collection of small computer programs which
|
||||
implement one-player puzzle games. All of them run natively on Unix
|
||||
(GTK), on Windows, and on Mac OS X; they can also be played on the
|
||||
web, as Java applets.
|
||||
|
||||
Simon Tatham wrote this collection because he thought there should
|
||||
be more small desktop toys available: little games you can pop up
|
||||
in a window and play for two or three minutes while you take a
|
||||
break from whatever else you were doing. And he was also annoyed
|
||||
that every time he found a good game on (say) Unix, it wasn't
|
||||
available the next time he was sitting at a Windows machine, or
|
||||
vice versa; so he arranged that everything in my personal puzzle
|
||||
collection will happily run on both those platforms and more. When
|
||||
he finds (or perhaps invent) further puzzle games that he likes,
|
||||
they'll be added to this collection and will immediately be available
|
||||
on both platforms. And if anyone feels like writing any other front
|
||||
ends - Mac OS pre-10, PocketPC, or whatever it might be - then all
|
||||
the games in this framework will immediately become available on
|
||||
another platform as well.
|
28
games/puzzles/Makefile
Normal file
28
games/puzzles/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/07/18 18:38:28 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= puzzles-r8605
|
||||
PKGNAME= ${DISTNAME:S/-r/-/}
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://www.chiark.greenend.org.uk/~sgtatham/puzzles/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.chiark.greenend.org.uk/~sgtatham/puzzles/
|
||||
COMMENT= Collection of small one-player puzzle games by Simon Tatham
|
||||
LICENSE= mit
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
INSTALLATION_DIRS= bin share/doc/puzzles
|
||||
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
|
||||
BUILDLINK_TRANSFORM+= rm:-Werror
|
||||
MAKE_FLAGS= prefix=${PREFIX}
|
||||
MAKE_FLAGS= gamesdir=${PREFIX}/bin
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/puzzles.txt \
|
||||
${DESTDIR}${PREFIX}/share/doc/puzzles
|
||||
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
29
games/puzzles/PLIST
Normal file
29
games/puzzles/PLIST
Normal file
|
@ -0,0 +1,29 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/07/18 18:38:28 wiz Exp $
|
||||
bin/blackbox
|
||||
bin/bridges
|
||||
bin/cube
|
||||
bin/dominosa
|
||||
bin/fifteen
|
||||
bin/filling
|
||||
bin/flip
|
||||
bin/galaxies
|
||||
bin/guess
|
||||
bin/inertia
|
||||
bin/lightup
|
||||
bin/loopy
|
||||
bin/map
|
||||
bin/mines
|
||||
bin/netgame
|
||||
bin/netslide
|
||||
bin/pattern
|
||||
bin/pegs
|
||||
bin/rect
|
||||
bin/samegame
|
||||
bin/sixteen
|
||||
bin/slant
|
||||
bin/solo
|
||||
bin/tents
|
||||
bin/twiddle
|
||||
bin/unequal
|
||||
bin/untangle
|
||||
share/doc/puzzles/puzzles.txt
|
6
games/puzzles/distinfo
Normal file
6
games/puzzles/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/07/18 18:38:28 wiz Exp $
|
||||
|
||||
SHA1 (puzzles-r8605.tar.gz) = 881ab754e67b03ad8710e14bb632e3ddeb3a51f2
|
||||
RMD160 (puzzles-r8605.tar.gz) = 3eeb594459e7b01fcc6eebf97ab684570dd0e378
|
||||
Size (puzzles-r8605.tar.gz) = 2155651 bytes
|
||||
SHA1 (patch-aa) = 67a8ddecf7c22a629344787be39603acf0a7aac4
|
37
games/puzzles/patches/patch-aa
Normal file
37
games/puzzles/patches/patch-aa
Normal file
|
@ -0,0 +1,37 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/07/18 18:38:28 wiz Exp $
|
||||
|
||||
--- Makefile.orig 2009-07-18 00:37:39.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -30,7 +30,7 @@ man1dir=$(mandir)/man1
|
||||
all: blackbox bridges cube dominosa fifteen filling fillingsolver flip \
|
||||
galaxies galaxiespicture galaxiessolver guess inertia \
|
||||
latincheck lightup lightupsolver loopy loopysolver map \
|
||||
- mapsolver mineobfusc mines net netslide nullgame obfusc \
|
||||
+ mapsolver mineobfusc mines netgame netslide nullgame obfusc \
|
||||
pattern patternsolver pegs rect samegame sixteen slant \
|
||||
slantsolver solo solosolver tents tentssolver twiddle \
|
||||
unequal unequalsolver untangle
|
||||
@@ -146,7 +146,7 @@ mines: drawing.o gtk.o malloc.o midend.o
|
||||
mines-icon.o misc.o printing.o ps.o random.o tree234.o \
|
||||
version.o
|
||||
|
||||
-net: drawing.o dsf.o gtk.o malloc.o midend.o misc.o net.o net-icon.o \
|
||||
+netgame: drawing.o dsf.o gtk.o malloc.o midend.o misc.o net.o net-icon.o \
|
||||
printing.o ps.o random.o tree234.o version.o
|
||||
$(CC) $(XLDFLAGS) -o $@ drawing.o dsf.o gtk.o malloc.o midend.o \
|
||||
misc.o net.o net-icon.o printing.o ps.o random.o tree234.o \
|
||||
@@ -502,7 +502,7 @@ GAMES += lightup
|
||||
GAMES += loopy
|
||||
GAMES += map
|
||||
GAMES += mines
|
||||
-GAMES += net
|
||||
+GAMES += netgame
|
||||
GAMES += netslide
|
||||
GAMES += pattern
|
||||
GAMES += pegs
|
||||
@@ -531,4 +531,4 @@ install:
|
||||
done
|
||||
|
||||
clean:
|
||||
- rm -f *.o blackbox bridges cube dominosa fifteen filling fillingsolver flip galaxies galaxiespicture galaxiessolver guess inertia latincheck lightup lightupsolver loopy loopysolver map mapsolver mineobfusc mines net netslide nullgame obfusc pattern patternsolver pegs rect samegame sixteen slant slantsolver solo solosolver tents tentssolver twiddle unequal unequalsolver untangle
|
||||
+ rm -f *.o blackbox bridges cube dominosa fifteen filling fillingsolver flip galaxies galaxiespicture galaxiessolver guess inertia latincheck lightup lightupsolver loopy loopysolver map mapsolver mineobfusc mines netgame netslide nullgame obfusc pattern patternsolver pegs rect samegame sixteen slant slantsolver solo solosolver tents tentssolver twiddle unequal unequalsolver untangle
|
Loading…
Reference in a new issue