Update gqmpeg to 0.7.3 development release. Changes from 0.7.2:
> Mouse wheel now controls volume (buttons 4, 5). - Updated translation fr, and added pt_BR. - Title of main window now shows current song. - Playlist button now toggles the playlist window on/off. - Added .okt to xmp extension types. - Better title display of http urls. - Moved 'read id3 tags' option to mpg123 config tab. - Renamed 'playlist accounting' to 'read file information' - Drop down history is now saved between runs. - Minor compile and file cleanups. * Made key presses work with capslock on (doh!), made keypad keys work. * Fix crash when preset names exceed 48 chars. * Various other changes and updates.
This commit is contained in:
parent
12b245d679
commit
7be4a71234
8 changed files with 51 additions and 39 deletions
|
@ -1,27 +1,26 @@
|
|||
# $NetBSD: Makefile,v 1.18 2000/07/31 04:14:04 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.19 2000/08/02 06:06:10 jlam Exp $
|
||||
# FreeBSD Id: Makefile,v 1.6 1998/12/28 01:02:05 vanilla Exp
|
||||
#
|
||||
|
||||
DISTNAME= gqmpeg-0.7.2
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.netpedia.net/hosting/gqview/packages/
|
||||
EXTRACT_SUFX= .tar.gz
|
||||
DISTNAME= gqmpeg-0.7.3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.netpedia.net/hosting/gqview/packages/
|
||||
|
||||
MAINTAINER= rxg@ms25.url.com.tw
|
||||
HOMEPAGE= http://www.netpedia.net/hosting/gqview/mpeg-index.html
|
||||
MAINTAINER= rxg@ms25.url.com.tw
|
||||
HOMEPAGE= http://www.netpedia.net/hosting/gqview/mpeg-index.html
|
||||
|
||||
DEPENDS+= gtk+-1.2.*:../../x11/gtk
|
||||
DEPENDS+= imlib-*:../../graphics/imlib
|
||||
DEPENDS+= mpg123-0.59r:../../audio/mpg123
|
||||
DEPENDS+= gdk-pixbuf>=0.8.0nb1:../../graphics/gdk-pixbuf
|
||||
DEPENDS+= gettext>=0.10.35nb1:../../devel/gettext
|
||||
DEPENDS+= gdk-pixbuf>=0.8.0nb1:../../graphics/gdk-pixbuf
|
||||
DEPENDS+= gettext>=0.10.35nb1:../../devel/gettext
|
||||
DEPENDS+= gtk+-1.2.*:../../x11/gtk
|
||||
DEPENDS+= imlib-*:../../graphics/imlib
|
||||
DEPENDS+= mpg123-0.59r:../../audio/mpg123
|
||||
|
||||
USE_X11BASE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-included-gettext=no
|
||||
USE_X11BASE= # defined
|
||||
|
||||
XCFLAGS+= -I${LOCALBASE}/include
|
||||
CONFIGURE_ENV+= CFLAGS=${XCFLAGS}
|
||||
MAKE_ENV+= CFLAGS=${XCFLAGS}
|
||||
GNU_CONFIGURE= # defined
|
||||
CONFIGURE_ARGS+= --without-included-gettext
|
||||
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include # libintl.h
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.8 2000/07/06 00:46:11 hubertf Exp $
|
||||
$NetBSD: md5,v 1.9 2000/08/02 06:06:14 jlam Exp $
|
||||
|
||||
MD5 (gqmpeg-0.7.2.tar.gz) = 5bab7ee3144b0aa015fe8ca56bc5a4d6
|
||||
MD5 (gqmpeg-0.7.3.tar.gz) = 23b7a900e13d80f5a42ff5a65c5fc2ee
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.3 2000/07/06 00:46:11 hubertf Exp $
|
||||
$NetBSD: patch-sum,v 1.4 2000/08/02 06:06:14 jlam Exp $
|
||||
|
||||
MD5 (patch-aa) = 1f9b5beb44696f0c2f431709fcf2cc90
|
||||
MD5 (patch-aa) = f276e6a2f0270b78b8ae8c6bff0dcfa5
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.8 2000/07/06 00:46:11 hubertf Exp $
|
||||
$NetBSD: patch-aa,v 1.9 2000/08/02 06:06:15 jlam Exp $
|
||||
|
||||
--- Makefile.in.orig Thu Jul 6 00:25:15 2000
|
||||
+++ Makefile.in Thu Jul 6 00:25:22 2000
|
||||
@@ -96,7 +96,7 @@
|
||||
l = @l@
|
||||
localedir = @localedir@
|
||||
|
||||
-SUBDIRS = src plugin intl po
|
||||
+SUBDIRS = src plugin po
|
||||
DIST_SUBDIRS = src plugin intl po
|
||||
|
||||
man_MANS = gqmpeg.1
|
||||
--- po/Makefile.in.in.orig Mon Jun 5 20:46:40 2000
|
||||
+++ po/Makefile.in.in Wed Aug 2 01:44:50 2000
|
||||
@@ -19,7 +19,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
datadir = $(prefix)/@DATADIRNAME@
|
||||
-localedir = $(datadir)/locale
|
||||
+localedir = $(prefix)/share/locale
|
||||
gnulocaledir = $(prefix)/share/locale
|
||||
gettextsrcdir = $(prefix)/share/gettext/po
|
||||
subdir = po
|
||||
|
|
|
@ -1 +1 @@
|
|||
X Windows front end to mpg123
|
||||
GTK+ front end to mpg123
|
||||
|
|
|
@ -12,3 +12,5 @@ Features:
|
|||
- Basic file management (move/copy/rename/delete)
|
||||
- Tab completion in most dialogs.
|
||||
- Presets for playlists.
|
||||
- Drag and drop support.
|
||||
- Shoutcast (http://server:port) support.
|
||||
|
|
|
@ -1,4 +1,14 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.3 2000/08/02 06:06:15 jlam Exp $
|
||||
|
||||
If you want other skins, you can download them from
|
||||
http://www.geocities.com/SiliconValley/Haven/5235/mpeg-skin.html
|
||||
To unpack them into HOME/.gqmpeg/skins then type
|
||||
"gqmpeg -skin:skinfile (the skin in the directory named skinfile)" to use them.
|
||||
|
||||
http://www.netpedia.net/hosting/gqview/mpeg-skin.html
|
||||
|
||||
Unpack them into the directory $HOME/.gqmpeg/skins, then type
|
||||
|
||||
gqmpeg -skin:skindir
|
||||
|
||||
to use them, where "skindir" is the directory containing the skin you
|
||||
wish to use.
|
||||
===========================================================================
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2000/07/06 00:46:12 hubertf Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2000/08/02 06:06:16 jlam Exp $
|
||||
bin/gqmpeg
|
||||
bin/gqmpeg-shoutcast-plugin.sh
|
||||
man/man1/gqmpeg.1
|
||||
|
@ -7,6 +7,7 @@ share/locale/cs/LC_MESSAGES/gqmpeg.mo
|
|||
share/locale/de/LC_MESSAGES/gqmpeg.mo
|
||||
share/locale/fr/LC_MESSAGES/gqmpeg.mo
|
||||
share/locale/ja/LC_MESSAGES/gqmpeg.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/gqmpeg.mo
|
||||
share/pixmaps/gqmpeg.png
|
||||
@exec mkdir -p %D/share/gqmpeg/skins
|
||||
@unexec rm -fr %D/share/gqmpeg/skins
|
||||
|
|
Loading…
Reference in a new issue