import the gd graphics generation library

This commit is contained in:
explorer 1998-03-07 21:59:13 +00:00
parent 455a08229f
commit 7c11f99455
7 changed files with 97 additions and 0 deletions

22
graphics/gd/Makefile Normal file
View file

@ -0,0 +1,22 @@
# New ports collection makefile for: gd
# Version required: 1.2
# Date created: 28 Jan 1997
# Whom: jeff@cetlink.net
#
# $NetBSD: Makefile,v 1.1.1.1 1998/03/07 21:59:13 explorer Exp $
# $FreeBSD Id: Makefile,v 1.2 1997/02/14 07:55:45 asami Exp $
#
DISTNAME= gd1.2
PKGNAME= gd-1.2
CATEGORIES= graphics
MASTER_SITES= http://www.boutell.com/gd/
EXTRACT_SUFX= .tar.Z
MAINTAINER= packages@netbsd.org
pre-install:
${MKDIR} ${PREFIX}/include/gd
${MKDIR} ${PREFIX}/share/examples/gd
.include <bsd.port.mk>

1
graphics/gd/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (gd1.2.tar.Z) = 7c703fca9a78d3468d363334adc9b54c

View file

@ -0,0 +1,27 @@
--- Makefile.orig Tue Aug 8 14:28:27 1995
+++ Makefile Sat Jun 14 18:19:04 1997
@@ -7,9 +7,9 @@
#If the ar command fails on your system, consult the ar manpage
#for your system.
-CC=gcc
-AR=ar
-CFLAGS=-O
+#CC=gcc
+#AR=ar
+#CFLAGS=-O
LIBS=-L./ -lgd -lm
all: libgd.a gddemo giftogd webgif
@@ -32,3 +32,11 @@
clean:
rm -f *.o *.a gddemo giftogd
+install:
+ install -cs -o bin -g bin gddemo giftogd webgif ${PREFIX}/bin
+ install -c -o bin -g bin libgd.a ${PREFIX}/lib
+ install -c -o bin -g bin gd.h gdfonts.h ${PREFIX}/include/gd
+ install -c -o bin -g bin gdfontt.h gdfontmb.h ${PREFIX}/include/gd
+ install -c -o bin -g bin gdfontl.h gdfontg.h ${PREFIX}/include/gd
+ install -c -o bin -g bin index.html ${PREFIX}/share/examples/gd
+ install -c -o bin -g bin demoin.gif ${PREFIX}/share/examples/gd

View file

@ -0,0 +1,13 @@
*** gd.c.dist Tue Jan 28 14:39:24 1997
--- gd.c Tue Jan 28 14:39:42 1997
***************
*** 1,4 ****
! #include <malloc.h>
#include <stdio.h>
#include <math.h>
#include <string.h>
--- 1,4 ----
! #include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <string.h>

1
graphics/gd/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
A graphics library for fast GIF creation

19
graphics/gd/pkg/DESCR Normal file
View file

@ -0,0 +1,19 @@
DESCRIPTION
gd is a graphics library. It allows your code to quickly draw images
complete with lines, arcs, text, multiple colors, cut and paste from
other images, and flood fills, and write out the result as a .GIF file.
This is particularly useful in World Wide Web applications, where .GIF
is the format used for inline images.
gd is not a paint program. If you are looking for a paint program, try
xpaint by David Koblas, available by anonymous FTP from ftp.netcom.com
in pub/ko/koblas. (That package is for the X Window System; for the Mac
and the PC, paint programs are considerably easier to find.)
gd does not provide for every possible desirable graphics operation. It
is not necessary or desirable for gd to become a kitchen-sink graphics
package, but version 1.2 incorporates most of the commonly requested
features for a 2D package.
AUTHOR
gd 1.2 was written by Thomas Boutell and is currently distributed by
boutell.com, Inc.

14
graphics/gd/pkg/PLIST Normal file
View file

@ -0,0 +1,14 @@
bin/gddemo
bin/giftogd
bin/webgif
include/gd/gd.h
include/gd/gdfontg.h
include/gd/gdfontl.h
include/gd/gdfontmb.h
include/gd/gdfonts.h
include/gd/gdfontt.h
lib/libgd.a
share/examples/gd/demoin.gif
share/examples/gd/index.html
@dirrm include/gd
@dirrm share/examples/gd