ExtUtils-MakeMaker-7.48 rejects invalid MIN_PERL_VERSION values.
Apply patch from <https://rt.cpan.org/Public/Bug/Display.html?id=133491>.
This commit is contained in:
parent
2bcba1b073
commit
7c72a7685a
5 changed files with 77 additions and 1 deletions
|
@ -1,6 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.6 2016/07/09 02:30:41 wen Exp $
|
||||
$NetBSD: distinfo,v 1.7 2021/05/25 11:20:55 schmonz Exp $
|
||||
|
||||
SHA1 (URI-Fetch-0.13.tar.gz) = 7cfae8948f14f84d85f598911b69cc3df4cb7ff2
|
||||
RMD160 (URI-Fetch-0.13.tar.gz) = 2760d29016eb125e3760355c1c876df099d2a298
|
||||
SHA512 (URI-Fetch-0.13.tar.gz) = 8df3e15bf49a7038b2a7c0d2d175bd69ed7fd6ba83bf13e65c18a46e356465bf57e1d725a6c940830dac3c3f3af294c56bb4685ede5181904b7c9a14260145e4
|
||||
Size (URI-Fetch-0.13.tar.gz) = 16669 bytes
|
||||
SHA1 (patch-META.json) = 247227107c5f9222009219a241ef1d704d11c993
|
||||
SHA1 (patch-META.yml) = a26ac05d4ea00636951e95bfb2fe81d3a82493a5
|
||||
SHA1 (patch-Makefile.PL) = b097c1f367d70a498ba670c30fd42be91ff1817b
|
||||
SHA1 (patch-lib_URI_Fetch.pm) = 5899a2e8ea5b4515629a46e660d242f13e638c4a
|
||||
|
|
16
www/p5-URI-Fetch/patches/patch-META.json
Normal file
16
www/p5-URI-Fetch/patches/patch-META.json
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-META.json,v 1.1 2021/05/25 11:20:55 schmonz Exp $
|
||||
|
||||
ExtUtils-MakeMaker-7.48 rejects invalid MIN_PERL_VERSION values.
|
||||
Apply patch from <https://rt.cpan.org/Public/Bug/Display.html?id=133491>.
|
||||
|
||||
--- META.json.orig 2016-07-02 08:35:41.000000000 +0000
|
||||
+++ META.json
|
||||
@@ -28,7 +28,7 @@
|
||||
"URI" : "0",
|
||||
"base" : "0",
|
||||
"constant" : "0",
|
||||
- "perl" : "5.008_001",
|
||||
+ "perl" : "5.008001",
|
||||
"strict" : "0",
|
||||
"warnings" : "0"
|
||||
}
|
16
www/p5-URI-Fetch/patches/patch-META.yml
Normal file
16
www/p5-URI-Fetch/patches/patch-META.yml
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-META.yml,v 1.1 2021/05/25 11:20:55 schmonz Exp $
|
||||
|
||||
ExtUtils-MakeMaker-7.48 rejects invalid MIN_PERL_VERSION values.
|
||||
Apply patch from <https://rt.cpan.org/Public/Bug/Display.html?id=133491>.
|
||||
|
||||
--- META.yml.orig 2016-07-02 08:35:41.000000000 +0000
|
||||
+++ META.yml
|
||||
@@ -23,7 +23,7 @@ requires:
|
||||
URI: '0'
|
||||
base: '0'
|
||||
constant: '0'
|
||||
- perl: 5.008_001
|
||||
+ perl: 5.008001
|
||||
strict: '0'
|
||||
warnings: '0'
|
||||
resources:
|
25
www/p5-URI-Fetch/patches/patch-Makefile.PL
Normal file
25
www/p5-URI-Fetch/patches/patch-Makefile.PL
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-Makefile.PL,v 1.1 2021/05/25 11:20:55 schmonz Exp $
|
||||
|
||||
ExtUtils-MakeMaker-7.48 rejects invalid MIN_PERL_VERSION values.
|
||||
Apply patch from <https://rt.cpan.org/Public/Bug/Display.html?id=133491>.
|
||||
|
||||
--- Makefile.PL.orig 2016-07-02 08:35:41.000000000 +0000
|
||||
+++ Makefile.PL
|
||||
@@ -2,7 +2,7 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
|
||||
-use 5.008_001;
|
||||
+use 5.008001;
|
||||
|
||||
use ExtUtils::MakeMaker;
|
||||
|
||||
@@ -15,7 +15,7 @@ my %WriteMakefileArgs = (
|
||||
"DISTNAME" => "URI-Fetch",
|
||||
"EXE_FILES" => [],
|
||||
"LICENSE" => "perl",
|
||||
- "MIN_PERL_VERSION" => "5.008_001",
|
||||
+ "MIN_PERL_VERSION" => "5.008001",
|
||||
"NAME" => "URI::Fetch",
|
||||
"PREREQ_PM" => {
|
||||
"Carp" => 0,
|
15
www/p5-URI-Fetch/patches/patch-lib_URI_Fetch.pm
Normal file
15
www/p5-URI-Fetch/patches/patch-lib_URI_Fetch.pm
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-lib_URI_Fetch.pm,v 1.1 2021/05/25 11:20:55 schmonz Exp $
|
||||
|
||||
ExtUtils-MakeMaker-7.48 rejects invalid MIN_PERL_VERSION values.
|
||||
Apply patch from <https://rt.cpan.org/Public/Bug/Display.html?id=133491>.
|
||||
|
||||
--- lib/URI/Fetch.pm.orig 2016-07-02 08:35:41.000000000 +0000
|
||||
+++ lib/URI/Fetch.pm
|
||||
@@ -1,6 +1,6 @@
|
||||
package URI::Fetch;
|
||||
$URI::Fetch::VERSION = '0.13';
|
||||
-use 5.008_001;
|
||||
+use 5.008001;
|
||||
use strict;
|
||||
use warnings;
|
||||
|
Loading…
Reference in a new issue