update to xf86-video-chips-1.2.5 for modular-xorg-server-1.12.4
This commit is contained in:
parent
4d46091fb6
commit
7c7fbde5ba
4 changed files with 30 additions and 70 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.10 2012/10/29 05:07:03 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2013/05/16 06:05:19 richard Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xf86-video-chips-1.2.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= xf86-video-chips-1.2.5
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_XORG:=driver/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -21,6 +20,14 @@ USE_TOOLS+= pkg-config
|
|||
CONFIGURE_ENV+= DRIVER_MAN_SUFFIX=4
|
||||
.endif
|
||||
|
||||
#
|
||||
# it appears the 1.2.5 tarball forgot something
|
||||
#
|
||||
post-extract:
|
||||
.if !exists(${WRKSRC}/util/iopl.h)
|
||||
${CP} ${FILESDIR}/iopl.h ${WRKSRC}/util/
|
||||
.endif
|
||||
|
||||
.include "../../x11/modular-xorg-server/buildlink3.mk"
|
||||
.include "../../x11/randrproto/buildlink3.mk"
|
||||
.include "../../x11/renderproto/buildlink3.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.4 2009/06/09 02:46:10 obache Exp $
|
||||
$NetBSD: distinfo,v 1.5 2013/05/16 06:05:19 richard Exp $
|
||||
|
||||
SHA1 (xf86-video-chips-1.2.1.tar.bz2) = 95705cb8d970fb52fb21e05acad952b71afb808b
|
||||
RMD160 (xf86-video-chips-1.2.1.tar.bz2) = 65f2e5f5414c95ff06aba99c3b89ef40bd65310e
|
||||
Size (xf86-video-chips-1.2.1.tar.bz2) = 340894 bytes
|
||||
SHA1 (patch-aa) = f815269f9ff15905fd3d06a72dc0b19c3bb7e8f9
|
||||
SHA1 (xf86-video-chips-1.2.5.tar.bz2) = 5642e1d1bf3a05d24a0b8db48ca3b522c1962b00
|
||||
RMD160 (xf86-video-chips-1.2.5.tar.bz2) = 11a23a67a96db8e40465b262853084495ef8a7b5
|
||||
Size (xf86-video-chips-1.2.5.tar.bz2) = 398804 bytes
|
||||
SHA1 (patch-util_Makefile.am) = 450f13ea360f0631db3ee8f7bedc76e4b70efbab
|
||||
|
|
|
@ -1,62 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.4 2009/06/09 02:46:10 obache Exp $
|
||||
|
||||
--- configure.orig 2008-12-22 04:26:01.000000000 +0000
|
||||
+++ configure
|
||||
@@ -21964,57 +21964,8 @@ fi
|
||||
|
||||
|
||||
# Checks for functions (often defined as inlines in compiler.h)
|
||||
-{ $as_echo "$as_me:$LINENO: checking for inb" >&5
|
||||
-$as_echo_n "checking for inb... " >&6; }
|
||||
-cat >conftest.$ac_ext <<_ACEOF
|
||||
-/* confdefs.h. */
|
||||
-_ACEOF
|
||||
-cat confdefs.h >>conftest.$ac_ext
|
||||
-cat >>conftest.$ac_ext <<_ACEOF
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
-#include "util/AsmMacros.h"
|
||||
-
|
||||
-int main() {
|
||||
- int x = inb(0);
|
||||
- return x;
|
||||
-}
|
||||
-
|
||||
-_ACEOF
|
||||
-rm -f conftest.$ac_objext conftest$ac_exeext
|
||||
-if { (ac_try="$ac_link"
|
||||
-case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
||||
-$as_echo "$ac_try_echo") >&5
|
||||
- (eval "$ac_link") 2>conftest.er1
|
||||
- ac_status=$?
|
||||
- grep -v '^ *+' conftest.er1 >conftest.err
|
||||
- rm -f conftest.er1
|
||||
- cat conftest.err >&5
|
||||
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } && {
|
||||
- test -z "$ac_c_werror_flag" ||
|
||||
- test ! -s conftest.err
|
||||
- } && test -s conftest$ac_exeext && {
|
||||
- test "$cross_compiling" = yes ||
|
||||
- $as_test_x conftest$ac_exeext
|
||||
- }; then
|
||||
- HAVE_INB=yes
|
||||
-else
|
||||
- $as_echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
HAVE_INB=no
|
||||
-fi
|
||||
|
||||
-rm -rf conftest.dSYM
|
||||
-rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
|
||||
- conftest$ac_exeext conftest.$ac_ext
|
||||
-{ $as_echo "$as_me:$LINENO: result: $HAVE_INB" >&5
|
||||
-$as_echo "$HAVE_INB" >&6; }
|
||||
if test x$HAVE_INB = xyes; then
|
||||
BUILD_UTILS_TRUE=
|
||||
BUILD_UTILS_FALSE='#'
|
15
x11/xf86-video-chips/patches/patch-util_Makefile.am
Normal file
15
x11/xf86-video-chips/patches/patch-util_Makefile.am
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-util_Makefile.am,v 1.1 2013/05/16 06:05:19 richard Exp $
|
||||
|
||||
--- util/Makefile.am.orig 2012-06-05 17:37:42.000000000 +0000
|
||||
+++ util/Makefile.am
|
||||
@@ -3,7 +3,7 @@ if BUILD_UTILS
|
||||
noinst_PROGRAMS = dRegs mRegs modClock memClock
|
||||
endif
|
||||
|
||||
-dRegs_SOURCES = dRegs.c AsmMacros.h
|
||||
-mRegs_SOURCES = mRegs.c AsmMacros.h
|
||||
-modClock_SOURCES = modClock.c AsmMacros.h
|
||||
+dRegs_SOURCES = dRegs.c AsmMacros.h iopl.h
|
||||
+mRegs_SOURCES = mRegs.c AsmMacros.h iopl.h
|
||||
+modClock_SOURCES = modClock.c AsmMacros.h iopl.h
|
||||
memClock_SOURCES = modClock.c AsmMacros.h
|
Loading…
Reference in a new issue