Don't abort the emulator if the mm58167 gets a read to an unexpected

register, just return 0 instead.
This commit is contained in:
thorpej 2020-03-05 14:55:16 +00:00
parent 272f527de2
commit 7c8c23ba0e
3 changed files with 21 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.73 2020/03/04 07:52:11 rin Exp $
# $NetBSD: Makefile,v 1.74 2020/03/05 14:55:16 thorpej Exp $
#
DISTNAME= tme-0.8
PKGREVISION= 40
PKGREVISION= 41
CATEGORIES= emulators
MASTER_SITES= http://csail.mit.edu/~fredette/tme/

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.24 2020/03/04 07:52:11 rin Exp $
$NetBSD: distinfo,v 1.25 2020/03/05 14:55:16 thorpej Exp $
SHA1 (tme-0.8.tar.gz) = dd4f3421c20ceed548c5328a21dbb26e80f46b9c
RMD160 (tme-0.8.tar.gz) = 6bd505c5fa7810d37f436883383c4ba655df2ded
@ -19,6 +19,7 @@ SHA1 (patch-ic_m68k_m6888x.c) = fe42dce7bf5abc69e2c9e15967d5e862ef651a0e
SHA1 (patch-ic_m68k_m68k-insns-auto.sh) = c493b4c6b066135e093abd7482e0a1e99294848b
SHA1 (patch-ic_m68k_m68k-m68k-insns.c) = 1a9d8e3d4e11c5710d1f67b65954d6e3de68d99f
SHA1 (patch-ic_m68k_m68k-misc.c) = 7aeef098631196fe60b9940600cf90c86d1be375
SHA1 (patch-ic_mm58167.c) = 1c35c599f56f6a13a9dfc85dc5154f094bd8c0d0
SHA1 (patch-libtme_memory-auto.sh) = f7d989831b2468d1288faabc10b6fc53ce5bd0f4
SHA1 (patch-machine_sun2_SUN2-MULTIBUS) = cf9f55fcc15e2d977823dd54b9a10c42b11a6666
SHA1 (patch-machine_sun2_sun2-mainbus.c) = 91b901d37d5f9a72064831d440c4371b81857640

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ic_mm58167.c,v 1.1 2020/03/05 14:55:16 thorpej Exp $
Don't abort the emulator if we get a read for an unexpected register (which
seems to happen with NetBSD 9 on sun2); just return 0 instead.
--- ic/mm58167.c.orig 2020-03-05 14:20:42.000000000 +0000
+++ ic/mm58167.c 2020-03-05 14:21:25.000000000 +0000
@@ -219,7 +219,8 @@ _tme_mm58167_bus_cycle(void *_mm58167, s
mm58167->tme_mm58167_status = 0;
break;
default:
- abort();
+ value = 0;
+ break;
}
/* if needed, convert this value to BCD: */