Update goaccess to 0.8

Changes to GoAccess 0.8 - Tuesday, May 20, 2014

  * Added APT-HTTP to the list of browsers.
  * Added data persistence and ability to load data from disk.
  * Added IE11 to the list of browsers.
  * Added IEMobile to the list of browsers.
  * Added multiple command line options.
  * Added Nagios check_http to the list of browsers.
  * Added parsing progress metrics - total requests / requests per second.
  * Added the ability to parse a GeoLiteCity.dat to get the city given an IPv4.
  * Change the way the configuration file is parsed. This will parse all
    configuration options under ~/.goaccessrc or the specified config file and will
    feed getopt_long with the extracted key/value pairs. This also allows the
    ability to have comments on the config file which won't be overwritten.
  * Ensure autoconf determines the location of ncurses headers.
  * Fixed issue where geo_location_data was NULL.
  * Fixed issue where GoAccess did not run without a tty allocated to it.
  * Fixed potential memory leak on --log-file realpath().
  * Fixed Solaris build errors.
  * Implemented an on-memory hash database using Tokyo Cabinet. This implementation
    allows GoAccess not to rely on GLib's hash table if one is needed.
  * Implemented large file support using an on-disk B+ Tree database. This
    implementation allows GoAccess not to hold everything in memory but instead it
    uses an on-disk B+ Tree database.
  * Trimmed leading and trailing whitespaces from keyphrases module.
This commit is contained in:
wiedi 2014-06-14 09:56:16 +00:00
parent 01edf7ade1
commit 7d3735cc1b
4 changed files with 31 additions and 9 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.2 2014/02/22 14:27:43 wiedi Exp $
# $NetBSD: Makefile,v 1.3 2014/06/14 09:56:16 wiedi Exp $
DISTNAME= goaccess-0.7.1
DISTNAME= goaccess-0.8
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=goaccess/}
MASTER_SITES= http://tar.goaccess.io/
MAINTAINER= wiedi@frubar.net
HOMEPAGE= http://goaccess.prosoftcorp.com/
@ -11,13 +11,19 @@ LICENSE= gnu-gpl-v2
GNU_CONFIGURE= yes
USE_TOOLS+= pkg-config
USE_TOOLS+= pkg-config aclocal automake
USE_NCURSES= yes
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
CONF_FILES= ${EGDIR}/goaccess.conf ${PKG_SYSCONFDIR}/goaccess.conf
LIBS.SunOS+= -lsocket -lnsl
CPPFLAGS.SunOS+= -D__EXTENSIONS__
.include "options.mk"
pre-configure:
cd ${WRKSRC} && aclocal && automake --add-missing
.include "../../devel/glib2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2014/01/27 21:40:38 wiedi Exp $
@comment $NetBSD: PLIST,v 1.2 2014/06/14 09:56:16 wiedi Exp $
bin/goaccess
man/man1/goaccess.1
share/examples/goaccess/goaccess.conf

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.2 2014/02/22 14:27:43 wiedi Exp $
$NetBSD: distinfo,v 1.3 2014/06/14 09:56:16 wiedi Exp $
SHA1 (goaccess-0.7.1.tar.gz) = 3b546062776df00bd539072c5bdfec2a62cbeb84
RMD160 (goaccess-0.7.1.tar.gz) = 5b58dfdd9137087f5fe24eb90a6fce66483e88d8
Size (goaccess-0.7.1.tar.gz) = 163640 bytes
SHA1 (goaccess-0.8.tar.gz) = 8c220e7e65a6e45ae5a2221e241e976d07c23def
RMD160 (goaccess-0.8.tar.gz) = 16f75fcba38dfb986737db1c35d7f50583057afa
Size (goaccess-0.8.tar.gz) = 184740 bytes
SHA1 (patch-Makefile.am) = 88ab1ca265e9d46bb664db42eb96b1946e624a29

View file

@ -0,0 +1,14 @@
$NetBSD: patch-Makefile.am,v 1.1 2014/06/14 09:56:16 wiedi Exp $
deploy example config in the correct place
--- Makefile.am.orig 2014-05-04 01:12:19.000000000 +0000
+++ Makefile.am
@@ -1,7 +1,7 @@
#AUTOMAKE_OPTIONS = foreign
bin_PROGRAMS = goaccess
-confdir = $(sysconfdir)
+confdir = $(PREFIX)/share/examples/goaccess
dist_conf_DATA = config/goaccess.conf
goaccess_SOURCES = \