Remove libscsi and the two packages using it, tosha and cdd.

The FreeBSD SCSI library on which libscsi was based, was removed in 1998.
The two other packages were last updated 1997 and 2001, respectively.
Better software exists (e.g. cdparanoia, cdrecord).

Ok agc@, gdt@
This commit is contained in:
wiz 2011-11-23 18:59:20 +00:00
parent 9f19f0d653
commit 7d666451a5
29 changed files with 2 additions and 550 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.461 2011/11/17 04:27:51 jnemeth Exp $
# $NetBSD: Makefile,v 1.462 2011/11/23 18:59:20 wiz Exp $
#
COMMENT= Audio tools
@ -54,7 +54,6 @@ SUBDIR+= bsl
SUBDIR+= buzztard
SUBDIR+= cam
SUBDIR+= cd-discid
SUBDIR+= cdd
SUBDIR+= cddb-bundle
SUBDIR+= cddbd
SUBDIR+= cdparanoia
@ -375,7 +374,6 @@ SUBDIR+= terminatorx
SUBDIR+= tfmxplay
SUBDIR+= timidity
SUBDIR+= toolame
SUBDIR+= tosha
SUBDIR+= tracker
SUBDIR+= tremor
SUBDIR+= tremor-tools

View file

@ -1,6 +0,0 @@
CDD is as the name implies, an attempt at a DD utility for CD's of all
flavors. CDD will do its best to copy CD audio data, CD-ROM data in both
raw and "cooked" forms to a directory of the users choice.
CDD doesn't support every CD-ROM drive, though it supports many common
ones, including those that support the new MMC command set.

View file

@ -1,25 +0,0 @@
# $NetBSD: Makefile,v 1.15 2008/03/02 06:10:31 jlam Exp $
DISTNAME= cdd-1.0nb3
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_LOCAL}
MAINTAINER= thorpej@NetBSD.org
COMMENT= Program for reading CD audio from SCSI/ATAPI CD-ROM drives
PKG_DESTDIR_SUPPORT= user-destdir
.include "../../mk/bsd.prefs.mk"
.if defined(CDDCPPFLAGS)
MAKE_ENV+= CDDCPPFLAGS=${CDDCPPFLAGS:Q}
.endif
INSTALLATION_DIRS= bin
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cdd ${DESTDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/stripzeros ${DESTDIR}${PREFIX}/bin
.include "../../devel/libscsi/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST,v 1.1 2001/11/01 00:15:24 zuntum Exp $
bin/cdd
bin/stripzeros

View file

@ -1,10 +0,0 @@
$NetBSD: distinfo,v 1.7 2005/02/23 20:39:43 agc Exp $
SHA1 (cdd-1.0nb3.tar.gz) = 333323444571f463501c206f9d9fd7dde09d12a6
RMD160 (cdd-1.0nb3.tar.gz) = 052cec366dbadde0c2de0f61a2d7a004cdf35a23
Size (cdd-1.0nb3.tar.gz) = 48699 bytes
SHA1 (patch-aa) = ab0188fe827c25a0c13c2af4a2b2f4806ac096bb
SHA1 (patch-ab) = e126697b7ecc8a1d03fcc9db9d12d5667e3b787c
SHA1 (patch-ac) = 39c609ac477981948f5f6822e188b52cd87d6489
SHA1 (patch-ad) = 366d863c01f38056ef636a1f5e14632236d7fb77
SHA1 (patch-ae) = fe2de6aa637a2832c066eb38f02fb9d438c1b78b

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.7 2004/11/28 23:02:26 simonb Exp $
--- cdd_cddb.c.orig Thu Jun 26 03:29:21 1997
+++ cdd_cddb.c
@@ -49,7 +49,7 @@
#include "st.h"
#define NETBUFSIZ 256;
-#define CDDB_SERVER "cddb.sonic.net"
+#define CDDB_SERVER "freedb.freedb.org"
#define CDDB_PORT 888
#define CDDB_TIMEOUT 30

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.3 2002/07/19 04:18:25 mycroft Exp $
--- st/stdriver.c.orig Tue Jun 24 19:46:28 1997
+++ st/stdriver.c Fri Jul 19 04:10:44 2002
@@ -607,8 +607,8 @@
int st_read(SOCK *entry, int timeout)
{
int ret; /* Generic return variable */
-long starttime;
-long endtime;
+time_t starttime;
+time_t endtime;
static struct timeval read_timer; /* Timeout struct for select */
static fd_set local_readfds; /* Socket bit sets for select */

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ac,v 1.3 2002/07/19 04:18:25 mycroft Exp $
--- cdd_cddb.c.orig Fri Jul 19 04:09:28 2002
+++ cdd_cddb.c Fri Jul 19 04:13:25 2002
@@ -63,7 +63,7 @@
int count;
int ret;
int track;
-long discid;
+unsigned int discid;
for(count=0;count<toc->numentries;count++)
{

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ad,v 1.8 2002/07/19 04:18:40 mycroft Exp $
--- cdd_cdcmds.c.orig Sat Jan 6 06:29:43 2001
+++ cdd_cdcmds.c Fri Jul 19 04:15:28 2002
@@ -356,7 +356,7 @@
return (F_dtable[F_pte].end_cdda_func)(scsifd);
}
-int unsupported(void)
+int unsupported()
{
cdd_printf("This operation is not supported on this device!\n");

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ae,v 1.1 2002/07/19 04:18:40 mycroft Exp $
--- cdd_cdcmds.h.orig Tue Feb 20 21:57:29 1996
+++ cdd_cdcmds.h Fri Jul 19 04:15:16 2002
@@ -57,7 +57,7 @@
void doinquiry(int scsifd);
-int unsupported(void);
+int unsupported();
int getcdtoc(int scsifd, CDTOC *cdtoc);
int cd_setblocksize(int scsifd, int bytessec);
int cddaread(char *buffer, int startlba, int blocksize,

View file

@ -1,7 +0,0 @@
"tosha" reads one or more CD-DA (digital audio) tracks or absolute
sectors and writes them into a single or multiple files, or to the
standard output.
The digital audio data is read through the SCSI bus; thus tosha
does NOT work with IDE/ATAPI CD-ROM drives nor with proprietary
interfaces.

View file

@ -1,21 +0,0 @@
# $NetBSD: Makefile,v 1.18 2009/07/08 14:03:26 joerg Exp $
DISTNAME= tosha-0.05
PKGREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_LOCAL}
MAINTAINER= pkgsrc-users@NetBSD.org
# author's homepage is at http://www.secnetix.de/~olli/, but tosha isn't mentioned
COMMENT= Read CD digital audio data through the SCSI bus
PKG_INSTALLATION_TYPES= overwrite pkgviews
PKG_DESTDIR_SUPPORT= user-destdir
CPPFLAGS+= -DDEVOSSAUDIO="\"${DEVOSSAUDIO}\""
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
.include "../../devel/libscsi/buildlink3.mk"
.include "../../mk/oss.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +0,0 @@
@comment $NetBSD: PLIST,v 1.1 2001/11/01 00:18:04 zuntum Exp $
bin/tosha
bin/pcmplay
bin/pcmfade
man/man1/tosha.1
man/man1/pcmplay.1
man/man1/pcmfade.1

View file

@ -1,10 +0,0 @@
$NetBSD: distinfo,v 1.8 2009/07/08 14:03:26 joerg Exp $
SHA1 (tosha-0.05.tar.gz) = b567f452843b544b082c88403d74ad1ca07f6820
RMD160 (tosha-0.05.tar.gz) = 21ed9253b020efba1035febe86080a2bd8cc04da
Size (tosha-0.05.tar.gz) = 17859 bytes
SHA1 (patch-aa) = eeefefb53525f903be12a8844b33a7b553a26552
SHA1 (patch-ab) = 9b4b43d6cb0fe2871cfd0e7e76ffdbd19123573a
SHA1 (patch-ac) = 26feb1151d4fb02c5831762447c7bb264517f4d6
SHA1 (patch-af) = 4a1debd7dec8eaa6e2cae2dc33c8ec1aecbfc736
SHA1 (patch-ah) = 95b93716401bf84964661834365de5da5fd7486d

View file

@ -1,48 +0,0 @@
$NetBSD: patch-aa,v 1.11 2009/07/08 14:03:26 joerg Exp $
--- Makefile.orig 1997-05-21 01:57:17.000000000 +0200
+++ Makefile 2006-06-24 10:36:24.000000000 +0200
@@ -5,7 +5,6 @@
# Wed May 21 01:51:37 MET DST 1997
#
-PREFIX=/usr/local
BINDIR=$(PREFIX)/bin
MANDIR=$(PREFIX)/man
SECTION=1
@@ -16,7 +15,7 @@ SECTION=1
###### ######
###################################################
-CFLAGS=-O2 -Wall -ansi
+# CFLAGS=-O2 -Wall -ansi
# CFLAGS=-g -Wall -ansi -pedantic
all: tosha pcmplay pcmfade
@@ -28,21 +27,17 @@ pcmplay.o: pcmplay.c utils.h getlopt.h
pcmfade.o: pcmfade.c utils.h
tosha: tosha.o utils.o getlopt.o
- $(CC) $(CFLAGS) -o tosha -lscsi tosha.o utils.o getlopt.o
+ $(CC) $(CFLAGS) -o tosha tosha.o utils.o getlopt.o ${LDFLAGS} -lscsi -lutil
pcmplay: pcmplay.o utils.o getlopt.o
- $(CC) $(CFLAGS) -o pcmplay pcmplay.o utils.o getlopt.o
+ $(CC) $(CFLAGS) -o pcmplay pcmplay.o utils.o getlopt.o ${LDFLAGS} ${LIBOSSAUDIO}
pcmfade: pcmfade.o utils.o
- $(CC) $(CFLAGS) -o pcmfade pcmfade.o utils.o
+ $(CC) $(CFLAGS) -o pcmfade pcmfade.o utils.o ${LDFLAGS}
install: tosha pcmplay pcmfade
- install -s -g bin -o bin -m 755 tosha pcmplay pcmfade $(BINDIR)
- install -c -g bin -o bin -m 644 tosha.1 pcmplay.1 pcmfade.1 \
- $(MANDIR)/man$(SECTION)
- gzip -f -9 $(MANDIR)/man$(SECTION)/tosha.1 \
- $(MANDIR)/man$(SECTION)/pcmplay.1 \
- $(MANDIR)/man$(SECTION)/pcmfade.1
+ ${BSD_INSTALL_PROGRAM} tosha pcmplay pcmfade ${DESTDIR}$(BINDIR)
+ ${BSD_INSTALL_MAN} tosha.1 pcmplay.1 pcmfade.1 ${DESTDIR}$(MANDIR)/man$(SECTION)
clean:
rm -f *.o *~ *core tosha pcmplay pcmfade

View file

@ -1,78 +0,0 @@
$NetBSD: patch-ab,v 1.6 2000/11/19 12:34:23 fvdl Exp $
--- tosha.c.orig Wed May 21 02:11:49 1997
+++ tosha.c Sun Nov 19 13:01:03 2000
@@ -49,7 +49,8 @@
#include <sys/uio.h>
#include <sys/scsiio.h>
#include <unistd.h>
-#include <scsi.h>
+#include <util.h>
+#include "scsi.h"
extern int errno;
/*
@@ -93,7 +94,7 @@
#include "getlopt.h"
typedef unsigned char byte;
-typedef unsigned long ulong;
+/*typedef unsigned long ulong;*/
struct scsireq *sreq; /* SCSI device request structure */
int scsifd; /* SCSI device file descriptor */
@@ -127,8 +128,8 @@
int result;
scsireq_reset (sreq);
- sreq->timeout = 10000;
scsireq_build (sreq, size, (char *) buf, flags, cmd);
+ sreq->timeout = 10000;
result = scsireq_enter (scsifd, sreq);
#ifndef DEBUG
if (SCSIREQ_ERROR (sreq))
@@ -182,7 +183,8 @@
char *tracklstr = "1-100";
char *outname = "track%02d.pcm";
-char *device = "/dev/cd0c";
+char device_store[256];
+char *device = device_store;
int indexonly = FALSE;
int quiet = FALSE;
int verbose = FALSE;
@@ -387,7 +389,6 @@
if ((secread = framesperbuf) > endpp - sec)
secread = endpp - sec;
scsireq_reset (sreq);
- sreq->timeout = 10000;
if (readcmd == 0xd8)
scsireq_build (sreq, FRAMESIZE * secread,
(char *) buf, SCCMD_READ,
@@ -398,6 +399,7 @@
(char *) buf, SCCMD_READ,
"v 0 0 v:i3 0 0 v 0", readcmd,
sec, secread);
+ sreq->timeout = 10000;
result = scsireq_enter (scsifd, sreq);
#ifndef DEBUG
if (SCSIREQ_ERROR (sreq))
@@ -464,6 +466,8 @@
int singlefile = FALSE;
int modechange = TRUE, denschange = 0;
+ (void) snprintf(device, 256, "/dev/rcd0%c", getrawpartition() + 'a');
+
utils_init (argv[0]);
#ifdef DEBUG
fprintf (stderr, "%s: DEBUG mode is ON.\n", me);
@@ -647,7 +651,8 @@
fprintf (stderr, " Reading ...\r");
}
else {
- asprintf (&ofname, outname, i+1);
+ ofname = malloc(1000); /* XXX */
+ sprintf (ofname, outname, i+1);
if (!quiet)
fprintf (stderr, verbose ?
" (output file: %s)\n" :

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ac,v 1.1 1998/10/28 05:43:20 garbled Exp $
--- tosha.1.orig Tue Oct 27 22:38:26 1998
+++ tosha.1 Tue Oct 27 22:40:02 1998
@@ -152,7 +152,10 @@
(raw), 44.1 kHz, signed 16 bit stereo. If you need a
different format, use
.BR sox (1)
-to convert it.
+to convert it. Output data is in little-endian format,
+regardless of the endianess of the machine you are running
+.BR tosha
+on.
.P
Not all SCSI drives work with
.BR tosha ,

View file

@ -1,13 +0,0 @@
$NetBSD: patch-af,v 1.3 2004/05/31 17:35:15 minskim Exp $
--- pcmplay.c.orig 1997-05-20 19:11:13.000000000 -0500
+++ pcmplay.c
@@ -46,7 +46,7 @@
#include "utils.h"
#include "getlopt.h"
-char *audevice = "/dev/dsp";
+char *audevice = DEVOSSAUDIO;
int buffersize = 32;
int dsp_samplesize = 16;
int dsp_channels = 2;

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ah,v 1.2 2007/10/19 13:33:25 rillig Exp $
--- utils.h.orig 1997-05-21 00:13:22.000000000 +0000
+++ utils.h 2007-10-17 21:47:24.000000000 +0000
@@ -59,6 +59,8 @@ void *tmalloc (size_t size);
* allocated.
*/
+#include <string.h>
+#define strndup tosha_strndup
char *strndup (char *src, int num);
/*
* Like strdup(), but limits the string length to at most

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1535 2011/11/23 11:43:30 hiramatsu Exp $
# $NetBSD: Makefile,v 1.1536 2011/11/23 18:59:21 wiz Exp $
#
COMMENT= Development utilities
@ -376,7 +376,6 @@ SUBDIR+= librfuncs
SUBDIR+= librlog
SUBDIR+= librsync
SUBDIR+= librxspencer
SUBDIR+= libscsi
SUBDIR+= libsexy
SUBDIR+= libsexymm
SUBDIR+= libsigc++

View file

@ -1,10 +0,0 @@
This library is meant for userland access to SCSI devices. The
library is part of the FreeBSD distribution but works for
NetBSD as well.
The functions of the library use the SCIOCCOMMAND ioctl(2) of
the NetBSD SCSI subsystem to provide user level access to SCSI
commands. The programmer must know the SCSI CDB (Command
Descriptor Block) to perform the desired command. These
functions assist in building up the CDB, submitting it to the
SCSI subsystem, and decoding the result.

View file

@ -1,23 +0,0 @@
# $NetBSD: Makefile,v 1.17 2011/11/22 10:47:14 marino Exp $
#
DISTNAME= libscsi-1.6
PKGREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.emsi.priv.at/pub/netbsd/contrib/
MAINTAINER= pkgsrc-users@NetBSD.org
COMMENT= FreeBSD SCSI user library
ONLY_FOR_PLATFORM= NetBSD-*-* OpenBSD-*-*
PKG_INSTALLATION_TYPES= overwrite pkgviews
PKG_DESTDIR_SUPPORT= user-destdir
USE_BSD_MAKEFILE= yes
INSTALLATION_DIRS= include lib ${PKGMANDIR}/cat3 ${PKGMANDIR}/man3
BUILDLINK_TRANSFORM+= rm:-Werror
.include "../../mk/bsd.pkg.mk"

View file

@ -1,27 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 2005/10/23 16:03:11 rillig Exp $
include/scsi.h
lib/libscsi.a
man/cat3/SCSIREQ_ERROR.0
man/cat3/scsi.0
man/cat3/scsi_debug.0
man/cat3/scsi_debug_output.0
man/cat3/scsi_open.0
man/cat3/scsireq_buff_decode.0
man/cat3/scsireq_build.0
man/cat3/scsireq_decode.0
man/cat3/scsireq_encode.0
man/cat3/scsireq_enter.0
man/cat3/scsireq_new.0
man/cat3/scsireq_reset.0
man/man3/SCSIREQ_ERROR.3
man/man3/scsi.3
man/man3/scsi_debug.3
man/man3/scsi_debug_output.3
man/man3/scsi_open.3
man/man3/scsireq_buff_decode.3
man/man3/scsireq_build.3
man/man3/scsireq_decode.3
man/man3/scsireq_encode.3
man/man3/scsireq_enter.3
man/man3/scsireq_new.3
man/man3/scsireq_reset.3

View file

@ -1,13 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.6 2009/03/20 19:24:22 joerg Exp $
BUILDLINK_TREE+= libscsi
.if !defined(LIBSCSI_BUILDLINK3_MK)
LIBSCSI_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.libscsi+= libscsi>=1.6
BUILDLINK_PKGSRCDIR.libscsi?= ../../devel/libscsi
BUILDLINK_DEPMETHOD.libscsi?= build
.endif # LIBSCSI_BUILDLINK3_MK
BUILDLINK_TREE+= -libscsi

View file

@ -1,9 +0,0 @@
$NetBSD: distinfo,v 1.7 2009/07/08 14:02:49 joerg Exp $
SHA1 (libscsi-1.6.tar.gz) = 8d6d47d2baa5e272e09ac5ee1330dd37461e922f
RMD160 (libscsi-1.6.tar.gz) = 586e0b73777a6be41f075c2b6f4fb73c81d7fa03
Size (libscsi-1.6.tar.gz) = 11896 bytes
SHA1 (patch-aa) = d34b6769997c3fe29b99d0465710bd3c5d9bcda8
SHA1 (patch-ab) = 6f8f913a0348666b973dfb50509c77c1a0056cc9
SHA1 (patch-ac) = 26234441505ad213642692f5b705e166c48eba47
SHA1 (patch-ad) = 7772f992e3df11b0461db33c91ff570f90ea82db

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.2 1998/08/07 10:40:25 agc Exp $
--- scsi.3.orig Wed Feb 18 15:43:00 1998
+++ scsi.3 Sat May 2 20:42:48 1998
@@ -75,7 +75,7 @@
These functions
use the SCIOCCOMMAND
.Xr ioctl 2
-of the FreeBSD SCSI subsystem
+of the NetBSD SCSI subsystem
to provide user level access to SCSI commands.
The programmer must know the SCSI CDB (Command Descriptor
Block) to perform the desired command. These functions assist in

View file

@ -1,30 +0,0 @@
$NetBSD: patch-ab,v 1.7 2009/07/08 14:02:49 joerg Exp $
--- Makefile.orig Wed Feb 18 15:43:00 1998
+++ Makefile Thu Dec 20 12:22:50 2001
@@ -4,7 +4,13 @@
#CFLAGS+=-DLIBC_SCCS -I${.CURDIR}/../../sys
SRCS= scsi.c
-MAN3= scsi.3
+NOLINT= 1
+NOPIC= 1
+NOPROFILE= 1
+
+MANINSTALL= maninstall catinstall
+
+MAN+= scsi.3
MLINKS+=scsi.3 scsireq_buff_decode.3 scsi.3 scsireq_build.3 \
scsi.3 scsireq_decode.3 scsi.3 scsireq_encode.3 \
@@ -14,8 +20,8 @@
scsi.3 scsi_debug_output.3
beforeinstall:
- ${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m 444 ${.CURDIR}/scsi.h \
- ${DESTDIR}/usr/include
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 444 ${.CURDIR}/scsi.h \
+ ${DESTDIR}${PREFIX}/include
.include <bsd.lib.mk>

View file

@ -1,75 +0,0 @@
$NetBSD: patch-ac,v 1.2 1998/08/07 10:40:25 agc Exp $
--- scsi.c.orig Sat Jun 20 02:30:03 1998
+++ scsi.c Sat Jun 20 03:00:07 1998
@@ -353,2 +353,11 @@
+static int wrap_do_buff_decode(u_char *databuf, size_t len,
+void (*arg_put)(void *, int , void *, int, char *), void *puthook,
+char *fmt, ...)
+{
+ va_list ap;
+ va_start(ap,fmt);
+ return do_buff_decode(databuf,len,arg_put,puthook,fmt,ap);
+}
+
int scsireq_decode(scsireq_t *scsireq, char *fmt, ...)
@@ -364,5 +373,4 @@
{
- va_list ap = (va_list)0;
- return do_buff_decode(scsireq->databuf, (size_t)scsireq->datalen,
- arg_put, puthook, fmt, ap);
+ return wrap_do_buff_decode(scsireq->databuf, (size_t)scsireq->datalen,
+ arg_put, puthook, fmt);
}
@@ -379,4 +387,3 @@
{
- va_list ap = (va_list)0;
- return do_buff_decode(buff, len, arg_put, puthook, fmt, ap);
+ return wrap_do_buff_decode(buff, len, arg_put, puthook, fmt);
}
@@ -752,2 +759,10 @@
+static int wrap_do_encode(u_char *buff, size_t vec_max, size_t *used,
+int (*arg_get)(void *, char *), void *gethook, char *fmt, ...)
+{
+ va_list ap;
+ va_start(ap,fmt);
+ return do_encode(buff,vec_max,used,arg_get,gethook,fmt,ap);
+}
+
/* XXX: Should be a constant in scsiio.h
@@ -760,3 +775,3 @@
{
- int cmdlen;
+ size_t cmdlen;
va_list ap;
@@ -800,4 +815,3 @@
{
- int cmdlen;
- va_list ap = (va_list) 0;
+ size_t cmdlen;
@@ -826,4 +840,4 @@
- if (do_encode(scsireq->cmd, CMD_BUFLEN, &cmdlen, arg_get, gethook,
- cmd_spec, ap) == -1)
+ if (wrap_do_encode(scsireq->cmd, CMD_BUFLEN, &cmdlen, arg_get, gethook,
+ cmd_spec) == -1)
return 0;
@@ -851,5 +865,4 @@
{
- va_list ap = (va_list)0;
- return do_encode(buff, len, 0,
- arg_get, gethook, fmt, ap);
+ return wrap_do_encode(buff, len, 0,
+ arg_get, gethook, fmt);
}
@@ -859,5 +872,4 @@
{
- va_list ap = (va_list)0;
- return do_encode(scsireq->databuf, scsireq->datalen, 0,
- arg_get, gethook, fmt, ap);
+ return wrap_do_encode(scsireq->databuf, scsireq->datalen, 0,
+ arg_get, gethook, fmt);
}

View file

@ -1,22 +0,0 @@
$NetBSD: patch-ad,v 1.2 2007/09/12 21:05:30 rillig Exp $
--- scsi.c.orig 2007-09-12 21:25:59.000000000 +0200
+++ scsi.c 2007-09-12 21:29:07.000000000 +0200
@@ -37,7 +37,7 @@
#include <ctype.h>
#include <string.h>
#include <sys/scsiio.h>
-#include <sys/errno.h>
+#include <errno.h>
#include <stdarg.h>
#include <fcntl.h>
@@ -1044,7 +1044,7 @@ static void sense_7x_dump(FILE *f, scsir
fprintf(f, "Illegal value in the %s.\n",
(bad_par ? "parameter list" : "command descriptor block"));
byte = ((s[16] << 8) | s[17]);
- value = bad_par ? (u_char)scsireq->databuf[byte] : (u_char)scsireq->cmd[byte];
+ value = ((u_char *)(bad_par ? scsireq->databuf : scsireq->cmd))[byte];
bit = s[15] & 0x7;
if (s[15] & 0x08)
fprintf(f, "Bit %d of byte %d (value %02x) is illegal.\n",