Add patch from KDE SVN to fix build with latest sip; patch found by

drochner. Make pkglint happier while here.
This commit is contained in:
wiz 2010-09-06 12:22:51 +00:00
parent a812b3184f
commit 7d6c514465
3 changed files with 74 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.16 2010/07/18 13:08:58 markd Exp $
# $NetBSD: Makefile,v 1.17 2010/09/06 12:22:51 wiz Exp $
PKGNAME= kdebindings4-python-${_KDE_VERSION}
DISTNAME= kdebindings-${_KDE_VERSION}
@ -10,7 +10,7 @@ COMMENT= Python bindings for the KDE integrated X11 desktop
# BUILD_MAKE_FLAGS+= VERBOSE=1
CMAKE_ARGS+= -DBUILD_smoke=OFF -DBUILD_ruby=OFF -DBUILD_php=OFF
CMAKE_ARGS+= -DBUILD_smoke=OFF -DBUILD_ruby=OFF -DBUILD_php=OFF
CMAKE_ARGS+= -DBUILD_java=OFF -DBUILD_falcon=OFF -DBUILD_csharp=OFF
CMAKE_ARGS+= -DENABLE_SMOKE=off
CMAKE_ARGS+= -DENABLE_QYOTO=off
@ -31,8 +31,10 @@ REPLACE_PYTHON+= \
post-extract:
${CP} ${FILESDIR}/FindPolkitQt.cmake ${WRKSRC}/cmake/modules
# patched by pkgsrc; remove them, otherwise they get installed
post-patch:
rm ${WRKSRC}/python/pykde4/sip/akonadi/addressattribute.sip.orig
rm ${WRKSRC}/python/pykde4/sip/kdecore/typedefs.sip.orig
.include "../../meta-pkgs/kde4/kde4.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.12 2010/07/18 13:08:58 markd Exp $
$NetBSD: distinfo,v 1.13 2010/09/06 12:22:51 wiz Exp $
SHA1 (kdebindings-4.4.5.tar.bz2) = 2f041c5b050da879e8f5d09f668b56881f9f1bb2
RMD160 (kdebindings-4.4.5.tar.bz2) = 057cafc1922a5ab3999e6dcc532d656dd4cf446c
@ -7,3 +7,4 @@ SHA1 (patch-aa) = f01b1d350a8e79e639f46c797baf035684275158
SHA1 (patch-ab) = cae51d216ad914009b4e9c80a17a172ec5a5eaec
SHA1 (patch-ac) = 698eaecc5cb2489b16409bc14c4beee5ca93a296
SHA1 (patch-ad) = 1f0170c454dd5eecf7433b937667ad200e1bd3a8
SHA1 (patch-am) = 21146fef7852f5316b606195686163372fc3a35e

View file

@ -0,0 +1,68 @@
$NetBSD: patch-am,v 1.1 2010/09/06 12:22:51 wiz Exp $
http://websvn.kde.org/?view=revision&revision=1170602
--- python/pykde4/sip/kdecore/typedefs.sip.orig 2010-01-19 23:24:08.000000000 +0000
+++ python/pykde4/sip/kdecore/typedefs.sip
@@ -733,61 +733,6 @@ template <TYPE1,TYPE2>
};
-%MappedType QList<uint>
-{
-%TypeHeaderCode
-#include <qlist.h>
-%End
-
-%ConvertFromTypeCode
- // Create the list.
- PyObject *l;
-
- if ((l = PyList_New(sipCpp->size())) == NULL)
- return NULL;
-
- // Set the list elements.
- for (int i = 0; i < sipCpp->size(); ++i) {
- PyObject *pobj;
-
-#if PY_MAJOR_VERSION >= 3
- if ((pobj = PyLong_FromLong(sipCpp->value(i))) == NULL) {
-#else
- if ((pobj = PyInt_FromLong(sipCpp->value(i))) == NULL) {
-#endif
- Py_DECREF(l);
-
- return NULL;
- }
-
- PyList_SET_ITEM(l, i, pobj);
- }
-
- return l;
-%End
-
-%ConvertToTypeCode
- // Check the type if that is all that is required.
- if (sipIsErr == NULL)
- return PyList_Check(sipPy);
-
- QList<uint> *ql = new QList<uint>;
-
- for (int i = 0; i < PyList_GET_SIZE(sipPy); ++i) {
-#if PY_MAJOR_VERSION >= 3
- ql->append(PyLong_AsLong(PyList_GET_ITEM(sipPy, i)));
-#else
- ql->append(PyInt_AsLong(PyList_GET_ITEM(sipPy, i)));
-#endif
- }
-
- *sipCppPtr = ql;
-
- return sipGetState(sipTransferObj);
-%End
-};
-
-
template <TYPE*>
%MappedType QStack<TYPE*>
{