Initial import of libwildmidi-0.2.3.4, packaged for wip by Pierre Allegraud.
WildMIDI is a simple software midi player which has a core softsynth library that can be use with other applications. The WildMIDI library uses Gravis Ultrasound patch files to convert MIDI files into audio which is them passed back to the calling application for further processing or output. The API of the library is designed so that it is easy to include WildMIDI into applications that wish to include MIDI file playback. With multiple MIDI file support you can develope applications to mix several midi files together at the same time and with the next release you will be able to use a different patch set for each MIDI file.
This commit is contained in:
parent
2c0aaffb50
commit
7d74685487
8 changed files with 129 additions and 0 deletions
11
audio/libwildmidi/DESCR
Normal file
11
audio/libwildmidi/DESCR
Normal file
|
@ -0,0 +1,11 @@
|
|||
WildMIDI is a simple software midi player which has a core softsynth
|
||||
library that can be use with other applications.
|
||||
|
||||
The WildMIDI library uses Gravis Ultrasound patch files to convert
|
||||
MIDI files into audio which is them passed back to the calling
|
||||
application for further processing or output. The API of the library
|
||||
is designed so that it is easy to include WildMIDI into applications
|
||||
that wish to include MIDI file playback. With multiple MIDI file support
|
||||
you can develope applications to mix several midi files together at the
|
||||
same time and with the next release you will be able to use a different
|
||||
patch set for each MIDI file.
|
9
audio/libwildmidi/MESSAGE
Normal file
9
audio/libwildmidi/MESSAGE
Normal file
|
@ -0,0 +1,9 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2011/11/30 13:47:15 wiz Exp $
|
||||
|
||||
To use this program, you'll have to install one of the following:
|
||||
* pkgsrc/audio/eawpatches
|
||||
* pkgsrc/audio/freepats
|
||||
* pkgsrc/audio/guspatches
|
||||
|
||||
===========================================================================
|
25
audio/libwildmidi/Makefile
Normal file
25
audio/libwildmidi/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/11/30 13:47:15 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= wildmidi-0.2.3.4
|
||||
PKGNAME= ${DISTNAME:S/wildmidi/libwildmidi/}
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=wildmidi/}
|
||||
|
||||
MAINTAINER= pallegra@gmail.com
|
||||
HOMEPAGE= http://wildmidi.sourceforge.net/
|
||||
COMMENT= Midi processing library and a midi player using the GUS patch set
|
||||
LICENSE= gnu-lgpl-v3
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_TOOLS+= gmake
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
CONFIGURE_ARGS+= --with-wildmidi-cfg=${PKG_SYSCONFDIR}/timidity.cfg
|
||||
CONFIGURE_ARGS+= --disable-werror
|
||||
CONFIGURE_ARGS+= --with-oss
|
||||
|
||||
.include "../../mk/oss.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
17
audio/libwildmidi/PLIST
Normal file
17
audio/libwildmidi/PLIST
Normal file
|
@ -0,0 +1,17 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/11/30 13:47:15 wiz Exp $
|
||||
bin/wildmidi
|
||||
include/wildmidi_lib.h
|
||||
lib/libWildMidi.la
|
||||
man/man1/wildmidi.1
|
||||
man/man3/WildMidi_Close.3
|
||||
man/man3/WildMidi_FastSeek.3
|
||||
man/man3/WildMidi_GetInfo.3
|
||||
man/man3/WildMidi_GetOutput.3
|
||||
man/man3/WildMidi_GetString.3
|
||||
man/man3/WildMidi_Init.3
|
||||
man/man3/WildMidi_MasterVolume.3
|
||||
man/man3/WildMidi_Open.3
|
||||
man/man3/WildMidi_OpenBuffer.3
|
||||
man/man3/WildMidi_SetOption.3
|
||||
man/man3/WildMidi_Shutdown.3
|
||||
man/man5/wildmidi.cfg.5
|
12
audio/libwildmidi/buildlink3.mk
Normal file
12
audio/libwildmidi/buildlink3.mk
Normal file
|
@ -0,0 +1,12 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2011/11/30 13:47:15 wiz Exp $
|
||||
|
||||
BUILDLINK_TREE+= libwildmidi
|
||||
|
||||
.if !defined(LIBWILDMIDI_BUILDLINK3_MK)
|
||||
LIBWILDMIDI_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.libwildmidi+= libwildmidi>=0.2.3.4
|
||||
BUILDLINK_PKGSRCDIR.libwildmidi?= ../../audio/libwildmidi
|
||||
.endif # LIBWILDMIDI_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -libwildmidi
|
7
audio/libwildmidi/distinfo
Normal file
7
audio/libwildmidi/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/11/30 13:47:15 wiz Exp $
|
||||
|
||||
SHA1 (wildmidi-0.2.3.4.tar.gz) = 99ffeb54980a29c5aa44f4cb152ad37acbe877bc
|
||||
RMD160 (wildmidi-0.2.3.4.tar.gz) = 50b4102f0b305ca0afd7649957a3a94343dbf2d6
|
||||
Size (wildmidi-0.2.3.4.tar.gz) = 348971 bytes
|
||||
SHA1 (patch-src_Makefile.in) = c04041123a882bda5b0029f70e69fda17b381638
|
||||
SHA1 (patch-src_wildmidi.c) = 572136a5476461db9be6f89a0523e812feeb39b7
|
15
audio/libwildmidi/patches/patch-src_Makefile.in
Normal file
15
audio/libwildmidi/patches/patch-src_Makefile.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_Makefile.in,v 1.1.1.1 2011/11/30 13:47:16 wiz Exp $
|
||||
|
||||
Link against libossaudio where necessary.
|
||||
|
||||
--- src/Makefile.in.orig 2010-07-30 04:36:20.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -227,7 +227,7 @@ libWildMidi_la_LDFLAGS = -version-info $
|
||||
libWildMidi_la_LIBADD = -lm -lc
|
||||
wildmidi_libs = ./libWildMidi.la
|
||||
wildmidi_SOURCES = wildmidi.c
|
||||
-wildmidi_LDADD = $(AUDDR) $(LDFLAGS) -L./ -lWildMidi
|
||||
+wildmidi_LDADD = $(AUDDR) $(LDFLAGS) -L./ -lWildMidi $(LIBOSSAUDIO)
|
||||
wildmidi_DEPENDENCIES = ./libWildMidi.la
|
||||
all: all-am
|
||||
|
33
audio/libwildmidi/patches/patch-src_wildmidi.c
Normal file
33
audio/libwildmidi/patches/patch-src_wildmidi.c
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-src_wildmidi.c,v 1.1.1.1 2011/11/30 13:47:16 wiz Exp $
|
||||
|
||||
On NetBSD, FNONBLOCK is only defined for the kernel.
|
||||
Fix device name in printf.
|
||||
|
||||
--- src/wildmidi.c.orig 2010-07-30 00:33:46.000000000 +0000
|
||||
+++ src/wildmidi.c
|
||||
@@ -63,7 +63,11 @@
|
||||
#include "wildmidi_lib.h"
|
||||
|
||||
#ifndef FNONBLOCK
|
||||
+#ifdef _FNONBLOCK
|
||||
#define FNONBLOCK _FNONBLOCK
|
||||
+#else
|
||||
+#define FNONBLOCK O_NONBLOCK
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
|
||||
@@ -573,11 +577,11 @@ open_oss_output( void ) {
|
||||
}
|
||||
|
||||
if ((audio_fd = open(pcmname, omode)) < 0) {
|
||||
- printf("ERROR: Unable to open /dev/dsp (%s)\r\n",strerror(errno));
|
||||
+ printf("ERROR: Unable to open %s (%s)\r\n",pcmname, strerror(errno));
|
||||
return -1;
|
||||
}
|
||||
if (ioctl (audio_fd, SNDCTL_DSP_RESET, 0) < 0) {
|
||||
- printf("ERROR: Unable to reset /dev/dsp\r\n");
|
||||
+ printf("ERROR: Unable to reset %s\r\n, pcmname");
|
||||
shutdown_output();
|
||||
return -1;
|
||||
}
|
Loading…
Reference in a new issue