Fix build with readline-7.0 and depend on it.
Bump PKGREVISION.
This commit is contained in:
parent
7f812039da
commit
7db779618b
4 changed files with 21 additions and 6 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.107 2016/08/23 20:03:48 asau Exp $
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.108 2016/09/20 14:10:25 wiz Exp $
|
||||
|
||||
DISTNAME= clisp-2.49
|
||||
PKGREVISION= 21
|
||||
PKGREVISION= 22
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=clisp/}
|
||||
#EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -68,5 +67,4 @@ post-extract:
|
|||
.include "../../devel/glib2/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.libsigsegv+= libsigsegv>=2.4
|
||||
.include "../../devel/libsigsegv/buildlink3.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.33 2016/01/30 00:38:15 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.34 2016/09/20 14:10:25 wiz Exp $
|
||||
|
||||
SHA1 (clisp-2.49.tar.gz) = 1743e7917013162400c955af441e991db43b3323
|
||||
RMD160 (clisp-2.49.tar.gz) = ae30f3b681cb023e885c6e4ed12210ee5ba14c76
|
||||
|
@ -7,6 +7,7 @@ Size (clisp-2.49.tar.gz) = 9823111 bytes
|
|||
SHA1 (patch-aa) = aa7e25685ed5818f45b550eba0011683dc36bc90
|
||||
SHA1 (patch-ab) = 93aef2c423ce9e5eabebc20cdc144c83845b19cb
|
||||
SHA1 (patch-ac) = c31fcd65d7d37aeaf69c0eee9499bff596b6619b
|
||||
SHA1 (patch-modules_readline_readline.lisp) = fe4752fde4524cf91975373accad55fa8680a170
|
||||
SHA1 (patch-src_configure) = 861681456cb768b7f308aa88e77f1cee1edb2090
|
||||
SHA1 (patch-src_lispbibl.d) = 68eeac6def2d22ffb214fd8be3870d5c654f10bc
|
||||
SHA1 (patch-src_stream.d) = 28bde27e99277d9df24028534c3b46e2099c460c
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.11 2013/10/15 16:21:46 asau Exp $
|
||||
# $NetBSD: options.mk,v 1.12 2016/09/20 14:10:25 wiz Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.clisp
|
||||
|
||||
|
@ -42,6 +42,7 @@ CONFIGURE_ARGS+= --with-dynamic-ffi
|
|||
|
||||
.if !empty(PKG_OPTIONS:Mreadline)
|
||||
CONFIGURE_ARGS+= --with-readline
|
||||
BUILDLINK_API_DEPENDS.readline+= readline>=7.0
|
||||
.include "../../devel/readline/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
|
|
15
lang/clisp/patches/patch-modules_readline_readline.lisp
Normal file
15
lang/clisp/patches/patch-modules_readline_readline.lisp
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-modules_readline_readline.lisp,v 1.1 2016/09/20 14:10:25 wiz Exp $
|
||||
|
||||
rl_readline_state changed from int to unsigned long in readline-7.0.
|
||||
|
||||
--- modules/readline/readline.lisp.orig 2010-01-06 22:18:03.000000000 +0000
|
||||
+++ modules/readline/readline.lisp
|
||||
@@ -424,7 +424,7 @@ name in ~/.inputrc. This is preferred wa
|
||||
"The version of this incarnation of the readline library, e.g., 0x0402."))
|
||||
(def-c-var gnu-readline-p (:name "rl_gnu_readline_p") (:type int)
|
||||
(:documentation "True if this is real GNU readline."))
|
||||
-(def-c-var readline-state (:name "rl_readline_state") (:type int)
|
||||
+(def-c-var readline-state (:name "rl_readline_state") (:type ulong)
|
||||
(:documentation "Flags word encapsulating the current readline state."))
|
||||
(def-c-var editing-mode (:name "rl_editing_mode") (:type int)
|
||||
(:documentation "Says which editing mode readline is currently using.
|
Loading…
Reference in a new issue