Patch udfclient so it will compile again under NetBSD-current wich has
changed scsipi headers and incorporating the submitted patches. It also gives Linux SCSI access to the SCSI sense code! Esp. Linux users and NetBSD-current users will benefit.
This commit is contained in:
parent
35d4b611e2
commit
7def1e6158
4 changed files with 6 additions and 34 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.4 2003/10/14 21:58:23 salo Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2003/10/27 03:22:52 reinoud Exp $
|
||||
#
|
||||
|
||||
DISTNAME= UDFclient.ro1-p1
|
||||
PKGNAME= udfclient-0.1.1
|
||||
DISTNAME= UDFclient.0.1p2
|
||||
PKGNAME= udfclient-0.1.2
|
||||
WRKSRC= ${WRKDIR}/UDFclient
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www.13thmonkey.org/udfclient/releases/
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2003/10/26 23:23:47 kristerw Exp $
|
||||
$NetBSD: distinfo,v 1.4 2003/10/27 03:22:52 reinoud Exp $
|
||||
|
||||
SHA1 (UDFclient.ro1-p1.tgz) = e00827defc37115e716ab8928422511fc430625c
|
||||
Size (UDFclient.ro1-p1.tgz) = 74914 bytes
|
||||
SHA1 (UDFclient.0.1p2.tgz) = b694f206da740650a41365b5cc248034040845f0
|
||||
Size (UDFclient.0.1p2.tgz) = 75080 bytes
|
||||
SHA1 (patch-aa) = 390ac9ff7ddd1a391729bf10272a762d7a4ff84b
|
||||
SHA1 (patch-ab) = 78a6d8b9b02656fb94d6fec56ba8b009e1c30b80
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2003/10/26 23:23:47 kristerw Exp $
|
||||
|
||||
--- udfclient.c.orig Mon Oct 27 00:09:21 2003
|
||||
+++ udfclient.c Mon Oct 27 00:09:45 2003
|
||||
@@ -609,7 +609,8 @@
|
||||
|
||||
int main(int argc, char *argv[]) {
|
||||
struct udf_discinfo *disc, *next_disc;
|
||||
- char *progname, *range, flag;
|
||||
+ int flag;
|
||||
+ char *progname, *range;
|
||||
|
||||
progname = argv[0];
|
||||
if (argc == 1) {
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2003/10/26 23:23:47 kristerw Exp $
|
||||
|
||||
--- udfdump.c.orig Mon Oct 27 00:06:46 2003
|
||||
+++ udfdump.c Mon Oct 27 00:07:20 2003
|
||||
@@ -118,7 +118,8 @@
|
||||
|
||||
int main(int argc, char *argv[]) {
|
||||
struct udf_discinfo *disc, *next_disc;
|
||||
- char flag, *progname, *range;
|
||||
+ char *progname, *range;
|
||||
+ int flag;
|
||||
int min_session_number, max_session_number;
|
||||
|
||||
progname = argv[0];
|
Loading…
Reference in a new issue