Initial import of tinycdb-0.75, a very fast and simple package for
creating and reading constant data bases, a data structure introduced by Dan J. Bernstein in his cdb package. It may be used to speed up searches in a sequence of (key,value) pairs with very big number of records. Example usage is indexing a big list of users - where a search will require linear reading of a large /etc/passwd file, and for many other tasks. It's usage/API is similar to ones found in BerkeleyDB, gdbm and traditional *nix dbm/ndbm libraries, and is compatible in great extent to cdb-0.75 package by Dan Bernstein. CDB is a constant database, that is, it cannot be updated at a runtime, only rebuilt. Rebuilding is atomic operation and is very fast - much faster than of many other similar packages. Once created, CDB may be queried, and a query takes very little time to complete.
This commit is contained in:
parent
5740ce8c75
commit
7df1d0fdb5
5 changed files with 74 additions and 0 deletions
14
databases/tinycdb/DESCR
Normal file
14
databases/tinycdb/DESCR
Normal file
|
@ -0,0 +1,14 @@
|
|||
TinyCDB is a very fast and simple package for creating and reading
|
||||
constant data bases, a data structure introduced by Dan J. Bernstein
|
||||
in his cdb package. It may be used to speed up searches in a sequence
|
||||
of (key,value) pairs with very big number of records. Example usage
|
||||
is indexing a big list of users - where a search will require linear
|
||||
reading of a large /etc/passwd file, and for many other tasks. It's
|
||||
usage/API is similar to ones found in BerkeleyDB, gdbm and traditional
|
||||
*nix dbm/ndbm libraries, and is compatible in great extent to
|
||||
cdb-0.75 package by Dan Bernstein.
|
||||
|
||||
CDB is a constant database, that is, it cannot be updated at a
|
||||
runtime, only rebuilt. Rebuilding is atomic operation and is very
|
||||
fast - much faster than of many other similar packages. Once created,
|
||||
CDB may be queried, and a query takes very little time to complete.
|
25
databases/tinycdb/Makefile
Normal file
25
databases/tinycdb/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2006/01/07 06:47:10 schmonz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tinycdb_0.75
|
||||
PKGNAME= ${DISTNAME:S/_/-/}
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.corpit.ru/mjt/tinycdb/
|
||||
|
||||
MAINTAINER= schmonz@NetBSD.org
|
||||
HOMEPAGE= http://www.corpit.ru/mjt/tinycdb.html
|
||||
COMMENT= Create and read constant databases
|
||||
|
||||
CONFLICTS+= cdb-[0-9]*
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
|
||||
|
||||
SUBST_CLASSES+= paths
|
||||
SUBST_STAGE.paths= do-configure
|
||||
SUBST_FILES.paths= Makefile
|
||||
SUBST_SED.paths= -e 's|@PREFIX@|${PREFIX}|g'
|
||||
SUBST_SED.paths+= -e 's|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g'
|
||||
SUBST_SED.paths+= -e 's|@PKGMANDIR@|${PKGMANDIR}|g'
|
||||
SUBST_MESSAGE.paths= "Configuring pkgsrc paths."
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
7
databases/tinycdb/PLIST
Normal file
7
databases/tinycdb/PLIST
Normal file
|
@ -0,0 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2006/01/07 06:47:10 schmonz Exp $
|
||||
bin/cdb
|
||||
include/cdb.h
|
||||
lib/libcdb.a
|
||||
man/man1/cdb.1
|
||||
man/man3/cdb.3
|
||||
man/man5/cdb.5
|
6
databases/tinycdb/distinfo
Normal file
6
databases/tinycdb/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2006/01/07 06:47:10 schmonz Exp $
|
||||
|
||||
SHA1 (tinycdb_0.75.tar.gz) = 8aa11210f1a3fc697a361b5a8223b37fcb084d29
|
||||
RMD160 (tinycdb_0.75.tar.gz) = 3d0eba569aea5acd02f7107391262ce6e26b4f1c
|
||||
Size (tinycdb_0.75.tar.gz) = 32025 bytes
|
||||
SHA1 (patch-aa) = 9d0a87b1caa439764311f1c1cec83ce6c8bf2bda
|
22
databases/tinycdb/patches/patch-aa
Normal file
22
databases/tinycdb/patches/patch-aa
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2006/01/07 06:47:10 schmonz Exp $
|
||||
|
||||
--- Makefile.orig 2005-08-23 12:22:03.000000000 -0400
|
||||
+++ Makefile
|
||||
@@ -6,14 +6,14 @@
|
||||
|
||||
VERSION = 0.75
|
||||
|
||||
-prefix=/usr/local
|
||||
+prefix=@PREFIX@
|
||||
exec_prefix=$(prefix)
|
||||
bindir=$(exec_prefix)/bin
|
||||
libdir=$(exec_prefix)/lib
|
||||
syslibdir=$(libdir)
|
||||
-sysconfdir=/etc
|
||||
+sysconfdir=@PKG_SYSCONFDIR@
|
||||
includedir=$(prefix)/include
|
||||
-mandir=$(prefix)/man
|
||||
+mandir=$(prefix)/@PKGMANDIR@
|
||||
DESTDIR=
|
||||
|
||||
CC = cc
|
Loading…
Reference in a new issue