This commit is contained in:
joerg 2015-04-25 00:56:03 +00:00
parent 599963b2de
commit 7df63c13e6
4 changed files with 63 additions and 1 deletions

View file

@ -1,6 +1,9 @@
$NetBSD: distinfo,v 1.8 2015/04/19 19:30:12 wiz Exp $
$NetBSD: distinfo,v 1.9 2015/04/25 00:56:03 joerg Exp $
SHA1 (exult-1.4.9rc1.tar.gz) = 259f778d6b8b5e9c9466e2f4967b6352435b6792
RMD160 (exult-1.4.9rc1.tar.gz) = 8c6fce2bc17ff59709c5827c5dd70f2e2a473914
Size (exult-1.4.9rc1.tar.gz) = 5452640 bytes
SHA1 (patch-configure) = 0812526182ffa1746c45fd5a005ca8b10fd50093
SHA1 (patch-imagewin_manip.h) = 1d79feccbd17633a5053197ebbf1c98a6e9d4de3
SHA1 (patch-istring.h) = c6c236714e03c4da64afac79a4707e02d8d140cc
SHA1 (patch-usecode_compiler_ucstmt.cc) = ca404dcb3e5ba8f318c35fa95b7fb6b31a7f5fe9

View file

@ -0,0 +1,15 @@
$NetBSD: patch-imagewin_manip.h,v 1.1 2015/04/25 00:56:04 joerg Exp $
Reference to member of base class must be explicit.
--- imagewin/manip.h.orig 2015-04-25 00:01:37.000000000 +0000
+++ imagewin/manip.h
@@ -319,7 +319,7 @@ public:
static uintD copy(uintS src)
{
unsigned int r, g, b;
- split_source(src,r,g,b);
+ ManipBaseSrc<color_s,color_d>::split_source(src,r,g,b);
return ManipBaseDest<color_d>::rgb(r,g,b);
}
static void copy(uintD& dest, uintS src)

View file

@ -0,0 +1,29 @@
$NetBSD: patch-istring.h,v 1.1 2015/04/25 00:56:04 joerg Exp $
append does not depend on the template, so make reference explicit.
--- istring.h.orig 2015-04-24 23:56:35.000000000 +0000
+++ istring.h
@@ -162,19 +162,19 @@ public:
_Myt& operator+=(const _Myt& _Right)
{ // append _Right
- append(_Right);
+ this->append(_Right);
return (*this);
}
_Myt& operator+=(const _Elem *_Ptr)
{ // append [_Ptr, <null>)
- append(_Ptr);
+ this->append(_Ptr);
return (*this);
}
_Myt& operator+=(_Elem _Ch)
{ // append 1 * _Ch
- append(static_cast<size_type>(1), _Ch);
+ this->append(static_cast<size_type>(1), _Ch);
return (*this);
}

View file

@ -0,0 +1,15 @@
$NetBSD: patch-usecode_compiler_ucstmt.cc,v 1.1 2015/04/25 00:56:04 joerg Exp $
Key function must not be inline, otherwise the vtable is not created.
--- usecode/compiler/ucstmt.cc.orig 2015-04-25 00:38:04.000000000 +0000
+++ usecode/compiler/ucstmt.cc
@@ -808,7 +808,7 @@ void Uc_converse_statement::gen
* Delete.
*/
-inline Uc_switch_expression_case_statement::~Uc_switch_expression_case_statement
+Uc_switch_expression_case_statement::~Uc_switch_expression_case_statement
(
)
{