DESTDIR support
This commit is contained in:
parent
4bd4aa14ac
commit
7e0ad6ab1c
6 changed files with 45 additions and 16 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.3 2010/01/17 12:02:13 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2010/01/30 19:10:25 joerg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= lwt-1.1.0
|
||||
|
@ -11,6 +11,8 @@ MAINTAINER= jaapb@kerguelen.org
|
|||
HOMEPAGE= http://www.ocsigen.org/
|
||||
COMMENT= Cooperative threading library for OCaml
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
MAKE_JOBS_SAFE= no
|
||||
|
||||
DEPENDS+= ocaml-findlib-[0-9]*:../../devel/ocaml-findlib
|
||||
|
@ -29,9 +31,10 @@ PLIST_SRC+= PLIST.opt
|
|||
BUILD_TARGET+= doc
|
||||
PLIST_SRC+= PLIST
|
||||
|
||||
INSTALLATION_DIRS+= share/doc/ocaml-lwt
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/${PKGBASE}
|
||||
${INSTALL_DATA} ${WRKSRC}/_build/lwt.docdir/* ${PREFIX}/share/doc/${PKGBASE}
|
||||
${INSTALL_DATA} ${WRKSRC}/_build/lwt.docdir/* ${DESTDIR}${PREFIX}/share/doc/ocaml-lwt
|
||||
|
||||
.include "../../security/ocaml-ssl/buildlink3.mk"
|
||||
.include "../../lang/ocaml/buildlink3.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/09/02 11:19:35 obache Exp $
|
||||
$NetBSD: distinfo,v 1.2 2010/01/30 19:10:25 joerg Exp $
|
||||
|
||||
SHA1 (lwt-1.1.0.tar.gz) = 838d99ce53accb4d0a393c4dd0f757d130a6bc2c
|
||||
RMD160 (lwt-1.1.0.tar.gz) = e7359a29af3c91ac006dfb3fc1150264aa27927b
|
||||
Size (lwt-1.1.0.tar.gz) = 32844 bytes
|
||||
SHA1 (patch-aa) = 84e614fd2734309a4dc83fbda25a5cad175a3e0b
|
||||
SHA1 (patch-aa) = 69047b997d80e4d2177f62c581f19c4365326319
|
||||
|
|
|
@ -1,8 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2008/09/02 11:19:35 obache Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2010/01/30 19:10:25 joerg Exp $
|
||||
|
||||
--- Makefile.orig 2008-07-07 11:24:41.000000000 +0200
|
||||
+++ Makefile 2008-07-07 11:24:56.000000000 +0200
|
||||
@@ -36,13 +36,13 @@
|
||||
--- Makefile.orig 2008-06-25 15:23:14.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
OCAMLFIND := ocamlfind
|
||||
OCAMLBUILD := ocamlbuild
|
||||
-DESTDIR := $(shell $(OCAMLFIND) printconf destdir)/$(NAME)
|
||||
+INSTALLDIR := ${DESTDIR}$(shell $(OCAMLFIND) printconf destdir)/$(NAME)
|
||||
|
||||
NAME := lwt
|
||||
VERSION := $(shell head -n 1 VERSION)
|
||||
@@ -36,13 +36,13 @@ TOINSTALL = $(wildcard $(ARCHIVES_BYTE)
|
||||
all: META byte opt doc
|
||||
|
||||
byte:
|
||||
|
@ -18,3 +27,18 @@ $NetBSD: patch-aa,v 1.1.1.1 2008/09/02 11:19:35 obache Exp $
|
|||
|
||||
examples:
|
||||
$(MAKE) -C examples
|
||||
@@ -54,11 +54,11 @@ dist:
|
||||
DARCS_REPO=$(PWD) darcs dist -d $(NAME)-$(VERSION)
|
||||
|
||||
install:
|
||||
- mkdir -p "$(DESTDIR)"
|
||||
- $(OCAMLFIND) install $(NAME) -destdir "$(DESTDIR)" META $(TOINSTALL)
|
||||
+ mkdir -p "$(INSTALLDIR)"
|
||||
+ $(OCAMLFIND) install $(NAME) -destdir "$(INSTALLDIR)" META $(TOINSTALL)
|
||||
|
||||
uninstall:
|
||||
- $(OCAMLFIND) remove $(NAME) -destdir "$(DESTDIR)"
|
||||
+ $(OCAMLFIND) remove $(NAME) -destdir "$(INSTALLDIR)"
|
||||
|
||||
clean:
|
||||
$(OCAMLBUILD) -clean
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.7 2008/08/31 13:20:34 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2010/01/30 19:16:09 joerg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pcre-ocaml-5.15.0
|
||||
|
@ -10,6 +10,8 @@ MAINTAINER= pkgsrc-users@NetBSD.org
|
|||
HOMEPAGE= http://www.ocaml.info/ocaml_sources/
|
||||
COMMENT= Perl compatible regular expressions for OCaml
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
DEPENDS+= ocaml-findlib-[0-9]*:../../devel/ocaml-findlib
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
@ -23,10 +25,10 @@ BUILD_TARGET= byte
|
|||
.endif
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/pcre-ocaml
|
||||
INSTALLATION_DIRS= ${EGDIR}
|
||||
INSTALLATION_DIRS= ${EGDIR} lib/ocaml/site-lib/pcre
|
||||
|
||||
post-install:
|
||||
cd ${WRKSRC}/examples && pax -rw -pm . ${EGDIR}
|
||||
cd ${WRKSRC}/examples && pax -rw -pm . ${DESTDIR}${EGDIR}
|
||||
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
.include "../../lang/ocaml/buildlink3.mk"
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.4 2008/08/31 13:20:34 obache Exp $
|
||||
$NetBSD: distinfo,v 1.5 2010/01/30 19:16:09 joerg Exp $
|
||||
|
||||
SHA1 (pcre-ocaml-5.15.0.tar.bz2) = b7fb293867cf2c7d7deddc29e6a445359b0f7604
|
||||
RMD160 (pcre-ocaml-5.15.0.tar.bz2) = b2a515f2120e2e6a25f03ee15d60fe766621f5a9
|
||||
Size (pcre-ocaml-5.15.0.tar.bz2) = 51120 bytes
|
||||
SHA1 (patch-aa) = ff7aaec3c2fb06b1c9ab410257b64c8d5d29dcf6
|
||||
SHA1 (patch-ab) = 1a4de1d021cc9ebafdab8f470750fe097d80905e
|
||||
SHA1 (patch-ab) = 95a3929612ebd5e81a1ab64b8bfbad9b63e9a330
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-ab,v 1.1 2007/06/09 11:05:00 rillig Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2010/01/30 19:16:10 joerg Exp $
|
||||
|
||||
--- lib/Makefile.orig 2007-03-21 11:30:21.000000000 +0100
|
||||
+++ lib/Makefile 2007-03-21 11:30:33.000000000 +0100
|
||||
@@ -1,4 +1,5 @@
|
||||
OCAMLMAKEFILE = ../OCamlMakefile
|
||||
+OCAMLFIND_INSTFLAGS = -optional
|
||||
+OCAMLFIND_INSTFLAGS = -optional -destdir ${DESTDIR}`$(OCAMLC) -where `/site-lib
|
||||
|
||||
SOURCES = pcre.mli pcre.ml pcre_stubs.c
|
||||
CFLAGS = -O2
|
||||
|
|
Loading…
Reference in a new issue