Use d_namlen as boundary for d_name, the printf still doesn't make much

sense, but who cares?
This commit is contained in:
joerg 2006-01-09 22:14:32 +00:00
parent 8756625bb7
commit 7e3773a31a
2 changed files with 15 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2005/02/24 09:03:06 agc Exp $
$NetBSD: distinfo,v 1.3 2006/01/09 22:14:32 joerg Exp $
SHA1 (focal.tar.gz) = 704d1411365085fb47ff25c1a77ae1f8e7fa601e
RMD160 (focal.tar.gz) = 6b06cc08b2761035c315ae13b80d64a5e7a6004b
Size (focal.tar.gz) = 12561 bytes
SHA1 (patch-aa) = f37f7271b0a7fe508bee1bf1630229096efb21d0
SHA1 (patch-ab) = f42b9f219bfee5a0deaae5d030989a6bc4ae2e77

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2006/01/09 22:14:32 joerg Exp $
--- focal2.c.orig 2006-01-09 22:06:20.000000000 +0000
+++ focal2.c
@@ -138,7 +138,7 @@ void library()
|| strcmp(de->d_name, ".") == 0
|| strcmp(de->d_name, "..") == 0)
continue;
- printf("%.*s\n", de->d_reclen, de->d_name);
+ printf("%.*s\n", de->d_namlen, de->d_name);
}
closedir(dp);
#else