Import brasero version 2.26.0.

Brasero is an application to burn CDs and DVDs for the GNOME desktop. It is
designed to be as simple as possible and has some unique features to enable
users to create their discs easily and quickly.
This commit is contained in:
jmcneill 2009-03-16 10:49:06 +00:00
parent cf166f8df9
commit 7e5851504d
8 changed files with 702 additions and 0 deletions

3
sysutils/brasero/DESCR Normal file
View file

@ -0,0 +1,3 @@
Brasero is an application to burn CDs and DVDs for the GNOME desktop. It is
designed to be as simple as possible and has some unique features to enable
users to create their discs easily and quickly.

57
sysutils/brasero/Makefile Normal file
View file

@ -0,0 +1,57 @@
# $NetBSD: Makefile,v 1.1.1.1 2009/03/16 10:49:06 jmcneill Exp $
#
DISTNAME= brasero-2.26.0
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/brasero/2.26/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://projects.gnome.org/brasero/
COMMENT= Disc-burning software for the GNOME desktop
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
CONFIGURE_ENV+= GCONF_SCHEMA_FILE_DIR=${PREFIX}/share/gconf/schemas/
MAKE_ENV+= GCONF_SCHEMA_FILE_DIR=${PREFIX}/share/gconf/schemas/
USE_LIBTOOL= yes
USE_TOOLS+= pkg-config gmake intltool autoconf automake gawk
USE_DIRS+= gnome2-1.6
CONFIGURE_ARGS+= --disable-inotify
GCONF_SCHEMAS+= brasero.schemas
PKGCONFIG_OVERRIDE+= libbrasero-media.pc.in
post-extract:
cp ${FILESDIR}/scsi-netbsd.c ${WRKSRC}/libbrasero-media/
# The gettext version in pkgsrc cannot handle the .po files, so
# we strip out usage of the newer features (context and fuzzy matches)
post-patch:
for f in ${WRKSRC}/po/*.po; do \
mv $$f $$f.original ; \
${AWK} -f ${FILESDIR}/msgfmtstrip $$f.original > $$f ; \
done
pre-configure:
cd ${WRKSRC} && automake && autoconf
.include "../../databases/shared-mime-info/mimedb.mk"
.include "../../devel/GConf/schemas.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
BUILDLINK_API_DEPENDS.gst-plugins0.10-base+= gst-plugins0.10-base>=0.10.10
.include "../../multimedia/gst-plugins0.10-base/buildlink3.mk"
BUILDLINK_API_DEPENDS.gstreamer0.10+= gstreamer0.10>=0.10.15
.include "../../multimedia/gstreamer0.10/buildlink3.mk"
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../sysutils/dbus-glib/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../sysutils/hal/buildlink3.mk"
.include "../../sysutils/libnotify/buildlink3.mk"
.include "../../sysutils/nautilus/buildlink3.mk"
.include "../../textproc/gnome-doc-utils/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/omf-scrollkeeper.mk"
.include "../../mk/bsd.pkg.mk"

370
sysutils/brasero/PLIST Normal file
View file

@ -0,0 +1,370 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2009/03/16 10:49:06 jmcneill Exp $
bin/brasero
include/brasero/brasero-drive-selection.h
include/brasero/brasero-drive.h
include/brasero/brasero-media.h
include/brasero/brasero-medium-monitor.h
include/brasero/brasero-medium-selection.h
include/brasero/brasero-medium.h
include/brasero/brasero-units.h
include/brasero/brasero-volume.h
lib/brasero/plugins/libbrasero-burn-uri.la
lib/brasero/plugins/libbrasero-cdrdao.la
lib/brasero/plugins/libbrasero-cdrecord.la
lib/brasero/plugins/libbrasero-checksum-file.la
lib/brasero/plugins/libbrasero-checksum.la
lib/brasero/plugins/libbrasero-dvdauthor.la
lib/brasero/plugins/libbrasero-dvdcss.la
lib/brasero/plugins/libbrasero-dvdrwformat.la
lib/brasero/plugins/libbrasero-genisoimage.la
lib/brasero/plugins/libbrasero-growisofs.la
lib/brasero/plugins/libbrasero-local-track.la
lib/brasero/plugins/libbrasero-mkisofs.la
lib/brasero/plugins/libbrasero-normalize.la
lib/brasero/plugins/libbrasero-readcd.la
lib/brasero/plugins/libbrasero-readom.la
lib/brasero/plugins/libbrasero-toc2cue.la
lib/brasero/plugins/libbrasero-transcode.la
lib/brasero/plugins/libbrasero-vcdimager.la
lib/brasero/plugins/libbrasero-vob.la
lib/brasero/plugins/libbrasero-wodim.la
lib/libbrasero-media.la
lib/nautilus/extensions-2.0/libnautilus-brasero-extension.la
lib/pkgconfig/libbrasero-media.pc
man/man1/brasero.1
share/applications/brasero-copy-medium.desktop
share/applications/brasero-nautilus.desktop
share/applications/brasero-open-image.desktop
share/applications/brasero-open-playlist.desktop
share/applications/brasero-open-project.desktop
share/applications/brasero.desktop
share/brasero/icons/hicolor/16x16/actions/insert-pause.png
share/brasero/icons/hicolor/16x16/actions/iso-image-burn.png
share/brasero/icons/hicolor/16x16/actions/iso-image-new.png
share/brasero/icons/hicolor/16x16/actions/media-optical-audio-new.png
share/brasero/icons/hicolor/16x16/actions/media-optical-blank.png
share/brasero/icons/hicolor/16x16/actions/media-optical-burn.png
share/brasero/icons/hicolor/16x16/actions/media-optical-copy.png
share/brasero/icons/hicolor/16x16/actions/media-optical-data-new.png
share/brasero/icons/hicolor/16x16/actions/media-optical-video-new.png
share/brasero/icons/hicolor/16x16/actions/transform-crop-and-resize.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-00.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-05.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-10.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-100.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-15.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-20.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-25.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-30.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-35.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-40.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-45.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-50.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-55.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-60.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-65.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-70.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-75.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-80.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-85.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-90.png
share/brasero/icons/hicolor/16x16/status/brasero-disc-95.png
share/brasero/icons/hicolor/22x22/actions/insert-pause.png
share/brasero/icons/hicolor/22x22/actions/iso-image-burn.png
share/brasero/icons/hicolor/22x22/actions/iso-image-new.png
share/brasero/icons/hicolor/22x22/actions/media-optical-audio-new.png
share/brasero/icons/hicolor/22x22/actions/media-optical-blank.png
share/brasero/icons/hicolor/22x22/actions/media-optical-burn.png
share/brasero/icons/hicolor/22x22/actions/media-optical-copy.png
share/brasero/icons/hicolor/22x22/actions/media-optical-data-new.png
share/brasero/icons/hicolor/22x22/actions/media-optical-video-new.png
share/brasero/icons/hicolor/22x22/actions/transform-crop-and-resize.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-00.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-05.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-10.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-100.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-15.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-20.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-25.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-30.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-35.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-40.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-45.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-50.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-55.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-60.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-65.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-70.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-75.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-80.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-85.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-90.png
share/brasero/icons/hicolor/22x22/status/brasero-disc-95.png
share/brasero/icons/hicolor/24x24/actions/insert-pause.png
share/brasero/icons/hicolor/24x24/actions/iso-image-burn.png
share/brasero/icons/hicolor/24x24/actions/iso-image-new.png
share/brasero/icons/hicolor/24x24/actions/media-optical-audio-new.png
share/brasero/icons/hicolor/24x24/actions/media-optical-blank.png
share/brasero/icons/hicolor/24x24/actions/media-optical-burn.png
share/brasero/icons/hicolor/24x24/actions/media-optical-copy.png
share/brasero/icons/hicolor/24x24/actions/media-optical-data-new.png
share/brasero/icons/hicolor/24x24/actions/media-optical-video-new.png
share/brasero/icons/hicolor/24x24/actions/transform-crop-and-resize.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-00.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-05.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-10.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-100.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-15.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-20.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-25.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-30.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-35.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-40.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-45.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-50.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-55.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-60.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-65.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-70.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-75.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-80.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-85.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-90.png
share/brasero/icons/hicolor/24x24/status/brasero-disc-95.png
share/brasero/icons/hicolor/32x32/actions/insert-pause.png
share/brasero/icons/hicolor/32x32/actions/iso-image-burn.png
share/brasero/icons/hicolor/32x32/actions/iso-image-new.png
share/brasero/icons/hicolor/32x32/actions/media-optical-audio-new.png
share/brasero/icons/hicolor/32x32/actions/media-optical-blank.png
share/brasero/icons/hicolor/32x32/actions/media-optical-burn.png
share/brasero/icons/hicolor/32x32/actions/media-optical-copy.png
share/brasero/icons/hicolor/32x32/actions/media-optical-data-new.png
share/brasero/icons/hicolor/32x32/actions/media-optical-video-new.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-00.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-05.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-10.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-100.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-15.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-20.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-25.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-30.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-35.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-40.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-45.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-50.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-55.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-60.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-65.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-70.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-75.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-80.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-85.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-90.png
share/brasero/icons/hicolor/32x32/status/brasero-disc-95.png
share/brasero/icons/hicolor/48x48/actions/media-optical-video-new.png
share/brasero/icons/hicolor/scalable/actions/insert-pause.svg
share/brasero/icons/hicolor/scalable/actions/iso-image-burn.svg
share/brasero/icons/hicolor/scalable/actions/iso-image-new.svg
share/brasero/icons/hicolor/scalable/actions/media-optical-audio-new.svg
share/brasero/icons/hicolor/scalable/actions/media-optical-blank.svg
share/brasero/icons/hicolor/scalable/actions/media-optical-burn.svg
share/brasero/icons/hicolor/scalable/actions/media-optical-copy.svg
share/brasero/icons/hicolor/scalable/actions/media-optical-data-new.svg
share/brasero/icons/hicolor/scalable/actions/transform-crop-and-resize.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-00.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-05.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-10.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-100.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-15.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-20.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-25.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-30.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-35.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-40.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-45.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-50.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-55.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-60.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-65.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-70.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-75.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-80.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-85.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-90.svg
share/brasero/icons/hicolor/scalable/status/brasero-disc-95.svg
share/brasero/logo.png
share/gconf/schemas/brasero.schemas
share/gnome/help/brasero/C/brasero.xml
share/gnome/help/brasero/C/figures/brasero_main.png
share/gnome/help/brasero/C/legal.xml
share/gnome/help/brasero/de/brasero.xml
share/gnome/help/brasero/de/figures/brasero_main.png
share/gnome/help/brasero/el/brasero.xml
share/gnome/help/brasero/el/figures/brasero_main.png
share/gnome/help/brasero/en_GB/brasero.xml
share/gnome/help/brasero/en_GB/figures/brasero_main.png
share/gnome/help/brasero/es/brasero.xml
share/gnome/help/brasero/es/figures/brasero_main.png
share/gnome/help/brasero/fr/brasero.xml
share/gnome/help/brasero/fr/figures/brasero_main.png
share/gnome/help/brasero/it/brasero.xml
share/gnome/help/brasero/it/figures/brasero_main.png
share/gnome/help/brasero/pl/brasero.xml
share/gnome/help/brasero/pl/figures/brasero_main.png
share/gnome/help/brasero/ru/brasero.xml
share/gnome/help/brasero/ru/figures/brasero_main.png
share/gnome/help/brasero/sv/brasero.xml
share/gnome/help/brasero/sv/figures/brasero_main.png
share/gtk-doc/html/brasero/BraseroDrive.html
share/gtk-doc/html/brasero/BraseroDriveSelection.html
share/gtk-doc/html/brasero/BraseroMedium.html
share/gtk-doc/html/brasero/BraseroMediumMonitor.html
share/gtk-doc/html/brasero/BraseroMediumSelection.html
share/gtk-doc/html/brasero/BraseroVolume.html
share/gtk-doc/html/brasero/brasero-brasero-media.html
share/gtk-doc/html/brasero/brasero-brasero-units.html
share/gtk-doc/html/brasero/brasero.devhelp
share/gtk-doc/html/brasero/brasero.devhelp2
share/gtk-doc/html/brasero/ch01.html
share/gtk-doc/html/brasero/home.png
share/gtk-doc/html/brasero/index.html
share/gtk-doc/html/brasero/index.sgml
share/gtk-doc/html/brasero/left.png
share/gtk-doc/html/brasero/right.png
share/gtk-doc/html/brasero/style.css
share/gtk-doc/html/brasero/up.png
share/icons/hicolor/16x16/apps/brasero.png
share/icons/hicolor/22x22/apps/brasero.png
share/icons/hicolor/24x24/apps/brasero.png
share/icons/hicolor/32x32/apps/brasero.png
share/icons/hicolor/48x48/apps/brasero.png
share/icons/hicolor/scalable/apps/brasero.svg
share/locale/ar/LC_MESSAGES/brasero.mo
share/locale/bg/LC_MESSAGES/brasero.mo
share/locale/bn_IN/LC_MESSAGES/brasero.mo
share/locale/ca/LC_MESSAGES/brasero.mo
share/locale/cs/LC_MESSAGES/brasero.mo
share/locale/da/LC_MESSAGES/brasero.mo
share/locale/de/LC_MESSAGES/brasero.mo
share/locale/dz/LC_MESSAGES/brasero.mo
share/locale/el/LC_MESSAGES/brasero.mo
share/locale/en_GB/LC_MESSAGES/brasero.mo
share/locale/es/LC_MESSAGES/brasero.mo
share/locale/et/LC_MESSAGES/brasero.mo
share/locale/eu/LC_MESSAGES/brasero.mo
share/locale/fi/LC_MESSAGES/brasero.mo
share/locale/fr/LC_MESSAGES/brasero.mo
share/locale/gl/LC_MESSAGES/brasero.mo
share/locale/gu/LC_MESSAGES/brasero.mo
share/locale/he/LC_MESSAGES/brasero.mo
share/locale/hi/LC_MESSAGES/brasero.mo
share/locale/hu/LC_MESSAGES/brasero.mo
share/locale/it/LC_MESSAGES/brasero.mo
share/locale/ja/LC_MESSAGES/brasero.mo
share/locale/kn/LC_MESSAGES/brasero.mo
share/locale/ko/LC_MESSAGES/brasero.mo
share/locale/lt/LC_MESSAGES/brasero.mo
share/locale/lv/LC_MESSAGES/brasero.mo
share/locale/mk/LC_MESSAGES/brasero.mo
share/locale/ml/LC_MESSAGES/brasero.mo
share/locale/mr/LC_MESSAGES/brasero.mo
share/locale/nb/LC_MESSAGES/brasero.mo
share/locale/nl/LC_MESSAGES/brasero.mo
share/locale/oc/LC_MESSAGES/brasero.mo
share/locale/or/LC_MESSAGES/brasero.mo
share/locale/pa/LC_MESSAGES/brasero.mo
share/locale/pl/LC_MESSAGES/brasero.mo
share/locale/pt/LC_MESSAGES/brasero.mo
share/locale/pt_BR/LC_MESSAGES/brasero.mo
share/locale/ro/LC_MESSAGES/brasero.mo
share/locale/ru/LC_MESSAGES/brasero.mo
share/locale/sl/LC_MESSAGES/brasero.mo
share/locale/sr/LC_MESSAGES/brasero.mo
share/locale/sr@latin/LC_MESSAGES/brasero.mo
share/locale/sv/LC_MESSAGES/brasero.mo
share/locale/ta/LC_MESSAGES/brasero.mo
share/locale/te/LC_MESSAGES/brasero.mo
share/locale/th/LC_MESSAGES/brasero.mo
share/locale/vi/LC_MESSAGES/brasero.mo
share/locale/zh_CN/LC_MESSAGES/brasero.mo
share/locale/zh_HK/LC_MESSAGES/brasero.mo
share/locale/zh_TW/LC_MESSAGES/brasero.mo
share/mime/packages/brasero.xml
share/omf/brasero/brasero-C.omf
share/omf/brasero/brasero-de.omf
share/omf/brasero/brasero-el.omf
share/omf/brasero/brasero-en_GB.omf
share/omf/brasero/brasero-es.omf
share/omf/brasero/brasero-fr.omf
share/omf/brasero/brasero-it.omf
share/omf/brasero/brasero-pl.omf
share/omf/brasero/brasero-ru.omf
share/omf/brasero/brasero-sv.omf
@dirrm share/omf/brasero
@comment in rarian: @dirrm share/omf
@comment in shared-mime-info: @dirrm share/mime/packages
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/scalable/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/scalable
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/48x48/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/48x48
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/32x32/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/32x32
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/24x24/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/24x24
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/22x22/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/22x22
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/16x16/apps
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/16x16
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor
@comment in xdg-dirs: @dirrm share/icons
@dirrm share/gtk-doc/html/brasero
@dirrm share/gnome/help/brasero/sv/figures
@dirrm share/gnome/help/brasero/sv
@dirrm share/gnome/help/brasero/ru/figures
@dirrm share/gnome/help/brasero/ru
@dirrm share/gnome/help/brasero/pl/figures
@dirrm share/gnome/help/brasero/pl
@dirrm share/gnome/help/brasero/it/figures
@dirrm share/gnome/help/brasero/it
@dirrm share/gnome/help/brasero/fr/figures
@dirrm share/gnome/help/brasero/fr
@dirrm share/gnome/help/brasero/es/figures
@dirrm share/gnome/help/brasero/es
@dirrm share/gnome/help/brasero/en_GB/figures
@dirrm share/gnome/help/brasero/en_GB
@dirrm share/gnome/help/brasero/el/figures
@dirrm share/gnome/help/brasero/el
@dirrm share/gnome/help/brasero/de/figures
@dirrm share/gnome/help/brasero/de
@dirrm share/gnome/help/brasero/C/figures
@dirrm share/gnome/help/brasero/C
@dirrm share/gnome/help/brasero
@comment in gnome2-dirs: @dirrm share/gnome/help
@comment in gnome2-dirs: @dirrm share/gnome
@comment in GConf: @dirrm share/gconf/schemas
@dirrm share/brasero/icons/hicolor/scalable/status
@dirrm share/brasero/icons/hicolor/scalable/actions
@dirrm share/brasero/icons/hicolor/scalable
@dirrm share/brasero/icons/hicolor/48x48/actions
@dirrm share/brasero/icons/hicolor/48x48
@dirrm share/brasero/icons/hicolor/32x32/status
@dirrm share/brasero/icons/hicolor/32x32/actions
@dirrm share/brasero/icons/hicolor/32x32
@dirrm share/brasero/icons/hicolor/24x24/status
@dirrm share/brasero/icons/hicolor/24x24/actions
@dirrm share/brasero/icons/hicolor/24x24
@dirrm share/brasero/icons/hicolor/22x22/status
@dirrm share/brasero/icons/hicolor/22x22/actions
@dirrm share/brasero/icons/hicolor/22x22
@dirrm share/brasero/icons/hicolor/16x16/status
@dirrm share/brasero/icons/hicolor/16x16/actions
@dirrm share/brasero/icons/hicolor/16x16
@dirrm share/brasero/icons/hicolor
@dirrm share/brasero/icons
@dirrm share/brasero
@comment in xdg-dirs: @dirrm share/applications
@comment in nautilus: @dirrm lib/nautilus/extensions-2.0
@comment in nautilus: @dirrm lib/nautilus
@dirrm lib/brasero/plugins
@dirrm lib/brasero
@dirrm include/brasero

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2009/03/16 10:49:06 jmcneill Exp $
SHA1 (brasero-2.26.0.tar.bz2) = 3f4e6595b5c8d6767ac220568b183e51d31c3c63
RMD160 (brasero-2.26.0.tar.bz2) = 522baad9bd7e0aad238067f690c9f3ca16b7a755
Size (brasero-2.26.0.tar.bz2) = 3129146 bytes
SHA1 (patch-aa) = ec853f5d230d7d9296ef042bcd9a65d87f172b08
SHA1 (patch-ab) = 3a1c1671d44ed0533540556b5b0bab89c2ff9175

View file

@ -0,0 +1,18 @@
# $Id: msgfmtstrip,v 1.1.1.1 2009/03/16 10:49:06 jmcneill Exp $
# Simple awk script to strip out .po entries with "msgctxt" or "#~|", so the
# resultant file can be handled by the msgfmt 0.14.4 in NetBSD 4.0
{
if (/^$/) { entry_end(); }
else if ($1 == "msgctxt" || $2 == "msgctxt") { skip = 1; }
else if ($1 == "#~|") { skip = 1; }
else { entry = entry $0 "\n" }
}
END { entry_end(); }
function entry_end() {
if (!skip)
print entry;
entry = "";
skip = 0;
}

View file

@ -0,0 +1,195 @@
/* $NetBSD: scsi-netbsd.c,v 1.1.1.1 2009/03/16 10:49:06 jmcneill Exp $ */
/* -*- Mode: C; indent-tabs-mode: t; c-basic-offset: 8; tab-width: 8 -*- */
/*
* Libbrasero-media
* Copyright (C) Philippe Rouquier 2005-2009 <bonfire-app@wanadoo.fr>
* Jared D. McNeill 2009 <jmcneill@NetBSD.org>
*
* Libbrasero-media is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
* the Free Software Foundation; either version 2 of the License, or
* (at your option) any later version.
*
* The Libbrasero-media authors hereby grant permission for non-GPL compatible
* GStreamer plugins to be used and distributed together with GStreamer
* and Libbrasero-media. This permission is above and beyond the permissions granted
* by the GPL license by which Libbrasero-media is covered. If you modify this code
* you may extend this exception to your version of the code, but you are not
* obligated to do so. If you do not wish to do so, delete this exception
* statement from your version.
*
* Libbrasero-media is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU Library General Public License for more details.
*
* You should have received a copy of the GNU General Public License
* along with this program; if not, write to:
* The Free Software Foundation, Inc.,
* 51 Franklin Street, Fifth Floor
* Boston, MA 02110-1301, USA.
*/
#ifdef HAVE_CONFIG_H
# include <config.h>
#endif
#include <errno.h>
#include <unistd.h>
#include <stdlib.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <fcntl.h>
#include <string.h>
#include <sys/ioctl.h>
#include <sys/scsiio.h>
#include "brasero-media-private.h"
#include "scsi-command.h"
#include "scsi-utils.h"
#include "scsi-error.h"
#include "scsi-sense-data.h"
struct _BraseroDeviceHandle {
int fd;
};
struct _BraseroScsiCmd {
uchar cmd [BRASERO_SCSI_CMD_MAX_LEN];
BraseroDeviceHandle *handle;
const BraseroScsiCmdInfo *info;
};
typedef struct _BraseroScsiCmd BraseroScsiCmd;
#define BRASERO_SCSI_CMD_OPCODE_OFF 0
#define BRASERO_SCSI_CMD_SET_OPCODE(command) (command->cmd [BRASERO_SCSI_CMD_OPCODE_OFF] = command->info->opcode)
#define OPEN_FLAGS O_RDWR /*|O_EXCL */|O_NONBLOCK
/**
* This is to send a command
*/
static void
brasero_sg_command_setup (scsireq_t *req,
BraseroScsiCmd *cmd,
uchar *buffer,
int size)
{
memset (req, 0, sizeof (scsireq_t));
req->cmdlen = cmd->info->size;
memcpy(req->cmd, cmd->cmd, req->cmdlen);
req->databuf = buffer;
req->datalen = size;
/* where to output the scsi sense buffer */
req->senselen = BRASERO_SENSE_DATA_SIZE;
if (cmd->info->direction & BRASERO_SCSI_READ)
req->flags = SCCMD_READ;
else if (cmd->info->direction & BRASERO_SCSI_WRITE)
req->flags = SCCMD_WRITE;
}
BraseroScsiResult
brasero_scsi_command_issue_sync (gpointer command,
gpointer buffer,
int size,
BraseroScsiErrCode *error)
{
scsireq_t req;
BraseroScsiResult res;
BraseroScsiCmd *cmd;
cmd = command;
brasero_sg_command_setup (&req,
cmd,
buffer,
size);
res = ioctl (cmd->handle->fd, SCIOCCOMMAND, &req);
if (res) {
BRASERO_SCSI_SET_ERRCODE (error, BRASERO_SCSI_ERRNO);
return BRASERO_SCSI_FAILURE;
}
if (req.retsts == SCCMD_OK)
return BRASERO_SCSI_OK;
if (req.retsts == SCCMD_SENSE)
return brasero_sense_data_process (req.sense, error);
return BRASERO_SCSI_FAILURE;
}
gpointer
brasero_scsi_command_new (const BraseroScsiCmdInfo *info,
BraseroDeviceHandle *handle)
{
BraseroScsiCmd *cmd;
/* make sure we can set the flags of the descriptor */
/* allocate the command */
cmd = g_new0 (BraseroScsiCmd, 1);
cmd->info = info;
cmd->handle = handle;
BRASERO_SCSI_CMD_SET_OPCODE (cmd);
return cmd;
}
BraseroScsiResult
brasero_scsi_command_free (gpointer cmd)
{
g_free (cmd);
return BRASERO_SCSI_OK;
}
/**
* This is to open a device
*/
BraseroDeviceHandle *
brasero_device_handle_open (const gchar *path,
gboolean exclusive,
BraseroScsiErrCode *code)
{
int fd;
int flags = OPEN_FLAGS;
BraseroDeviceHandle *handle;
if (exclusive)
flags |= O_EXCL;
fd = open (path, flags);
if (fd < 0) {
if (code) {
if (errno == EAGAIN
|| errno == EWOULDBLOCK
|| errno == EBUSY)
*code = BRASERO_SCSI_NOT_READY;
else
*code = BRASERO_SCSI_ERRNO;
}
return NULL;
}
handle = g_new (BraseroDeviceHandle, 1);
handle->fd = fd;
return handle;
}
void
brasero_device_handle_close (BraseroDeviceHandle *handle)
{
close (handle->fd);
g_free (handle);
}

View file

@ -0,0 +1,36 @@
$NetBSD: patch-aa,v 1.1.1.1 2009/03/16 10:49:06 jmcneill Exp $
--- configure.in.orig 2009-03-15 20:47:59.000000000 -0400
+++ configure.in
@@ -82,6 +82,11 @@ AC_CHECK_TYPES([sg_io_hdr_t],[has_sg="ye
[#include <sys/types.h>
#include <scsi/sg.h>])
+dnl ***************** check for netbsd *************************
+AC_CHECK_TYPES([scsireq_t],[has_scsiio="yes"],[has_scsiio="no"],
+[#include <sys/types.h>
+ #include <sys/scsiio.h>])
+
dnl ***************** check for solaris uscsi interface ********
AC_CHECK_TYPES([struct uscsi_cmd],[has_uscsi="yes"],[has_uscsi="no"],
[#include <sys/types.h>
@@ -91,15 +96,18 @@ if test x"$has_cam" = x"yes"; then
BRASERO_SCSI_LIBS="-lcam"
elif test x"$has_sg" = x"yes"; then
:
+elif test x"$has_scsiio" = x"yes"; then
+ :
elif test x"$has_uscsi" = x"yes"; then
:
else
- AC_ERROR([Support Linux SG, FreeBSD CAM, Solaris USCSI. No supported SCSI interface headers could not be found.])
+ AC_ERROR([Support Linux SG, FreeBSD CAM, NetBSD SCSIPI, Solaris USCSI. No supported SCSI interface headers could not be found.])
fi
AM_CONDITIONAL(HAVE_CAM_LIB_H, test x"$has_cam" = "xyes")
AM_CONDITIONAL(HAVE_SG_IO_HDR_T, test x"$has_sg" = "xyes")
AM_CONDITIONAL(HAVE_USCSI_H, test x"$has_uscsi" = "xyes")
+AM_CONDITIONAL(HAVE_SCSIIO_H, test x"$has_scsiio" = "xyes")
dnl ***************** LARGE FILE SUPPORT ***********************

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ab,v 1.1.1.1 2009/03/16 10:49:06 jmcneill Exp $
--- libbrasero-media/Makefile.am.orig 2009-03-15 20:47:51.000000000 -0400
+++ libbrasero-media/Makefile.am
@@ -141,6 +141,11 @@ if HAVE_SG_IO_HDR_T
libbrasero_media_la_SOURCES += scsi-sg.c
endif
+# NetBSD's scsi(4)
+if HAVE_SCSIIO_H
+libbrasero_media_la_SOURCES += scsi-netbsd.c
+endif
+
# Solaris's USCSI interface
if HAVE_USCSI_H
libbrasero_media_la_SOURCES += scsi-uscsi.c