databases/ocaml-sqlite3: Fix build for DragonFly

Redefining __unused will break the build, so don't do it.
This commit is contained in:
marino 2012-09-01 12:48:10 +00:00
parent 00c2be385c
commit 7e6d17d0b2
2 changed files with 6 additions and 5 deletions

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2012/05/14 09:20:39 wiz Exp $
$NetBSD: distinfo,v 1.2 2012/09/01 12:48:10 marino Exp $
SHA1 (ocaml-sqlite3-1.6.1.tar.gz) = 1f67e2bd80907a755ac5689fc466020f5f2c394c
RMD160 (ocaml-sqlite3-1.6.1.tar.gz) = dbfdb928041fdb8ccaac8f1d14223124d6bfe8ec
Size (ocaml-sqlite3-1.6.1.tar.gz) = 59073 bytes
SHA1 (patch-Makefile.in) = 4c60faa5c9e0e2b5ae55d6fc96d63a12fac369bd
SHA1 (patch-configure.ac) = 18f762288c41c4e23cfc263108b20339ff9179cb
SHA1 (patch-sqlite3_stubs.c) = 1ec65d01c5119e36be1431da9d57b49fc25ef4ff
SHA1 (patch-sqlite3_stubs.c) = b069cfda4e7aeb40ebedab1c531b1157a031428c

View file

@ -1,6 +1,7 @@
$NetBSD: patch-sqlite3_stubs.c,v 1.1.1.1 2012/05/14 09:20:39 wiz Exp $
$NetBSD: patch-sqlite3_stubs.c,v 1.2 2012/09/01 12:48:10 marino Exp $
Avoiding redefinition of __unused on NetBSD and DragonFly
unused definition for FreeBSD works on NetBSD too
--- sqlite3_stubs.c.orig 2008-04-13 14:26:56.000000000 +0200
+++ sqlite3_stubs.c 2008-04-13 14:27:35.000000000 +0200
@@ -40,7 +40,7 @@
@ -8,7 +9,7 @@ unused definition for FreeBSD works on NetBSD too
#if __GNUC__ >= 3
# define inline inline __attribute__ ((always_inline))
-# if !defined(__FreeBSD__) && !__APPLE__
+# if !defined(__FreeBSD__) && !defined(__NetBSD__) && !__APPLE__
+# if !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__DragonFly__) && !__APPLE__
# define __unused __attribute__ ((unused))
# endif
#else