Update smokeping to 1.30
- Add option to build with SpeedyCGI support (USE_SPEEDY) - Use @RCD_SCRIPTS_SHELL@ instead of hardcoded /bin/sh - Use REPLACE_PERL instead of patch/sed hack Closes PR #25549 submitted by me. Ok'ed wiz@/bouyer@ From the CHANGELOG: 2004/05/12 -- 1.30 * fix nodata_color syntax --tobi * when inserting unknown values into sorted rtt list, do this on the outside ... U:U:1:2:3:U:U and not in the middle. This will make the graphs more smokei when there is data loss. --tobi * config files with different probes should work ... fixed problem introduced in 1.29 --tobi 2004/05/08 -- 1.29 * while running, make all die and warn things go to the log file if there is one --tobi * added rawlog option for logging actual gatherd data --tobi (for virtela) * added alertee option to send a copy of any alert generated to additional 'perbranche' people --tobi * cgi should not complain about non existing hosts ... the daemon does that i already --tobi * actually allow empty alerts -- tobi * added nodata_color property to specify background color for graph when when no data is available -- David Hull <hull@dslextreme.com>
This commit is contained in:
parent
ce4a753108
commit
7e78a7a752
5 changed files with 34 additions and 25 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.7 2004/06/08 12:24:00 cjep Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2004/06/23 22:25:44 adrianp Exp $
|
||||
|
||||
DISTNAME= smokeping-1.28
|
||||
DISTNAME= smokeping-1.30
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://people.ee.ethz.ch/~oetiker/webtools/smokeping/pub/
|
||||
|
||||
|
@ -15,29 +15,40 @@ DEPENDS+= p5-libwww>=5.64:../../www/p5-libwww
|
|||
|
||||
USE_PERL5= YES
|
||||
PERL5_REQD+= 5.6.0
|
||||
USE_PKGINSTALL= yes
|
||||
USE_PKGINSTALL= YES
|
||||
|
||||
BUILD_DEFS+= USE_INET6
|
||||
|
||||
PKG_SYSCONFSUBDIR?= smokeping
|
||||
MESSAGE_SUBST+= PKG_SYSCONFDIR=${PKG_SYSCONFDIR}
|
||||
|
||||
EGDIR=${PREFIX}/share/examples/smokeping
|
||||
CONF_FILES= ${EGDIR}/basepage.html.dist ${PKG_SYSCONFDIR}/basepage.html
|
||||
CONF_FILES+= ${EGDIR}/smokemail.dist ${PKG_SYSCONFDIR}/smokemail
|
||||
EGDIR= ${PREFIX}/share/examples/smokeping
|
||||
CONF_FILES= ${EGDIR}/basepage.html.dist ${PKG_SYSCONFDIR}/basepage.html
|
||||
CONF_FILES+= ${EGDIR}/smokemail.dist ${PKG_SYSCONFDIR}/smokemail
|
||||
RCD_SCRIPTS= smokeping
|
||||
REPLACE_PERL= bin/smokeping.dist
|
||||
|
||||
BUILD_DEFS+= USE_SPEEDY
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.if defined(USE_INET6) && ${USE_INET6} == "YES"
|
||||
DEPENDS+= p5-Socket6-*:../../net/p5-Socket6
|
||||
.endif
|
||||
|
||||
.if defined(USE_SPEEDY) && ${USE_SPEEDY} == "YES"
|
||||
DEPENDS+= SpeedyCGI-*:../../www/SpeedyCGI
|
||||
INTERP= speedy
|
||||
.else
|
||||
INTERP= perl
|
||||
.endif
|
||||
|
||||
do-build:
|
||||
${SED} -e s#@PREFIX@#${PREFIX}#g \
|
||||
-e s#@PKG_SYSCONFDIR@#${PKG_SYSCONFDIR}#g \
|
||||
<${WRKSRC}/bin/smokeping.dist >${WRKDIR}/smokeping.pl
|
||||
${SED} -e s#@PREFIX@#${PREFIX}#g \
|
||||
-e s#@PKG_SYSCONFDIR@#${PKG_SYSCONFDIR}#g \
|
||||
-e s#@INTERP@#${INTERP}#g \
|
||||
<${WRKSRC}/htdocs/smokeping.cgi.dist >${WRKDIR}/smokeping.cgi
|
||||
${SED} -e s#@PREFIX@#${PREFIX}#g \
|
||||
-e s#@PKG_SYSCONFDIR@#${PKG_SYSCONFDIR}#g \
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2004/04/12 21:05:15 kim Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/06/23 22:25:44 adrianp Exp $
|
||||
|
||||
SHA1 (smokeping-1.28.tar.gz) = d53642255b1923f4541ea17fb51ae7fe394daa63
|
||||
Size (smokeping-1.28.tar.gz) = 214564 bytes
|
||||
SHA1 (patch-aa) = 88fc78660d5b44430725783653cb72e04aaec88a
|
||||
SHA1 (patch-ab) = 8ca6c7c069da74d9a5e28cc54d30a8f90cbe8ad7
|
||||
SHA1 (smokeping-1.30.tar.gz) = 8161ed558b357be69da1c20b7738fd166e8f90e2
|
||||
Size (smokeping-1.30.tar.gz) = 191865 bytes
|
||||
SHA1 (patch-aa) = fce938bab82e77c66b0dc27118f16cd981dead8a
|
||||
SHA1 (patch-ab) = c7a303b5285df490925cc2e14de9e65b2f2c818c
|
||||
SHA1 (patch-ac) = 38192257b9ab760650c6972e34089bfa058d1007
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#! /bin/sh
|
||||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: smokeping.sh,v 1.1.1.1 2003/03/24 15:24:39 bouyer Exp $
|
||||
# $NetBSD: smokeping.sh,v 1.2 2004/06/23 22:25:44 adrianp Exp $
|
||||
#
|
||||
# PROVIDE: smokeping
|
||||
# REQUIRE: DAEMON
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
$NetBSD: patch-aa,v 1.2 2004/04/12 21:05:15 kim Exp $
|
||||
$NetBSD: patch-aa,v 1.3 2004/06/23 22:25:44 adrianp Exp $
|
||||
|
||||
--- bin/smokeping.dist.orig 2004-03-14 15:27:24.000000000 -0500
|
||||
+++ bin/smokeping.dist 2004-04-12 16:24:12.000000000 -0400
|
||||
--- bin/smokeping.dist.orig Wed May 12 20:49:01 2004
|
||||
+++ bin/smokeping.dist Wed May 12 20:49:44 2004
|
||||
@@ -1,14 +1,11 @@
|
||||
-#!/usr/sepp/bin/perl -w
|
||||
+#!@PREFIX@/bin/perl -w
|
||||
#!/usr/sepp/bin/perl -w
|
||||
# -*-perl-*-
|
||||
|
||||
-use lib qw(/home/oetiker/data/projects/AABN-rrdtool/perl-shared/blib/lib);
|
||||
|
@ -13,7 +12,7 @@ $NetBSD: patch-aa,v 1.2 2004/04/12 21:05:15 kim Exp $
|
|||
-use lib qw(/home/oetiker/data/projects/AADJ-smokeping/dist/lib);
|
||||
+use lib qw(@PREFIX@/lib/smokeping);
|
||||
|
||||
use Smokeping 1.28;
|
||||
use Smokeping 1.30;
|
||||
|
||||
-Smokeping::main("etc/config.dist");
|
||||
+Smokeping::main("@PKG_SYSCONFDIR@/config");
|
||||
|
|
|
@ -1,17 +1,16 @@
|
|||
$NetBSD: patch-ab,v 1.2 2004/04/12 21:05:15 kim Exp $
|
||||
|
||||
--- htdocs/smokeping.cgi.dist.orig 2004-03-14 15:27:24.000000000 -0500
|
||||
+++ htdocs/smokeping.cgi.dist 2004-04-12 16:23:45.000000000 -0400
|
||||
$NetBSD: patch-ab,v 1.3 2004/06/23 22:25:44 adrianp Exp $
|
||||
--- htdocs/smokeping.cgi.dist.orig Thu Jun 10 00:14:25 2004
|
||||
+++ htdocs/smokeping.cgi.dist Thu Jun 10 00:15:42 2004
|
||||
@@ -1,12 +1,11 @@
|
||||
-#!/usr/sepp/bin/speedy -w
|
||||
+#!@PREFIX@/bin/perl -w
|
||||
+#!@PREFIX@/bin/@INTERP@ -w
|
||||
# -*-perl-*-
|
||||
|
||||
-use lib qw(/usr/pack/rrdtool-1.0.33-to/lib/perl);
|
||||
-use lib qw(/home/oetiker/data/projects/AADJ-smokeping/dist/lib);
|
||||
+use lib qw(@PREFIX@/lib/smokeping);
|
||||
|
||||
use Smokeping 1.28;
|
||||
use Smokeping 1.30;
|
||||
|
||||
-Smokeping::cgi("/home/oetiker/data/projects/AADJ-smokeping/dist/etc/config");
|
||||
+Smokeping::cgi("@PKG_SYSCONFDIR@/config");
|
||||
|
|
Loading…
Reference in a new issue