Initial import of databases/p5-AddressBook:
Perl-AddressBook is a collection of perl library modules which provide a unified interface for accessing addressbook entries stored in various types of databases, e.g. LDAP, LDIF, PalmDB, DBI, text, HTML.
This commit is contained in:
parent
075782f99f
commit
7e911e1135
5 changed files with 96 additions and 0 deletions
3
databases/p5-AddressBook/DESCR
Normal file
3
databases/p5-AddressBook/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
Perl-AddressBook is a collection of perl library modules which provide a
|
||||
unified interface for accessing addressbook entries stored in various
|
||||
types of databases, e.g. LDAP, LDIF, PalmDB, DBI, text, HTML.
|
38
databases/p5-AddressBook/Makefile
Normal file
38
databases/p5-AddressBook/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2002/01/28 02:22:59 jlam Exp $
|
||||
|
||||
DISTNAME= AddressBook-0.16
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
CATEGORIES= databases perl5
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=perl-abook/} \
|
||||
ftp://ftp.loaded.net/pub/CPAN/authors/id/D/DL/DLEIGH/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://perl-abook.sourceforge.net/
|
||||
COMMENT= perl5 module for unified access to addressbook databases
|
||||
|
||||
DEPENDS+= p5-DBI>=1.14:../../databases/p5-DBI
|
||||
DEPENDS+= p5-Date-Manip>=5.39:../../devel/p5-Date-Manip
|
||||
DEPENDS+= p5-XML-DOM>=1.25:../../textproc/p5-XML-DOM
|
||||
DEPENDS+= p5-perl-ldap>=0.20:../../databases/p5-perl-ldap
|
||||
DEPENDS+= p5-pilot-link-[0-9]*:../../comms/p5-pilot-link
|
||||
|
||||
USE_PERL5= YES
|
||||
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/AddressBook/.packlist
|
||||
|
||||
REPLACE_PERL= examples/SyncAbook.pm
|
||||
REPLACE_PERL+= examples/abook.palm
|
||||
REPLACE_PERL+= examples/phonelist.cgi
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${EGDIR}
|
||||
cd ${WRKSRC}; \
|
||||
for file in ${REPLACE_PERL} examples/ldap-abook.conf; do \
|
||||
${INSTALL_DATA} $${file} ${EGDIR}; \
|
||||
done
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
6
databases/p5-AddressBook/PLIST
Normal file
6
databases/p5-AddressBook/PLIST
Normal file
|
@ -0,0 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/01/28 02:22:59 jlam Exp $
|
||||
share/examples/p5-AddressBook/SyncAbook.pm
|
||||
share/examples/p5-AddressBook/abook.palm
|
||||
share/examples/p5-AddressBook/ldap-abook.conf
|
||||
share/examples/p5-AddressBook/phonelist.cgi
|
||||
@dirrm share/examples/p5-AddressBook
|
5
databases/p5-AddressBook/distinfo
Normal file
5
databases/p5-AddressBook/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/01/28 02:22:59 jlam Exp $
|
||||
|
||||
SHA1 (AddressBook-0.16.tar.gz) = 953746d71b64771aab25475366c35e6778dd313c
|
||||
Size (AddressBook-0.16.tar.gz) = 32634 bytes
|
||||
SHA1 (patch-aa) = d5e38c7c9519de7663eee597e1584406ec613a39
|
44
databases/p5-AddressBook/patches/patch-aa
Normal file
44
databases/p5-AddressBook/patches/patch-aa
Normal file
|
@ -0,0 +1,44 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/01/28 02:22:59 jlam Exp $
|
||||
|
||||
--- Makefile.PL.orig Fri Feb 2 16:59:42 2001
|
||||
+++ Makefile.PL
|
||||
@@ -66,39 +66,6 @@
|
||||
|
||||
exit unless $reqs_found;
|
||||
|
||||
-$r = prompt("For testing the LDAP backend, I need to know some things about
|
||||
-your LDAP server. Continue? [y/n]","y");
|
||||
-
|
||||
-if ($r =~ /^y$/i) {
|
||||
- $hostname = prompt("What is your LDAP server hostname","localhost");
|
||||
- $base = prompt("What is a valid LDAP base that I can use for searching?
|
||||
-(eg. \"ou=abook,dc=<your_domain>\")");
|
||||
- $objectclass = prompt("What is a valid LDAP objectclass that I can search for?",
|
||||
-"organizationalUnit");
|
||||
- print "The LDAP test script will attempt to bind anonymously to \"$hostname\"
|
||||
-and search for \"objectclass=$objectclass\"
|
||||
-using the base: $base\n";
|
||||
- open F, ">t/t.ldap.conf";
|
||||
- print F << "EDQ";
|
||||
-<AddressBook_config>
|
||||
- <fields>
|
||||
- <field name="objectclass">
|
||||
- <db type="LDAP" name="objectclass" />
|
||||
- </field>
|
||||
- </fields>
|
||||
- <databases>
|
||||
- <LDAP
|
||||
- hostname = "$hostname"
|
||||
- base = "$base"
|
||||
- anonymous = "1"
|
||||
- objectclass = "$objectclass"
|
||||
- />
|
||||
- </databases>
|
||||
-</AddressBook_config>
|
||||
-EDQ
|
||||
- close F;
|
||||
-}
|
||||
-
|
||||
WriteMakefile(
|
||||
'NAME' => 'AddressBook',
|
||||
'VERSION_FROM' => 'lib/AddressBook.pm',
|
Loading…
Reference in a new issue