update for changed signature of MP4GetMetadataCoverArt() in libmp4v2-1.6.1,

bump required version of libmp4v2 and PKGREVISION
should resolve PR pkg/37418 by Johann Franz (half of it)
This commit is contained in:
drochner 2007-11-21 21:40:25 +00:00
parent 7af5cd05ed
commit 7eae8e2ced
4 changed files with 19 additions and 3 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.3 2007/10/17 20:45:13 wiz Exp $
# $NetBSD: Makefile,v 1.4 2007/11/21 21:40:25 drochner Exp $
#
DISTNAME= easytag-2.1.3
PKGREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=easytag/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.3 2007/10/17 20:45:13 wiz Exp $
$NetBSD: distinfo,v 1.4 2007/11/21 21:40:25 drochner Exp $
SHA1 (easytag-2.1.3.tar.bz2) = 8be1f0f84fed9b9f3fe0f1f9770315744005905e
RMD160 (easytag-2.1.3.tar.bz2) = b6c0d4b204ff637c310775f174d6663ce1fe51bd
Size (easytag-2.1.3.tar.bz2) = 3101510 bytes
SHA1 (patch-aa) = bfb67a2d37317243f197f6a497fff67adf38df0b

View file

@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.1.1.1 2007/07/07 07:47:51 wiz Exp $
# $NetBSD: options.mk,v 1.2 2007/11/21 21:40:25 drochner Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.easytag-current
PKG_SUPPORTED_OPTIONS= flac mpeg4ip ogg speex wavpack
@ -15,6 +15,7 @@ CONFIGURE_ARGS+= --disable-flac
.endif
.if !empty(PKG_OPTIONS:Mmpeg4ip)
BUILDLINK_API_DEPENDS.libmp4v2+= libmp4v2>=1.6.1
.include "../../multimedia/libmp4v2/buildlink3.mk"
# for mpeg4ip.h
CPPFLAGS+= -DHAVE_GTK

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.3 2007/11/21 21:40:25 drochner Exp $
--- src/mp4_tag.c.orig 2007-11-19 19:27:42.000000000 +0100
+++ src/mp4_tag.c
@@ -185,7 +185,7 @@ gboolean Mp4tag_Read_File_Tag (gchar *fi
* Picture *
***********/
// There is only one picture!
- if ( MP4GetMetadataCoverArt( mp4file, &coverArt, &coverSize ) )
+ if ( MP4GetMetadataCoverArt( mp4file, &coverArt, &coverSize, 0 ) )
{
Picture *pic = Picture_Allocate();
pic->size = coverSize;