Update to 1.12.3:
Changes in version 1.12.3, released on December 31, 2013 * In the mdoc(7) SYNOPSIS, line breaks and hanging indentation now work correctly for .Fo/.Fa/.Fc and .Fn blocks. Thanks to Franco Fichtner for doing part of the work. * The mdoc(7) .Bk macro got some addititonal bugfixes. * In mdoc(7) macro arguments, double quotes can now be quoted by doubling them, just like in man(7). Thanks to Tsugutomo ENAMI for the patch. * At the end of man(7) macro lines, end-of-sentence spacing now works. Thanks to Franco Fichtner for the patch. * For backward compatibility, the man(7) parser now supports the man-ext .UR/.UE (uniform resource identifier) block macros. * The man(7) parser now handles closing blocks that are not open more gracefully. * The man(7) parser now ignores blank lines right after .SH and .SS. * In the man(7) formatter, reset indentation when leaving a block, not just when entering the next one. * The roff(7) .nr request now supports incrementing and decrementing number registers and stops parsing the number right before the first non-digit character. * The roff(7) parser now supports the alternative escape sequence syntax \C'uXXXX' for Unicode characters. * The roff(7) parser now parses and ignores the .fam (font family) and .hw (hyphenation points) requests and the \d and \u escape sequences. * The roff(7) manual got a new ESCAPE SEQUENCE REFERENCE.
This commit is contained in:
parent
c8bcc3deaf
commit
7eb8c63fd1
8 changed files with 12 additions and 198 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.40 2013/12/29 19:26:36 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.41 2013/12/31 11:06:29 wiz Exp $
|
||||
|
||||
DISTNAME= mdocml-1.12.2
|
||||
DISTNAME= mdocml-1.12.3
|
||||
CATEGORIES= textproc devel
|
||||
MASTER_SITES= http://mdocml.bsd.lv/snapshots/
|
||||
|
||||
|
|
|
@ -1,13 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.31 2013/12/29 19:19:03 tron Exp $
|
||||
$NetBSD: distinfo,v 1.32 2013/12/31 11:06:29 wiz Exp $
|
||||
|
||||
SHA1 (mdocml-1.12.2.tar.gz) = 6a86cc4f373bcc51aa8bf1a7499db368e977a166
|
||||
RMD160 (mdocml-1.12.2.tar.gz) = 8fcd1b9dd20b3a2eee9412d210e1b994c9ae7c17
|
||||
Size (mdocml-1.12.2.tar.gz) = 286400 bytes
|
||||
SHA1 (mdocml-1.12.3.tar.gz) = 6a74b4e4b54a20b8022f05236e2294ad2915e5d7
|
||||
RMD160 (mdocml-1.12.3.tar.gz) = 0a9a717ddf9d32c4ce1be8e51659932c5ccf2b8b
|
||||
Size (mdocml-1.12.3.tar.gz) = 292544 bytes
|
||||
SHA1 (patch-Makefile) = 569fdf24dff306c6c7222a3807e99d9ae1bb0ce6
|
||||
SHA1 (patch-apropos__db.c) = 862851ae479d8ee0b296269fb0b79e30c6f55435
|
||||
SHA1 (patch-catman.c) = c7738a6c1089963b83556cafc6bdca2735d28c48
|
||||
SHA1 (patch-cgi.c) = 2eccde5060bbf0479c80f0b4368ebf1950c90c47
|
||||
SHA1 (patch-config.h.post) = ff9805110e590e19a65bf9a6130e1b086893cfb0
|
||||
SHA1 (patch-mandocdb.c) = 88ab5ceb2db1f108c9a4d8f6c3a23718b2ad05ce
|
||||
SHA1 (patch-apropos__db.c) = efde1e020c84307e8549cf8b3e25668023fb4d34
|
||||
SHA1 (patch-preconv.1) = 92787c58f451e1d247a25bbe136f188bf42e4c73
|
||||
SHA1 (patch-roff.7) = a8daeae7e8e6c0117d499fb0c4a848d724b29b3e
|
||||
SHA1 (patch-roff.7) = 9b6033b5ec92c8e8c827fe79aff30228f7c2fc2f
|
||||
|
|
|
@ -1,34 +1,9 @@
|
|||
$NetBSD: patch-apropos__db.c,v 1.3 2013/12/29 19:19:03 tron Exp $
|
||||
$NetBSD: patch-apropos__db.c,v 1.4 2013/12/31 11:06:30 wiz Exp $
|
||||
|
||||
SunOS fix.
|
||||
|
||||
--- apropos_db.c.orig 2013-10-05 15:09:07.000000000 +0100
|
||||
+++ apropos_db.c 2013-12-29 19:07:21.000000000 +0000
|
||||
@@ -30,14 +30,19 @@
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
|
||||
-#if defined(__linux__)
|
||||
-# include <endian.h>
|
||||
-# include <db_185.h>
|
||||
-#elif defined(__APPLE__)
|
||||
+#if defined(__APPLE__)
|
||||
# include <libkern/OSByteOrder.h>
|
||||
-# include <db.h>
|
||||
+#elif defined(__linux__)
|
||||
+# include <endian.h>
|
||||
+#elif defined(__sun)
|
||||
+# include <sys/byteorder.h>
|
||||
#else
|
||||
# include <sys/endian.h>
|
||||
+#endif
|
||||
+
|
||||
+#if defined(__linux__) || defined(__sun)
|
||||
+# include <db_185.h>
|
||||
+#else
|
||||
# include <db.h>
|
||||
#endif
|
||||
|
||||
@@ -141,6 +146,14 @@
|
||||
const struct expr *, size_t terms,
|
||||
struct mchars *, int);
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-catman.c,v 1.1 2013/10/11 14:45:18 wiz Exp $
|
||||
|
||||
SunOS fix.
|
||||
|
||||
--- catman.c.orig 2013-10-05 14:09:07.000000000 +0000
|
||||
+++ catman.c
|
||||
@@ -31,7 +31,7 @@
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__sun)
|
||||
# include <db_185.h>
|
||||
#else
|
||||
# include <db.h>
|
|
@ -1,90 +0,0 @@
|
|||
$NetBSD: patch-cgi.c,v 1.1 2013/10/11 14:45:18 wiz Exp $
|
||||
|
||||
SunOS fix.
|
||||
|
||||
--- cgi.c.orig 2013-10-05 14:09:07.000000000 +0000
|
||||
+++ cgi.c
|
||||
@@ -33,6 +33,12 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
+#if defined(__sun)
|
||||
+/* for stat() */
|
||||
+#include <fcntl.h>
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/stat.h>
|
||||
+#endif
|
||||
|
||||
#include "apropos_db.h"
|
||||
#include "mandoc.h"
|
||||
@@ -42,7 +48,7 @@
|
||||
#include "manpath.h"
|
||||
#include "mandocdb.h"
|
||||
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__sun)
|
||||
# include <db_185.h>
|
||||
#else
|
||||
# include <db.h>
|
||||
@@ -1097,11 +1103,20 @@ static int
|
||||
pathstop(DIR *dir)
|
||||
{
|
||||
struct dirent *d;
|
||||
+#if defined(__sun)
|
||||
+ struct stat sb;
|
||||
+#endif
|
||||
|
||||
- while (NULL != (d = readdir(dir)))
|
||||
+ while (NULL != (d = readdir(dir))) {
|
||||
+#if defined(__sun)
|
||||
+ stat(d->d_name, &sb);
|
||||
+ if (S_IFREG & sb.st_mode)
|
||||
+#else
|
||||
if (DT_REG == d->d_type)
|
||||
+#endif
|
||||
if (0 == strcmp(d->d_name, "catman.conf"))
|
||||
return(1);
|
||||
+ }
|
||||
|
||||
return(0);
|
||||
}
|
||||
@@ -1118,6 +1133,9 @@ pathgen(DIR *dir, char *path, struct req
|
||||
DIR *cd;
|
||||
int rc;
|
||||
size_t sz, ssz;
|
||||
+#if defined(__sun)
|
||||
+ struct stat sb;
|
||||
+#endif
|
||||
|
||||
sz = strlcat(path, "/", PATH_MAX);
|
||||
if (sz >= PATH_MAX) {
|
||||
@@ -1133,7 +1151,13 @@ pathgen(DIR *dir, char *path, struct req
|
||||
|
||||
rc = 0;
|
||||
while (0 == rc && NULL != (d = readdir(dir))) {
|
||||
- if (DT_DIR != d->d_type || strcmp(d->d_name, "etc"))
|
||||
+#if defined(__sun)
|
||||
+ stat(d->d_name, &sb);
|
||||
+ if (!(S_IFDIR & sb.st_mode)
|
||||
+#else
|
||||
+ if (DT_DIR != d->d_type
|
||||
+#endif
|
||||
+ || strcmp(d->d_name, "etc"))
|
||||
continue;
|
||||
|
||||
path[(int)sz] = '\0';
|
||||
@@ -1182,7 +1206,13 @@ pathgen(DIR *dir, char *path, struct req
|
||||
|
||||
rewinddir(dir);
|
||||
while (NULL != (d = readdir(dir))) {
|
||||
- if (DT_DIR != d->d_type || '.' == d->d_name[0])
|
||||
+#if defined(__sun)
|
||||
+ stat(d->d_name, &sb);
|
||||
+ if (!(S_IFDIR & sb.st_mode)
|
||||
+#else
|
||||
+ if (DT_DIR != d->d_type
|
||||
+#endif
|
||||
+ || '.' == d->d_name[0])
|
||||
continue;
|
||||
|
||||
path[(int)sz] = '\0';
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-config.h.post,v 1.2 2013/10/11 14:45:18 wiz Exp $
|
||||
|
||||
SunOS fix.
|
||||
|
||||
--- config.h.post.orig 2013-10-05 14:09:07.000000000 +0000
|
||||
+++ config.h.post
|
||||
@@ -19,6 +19,9 @@
|
||||
# if defined(__APPLE__)
|
||||
# define betoh64(x) OSSwapBigToHostInt64(x)
|
||||
# define htobe64(x) OSSwapHostToBigInt64(x)
|
||||
+# elif defined(__sun)
|
||||
+# define betoh64(x) BE_64(x)
|
||||
+# define htobe64(x) BE_64(x)
|
||||
# else
|
||||
# define betoh64(x) be64toh(x)
|
||||
# endif
|
|
@ -1,36 +0,0 @@
|
|||
$NetBSD: patch-mandocdb.c,v 1.5 2013/10/11 14:45:18 wiz Exp $
|
||||
|
||||
SunOS fix.
|
||||
|
||||
--- mandocdb.c.orig 2013-10-05 14:09:07.000000000 +0000
|
||||
+++ mandocdb.c
|
||||
@@ -34,19 +34,21 @@
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
|
||||
-#if defined(__linux__) || defined(__sun)
|
||||
-# include <endian.h>
|
||||
-# include <db_185.h>
|
||||
-#elif defined(__APPLE__)
|
||||
+#if defined(__APPLE__)
|
||||
# include <libkern/OSByteOrder.h>
|
||||
-# include <db.h>
|
||||
+#elif defined(__linux__)
|
||||
+# include <endian.h>
|
||||
+#elif defined(__sun)
|
||||
+# include <sys/byteorder.h>
|
||||
+# include <sys/stat.h>
|
||||
#else
|
||||
# include <sys/endian.h>
|
||||
-# include <db.h>
|
||||
#endif
|
||||
|
||||
-#if defined(__sun)
|
||||
-#include <sys/stat.h>
|
||||
+#if defined(__linux__) || defined(__sun)
|
||||
+# include <db_185.h>
|
||||
+#else
|
||||
+# include <db.h>
|
||||
#endif
|
||||
|
||||
#include "man.h"
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-roff.7,v 1.2 2013/10/05 14:48:15 wiz Exp $
|
||||
$NetBSD: patch-roff.7,v 1.3 2013/12/31 11:06:30 wiz Exp $
|
||||
|
||||
Install preconv and roff with 'mandoc-' prefix to avoid conflict with groff.
|
||||
|
||||
--- roff.7.orig 2013-09-29 23:34:34.000000000 +0000
|
||||
--- roff.7.orig 2013-12-28 23:28:23.000000000 +0000
|
||||
+++ roff.7
|
||||
@@ -16,10 +16,10 @@
|
||||
.\" OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
.\"
|
||||
.Dd $Mdocdate: August 8 2013 $
|
||||
.Dd $Mdocdate: December 26 2013 $
|
||||
-.Dt ROFF 7
|
||||
+.Dt MANDOC-ROFF 7
|
||||
.Os
|
||||
|
|
Loading…
Reference in a new issue