Update to john-1.7.2 and enable per-arch optimization for NetBSD and
OpenBSD. Changes: The following changes have been made between John 1.7.1 and 1.7.2: * Bitslice DES assembly code for x86-64 making use of the 64-bit mode extended SSE2 with 16 XMM registers has been added for better performance at DES-based crypt(3) hashes with x86-64 builds on AMD processors. * New make target for FreeBSD/x86-64. The following changes have been made between John 1.7.0.2 and 1.7.1: * Bitslice DES code for x86 with SSE2 has been added for better performance at DES-based crypt(3) hashes on Pentium 4 and SSE2-capable AMD processors. * Assorted high-level changes have been applied to improve performance on current x86-64 processors. * New make target for NetBSD/SPARC64. * Minor source code cleanups.
This commit is contained in:
parent
f94b7ea69c
commit
7ebc7857d8
3 changed files with 49 additions and 12 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.14 2006/03/30 13:38:41 salo Exp $
|
||||
# $NetBSD: Makefile,v 1.15 2007/02/03 17:09:20 sborrill Exp $
|
||||
#
|
||||
|
||||
DISTNAME= john-1.7.0.2
|
||||
#PKGREVISION= 1
|
||||
DISTNAME= john-1.7.2
|
||||
CATEGORIES= security textproc
|
||||
MASTER_SITES= http://www.openwall.com/john/f/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -29,6 +28,44 @@ BUILD_TARGET= solaris-sparc-gcc
|
|||
. endif
|
||||
.elif ${OPSYS} == "SunOS" && ${MACHINE_ARCH} == "i386"
|
||||
BUILD_TARGET= solaris-x86-any
|
||||
.elif ${OPSYS} == "NetBSD"
|
||||
. if ${MACHINE_ARCH} == "i386"
|
||||
BUILD_TARGET= openbsd-x86-any
|
||||
. elif ${MACHINE_ARCH} == "x86_64"
|
||||
BUILD_TARGET= openbsd-x86-64
|
||||
. elif ${MACHINE_ARCH} == "sparc64"
|
||||
BUILD_TARGET= netbsd-sparc64
|
||||
. elif ${MACHINE_ARCH} == "sparc"
|
||||
BUILD_TARGET= openbsd-sparc
|
||||
. elif ${MACHINE_ARCH} == "alpha"
|
||||
BUILD_TARGET= openbsd-alpha
|
||||
. elif ${MACHINE_ARCH} == "powerpc"
|
||||
BUILD_TARGET= openbsd-ppc32
|
||||
. elif ${MACHINE_ARCH} == "powerpc64"
|
||||
BUILD_TARGET= openbsd-ppc64
|
||||
. elif ${MACHINE_ARCH} == "vax"
|
||||
BUILD_TARGET= netbsd-vax
|
||||
. else
|
||||
BUILD_TARGET= generic
|
||||
. endif
|
||||
.elif ${OPSYS} == "OpenBSD"
|
||||
. if ${MACHINE_ARCH} == "i386"
|
||||
BUILD_TARGET= openbsd-x86-any
|
||||
. elif ${MACHINE_ARCH} == "x86_64"
|
||||
BUILD_TARGET= openbsd-x86-64
|
||||
. elif ${MACHINE_ARCH} == "sparc64"
|
||||
BUILD_TARGET= openbsd-sparc64
|
||||
. elif ${MACHINE_ARCH} == "sparc"
|
||||
BUILD_TARGET= openbsd-sparc
|
||||
. elif ${MACHINE_ARCH} == "alpha"
|
||||
BUILD_TARGET= openbsd-alpha
|
||||
. elif ${MACHINE_ARCH} == "powerpc"
|
||||
BUILD_TARGET= openbsd-ppc32
|
||||
. elif ${MACHINE_ARCH} == "powerpc64"
|
||||
BUILD_TARGET= openbsd-ppc64
|
||||
. else
|
||||
BUILD_TARGET= generic
|
||||
. endif
|
||||
.else
|
||||
BUILD_TARGET= generic
|
||||
.endif
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.8 2006/03/30 13:38:41 salo Exp $
|
||||
$NetBSD: distinfo,v 1.9 2007/02/03 17:09:20 sborrill Exp $
|
||||
|
||||
SHA1 (john-1.7.0.2.tar.bz2) = bc6895c986d65f502366cf93c91f88ba865572b6
|
||||
RMD160 (john-1.7.0.2.tar.bz2) = 9e75f5fd5561595ec2f3a1a290e85605234b8c41
|
||||
Size (john-1.7.0.2.tar.bz2) = 690516 bytes
|
||||
SHA1 (patch-aa) = 5daecad929d2fc3819354f969f885421b4077497
|
||||
SHA1 (john-1.7.2.tar.bz2) = 7cc994f9cbd1582b46cbdeb1d5f318891ea8b411
|
||||
RMD160 (john-1.7.2.tar.bz2) = 3754da88a98f1c120e28de1eb10b214bf7dd3baf
|
||||
Size (john-1.7.2.tar.bz2) = 691706 bytes
|
||||
SHA1 (patch-aa) = e458b6c2423f625ef30a36a96e79bac69fae297f
|
||||
SHA1 (patch-ab) = 331fa2333860879edabdbf1beeb3323d303406ec
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-aa,v 1.4 2006/03/14 10:17:25 martti Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2007/02/03 17:09:21 sborrill Exp $
|
||||
|
||||
--- src/Makefile.orig 2006-01-12 04:30:50.000000000 +0200
|
||||
+++ src/Makefile 2006-03-14 08:38:08.000000000 +0200
|
||||
--- src/Makefile.orig 2006-05-15 17:38:00.000000000 +0100
|
||||
+++ src/Makefile 2007-02-03 16:13:58.000000000 +0000
|
||||
@@ -3,10 +3,10 @@
|
||||
# Copyright (c) 1996-2005 by Solar Designer
|
||||
# Copyright (c) 1996-2006 by Solar Designer
|
||||
#
|
||||
|
||||
-CPP = gcc
|
||||
|
|
Loading…
Reference in a new issue