- Convert gnome option to use gnome2 libraries, via official patch.

Manually patch Makefile.in and configure to avoid dependency on autotools.
- Explicitly disable esd when not requested, it is found and used
  with gnome enabled otherwise.
This commit is contained in:
dillo 2006-07-06 08:37:27 +00:00
parent 7145580d62
commit 7ebc8b46c8
4 changed files with 104 additions and 3 deletions

View file

@ -1,11 +1,16 @@
$NetBSD: distinfo,v 1.24 2006/06/29 22:56:34 dillo Exp $
$NetBSD: distinfo,v 1.25 2006/07/06 08:37:27 dillo Exp $
SHA1 (vice-1.19.tar.gz) = 8620d891fa9de29eb21e334f3c7c8254e89e80a9
RMD160 (vice-1.19.tar.gz) = d0a62750c30e3cf8645117a8e8536a8061c260ea
Size (vice-1.19.tar.gz) = 4796181 bytes
SHA1 (vice-1.19-gnome2.diff.gz) = 66c11e6e10886754a9a22c95d9d570dc00f57dad
RMD160 (vice-1.19-gnome2.diff.gz) = bff155d6d6ee69b7e9df7366e49976164dea415f
Size (vice-1.19-gnome2.diff.gz) = 24202 bytes
SHA1 (patch-aa) = 8e1a8b661e1e4f6847c8a0495308ad3e0c2f6dcd
SHA1 (patch-ab) = 12657561998b724c39699c380290e7333365d300
SHA1 (patch-ac) = 0a0c1da41d5dc7cb322f1a6a62023c0bad1419f2
SHA1 (patch-ad) = 5c1510a66d775b8a5a1b0a7d596aa111218993be
SHA1 (patch-ae) = 9528bc0da7af5a0c74f5f0d2a8bf30b71802850c
SHA1 (patch-af) = 524913b7bc753dafde909bb26ace8f0500be14d5
SHA1 (patch-ag) = 79c27bf784041792f04f09c6cd967d0c6cafc1ce
SHA1 (patch-ah) = 3f92ef4e5f64b254c3d52f9bbd9921dd25ee0aeb

View file

@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.1 2006/02/17 19:26:20 wiz Exp $
# $NetBSD: options.mk,v 1.2 2006/07/06 08:37:27 dillo Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.vice
PKG_SUPPORTED_OPTIONS= esound ffmpeg lame gnome
@ -7,6 +7,8 @@ PKG_SUPPORTED_OPTIONS= esound ffmpeg lame gnome
.if !empty(PKG_OPTIONS:Mesound)
.include "../../audio/esound/buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-esd
.endif
.if !empty(PKG_OPTIONS:Mffmpeg)
@ -19,5 +21,8 @@ CONFIGURE_ARGS+= --enable-ffmpeg
.if !empty(PKG_OPTIONS:Mgnome)
CONFIGURE_ARGS+= --enable-gnomeui
.include "../../x11/gnome-libs/buildlink3.mk"
PATCHFILES= vice-1.19-gnome2.diff.gz
PATCH_SITES= http://www.viceteam.org/online/
PATCH_DIST_STRIP= -p1
.include "../../devel/libgnomeui/buildlink3.mk"
.endif

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ag,v 1.5 2006/07/06 08:37:27 dillo Exp $
--- configure.orig 2006-01-08 21:31:51.000000000 +0100
+++ configure
@@ -19748,7 +19748,7 @@ _ACEOF
elif [ x"${enable_gnomeui}" = x"yes" ] ; then
- LIBS="${LIBS} `gnome-config --libs gnomeui`"
+ LIBS="${LIBS} `pkg-config --libs libgnomeui-2.0`"
cat >>confdefs.h <<\_ACEOF
@@ -20509,7 +20509,7 @@ if test x"$is_dos" != "xyes" -a x"$is_wi
ARCH_INCLUDES="-I\$(top_srcdir)/src/arch/unix"
else
ARCH_LIBS="$ARCH_DIR/x11/gnome/libgnomeui.a $ARCH_DIR/libarch.a $ARCH_DIR/x11/libx11ui.a $ARCH_DIR/x11/gnome/libgnomeui.a $ARCH_DIR/x11/libx11ui.a $ARCH_DIR/libarch.a"
- ARCH_INCLUDES="-I\$(top_srcdir)/src/arch/unix `gnome-config --cflags gnomeui`"
+ ARCH_INCLUDES="-I\$(top_srcdir)/src/arch/unix `pkg-config --cflags libgnomeui-2.0`"
fi

View file

@ -0,0 +1,69 @@
$NetBSD: patch-ah,v 1.3 2006/07/06 08:37:27 dillo Exp $
--- src/arch/unix/x11/gnome/Makefile.in.orig 2006-06-30 02:35:06.000000000 +0200
+++ src/arch/unix/x11/gnome/Makefile.in
@@ -245,7 +245,6 @@ noinst_LIBRARIES = libgnomeui.a
libgnomeui_a_SOURCES = \
about.c \
- dummies.c \
gnomekbd.c \
gnomevideo.c \
uiarch.h \
@@ -259,6 +258,8 @@ libgnomeui_a_SOURCES = \
uiscreenshot.c \
uisnapshot.c \
uivsidcontrol.c \
+ uifileentry.c \
+ uifileentry.h \
videoarch.h \
x11ui.c
@@ -270,18 +271,18 @@ LIBRARIES = $(noinst_LIBRARIES)
libgnomeui_a_AR = $(AR) cru
libgnomeui_a_LIBADD =
-am_libgnomeui_a_OBJECTS = about.$(OBJEXT) dummies.$(OBJEXT) \
+am_libgnomeui_a_OBJECTS = about.$(OBJEXT) \
gnomekbd.$(OBJEXT) gnomevideo.$(OBJEXT) uicartridge.$(OBJEXT) \
uicolor.$(OBJEXT) uiedisk.$(OBJEXT) uimenu.$(OBJEXT) \
uinetplay.$(OBJEXT) uipalcontrol.$(OBJEXT) \
uiscreenshot.$(OBJEXT) uisnapshot.$(OBJEXT) \
- uivsidcontrol.$(OBJEXT) x11ui.$(OBJEXT)
+ uifileentry.$(OBJEXT) uivsidcontrol.$(OBJEXT) x11ui.$(OBJEXT)
libgnomeui_a_OBJECTS = $(am_libgnomeui_a_OBJECTS)
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)/src
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
-@AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/about.Po ./$(DEPDIR)/dummies.Po \
+@AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/about.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/gnomekbd.Po ./$(DEPDIR)/gnomevideo.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/uicartridge.Po ./$(DEPDIR)/uicolor.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/uiedisk.Po ./$(DEPDIR)/uimenu.Po \
@@ -289,7 +290,8 @@ am__depfiles_maybe = depfiles
@AMDEP_TRUE@ ./$(DEPDIR)/uipalcontrol.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/uiscreenshot.Po \
@AMDEP_TRUE@ ./$(DEPDIR)/uisnapshot.Po \
-@AMDEP_TRUE@ ./$(DEPDIR)/uivsidcontrol.Po ./$(DEPDIR)/x11ui.Po
+@AMDEP_TRUE@ ./$(DEPDIR)/uivsidcontrol.Po ./$(DEPDIR)/uifileentry.Po \
+@AMDEP_TRUE@ ./$(DEPDIR)/x11ui.Po
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
@@ -322,7 +324,6 @@ distclean-compile:
-rm -f *.tab.c
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/about.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/dummies.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gnomekbd.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gnomevideo.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/uicartridge.Po@am__quote@
@@ -334,6 +335,7 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/uiscreenshot.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/uisnapshot.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/uivsidcontrol.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/uifileentry.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/x11ui.Po@am__quote@
distclean-depend: