Always use /dev/random to seed on NetBSD, instead of relying on a
configure test, which might arbitrarily fail if chrooted.
This commit is contained in:
parent
bb2274cc9b
commit
7ec9f61923
2 changed files with 16 additions and 4 deletions
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.4 2012/06/25 11:49:10 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.5 2012/06/28 04:50:12 dholland Exp $
|
||||
|
||||
SHA1 (ortp-0.16.1.tar.gz) = 4e6288745b066d51b58834e2e33d8bc48d50d94e
|
||||
RMD160 (ortp-0.16.1.tar.gz) = c1c85ebdf308de4b5be66707c56a156299f67b9e
|
||||
Size (ortp-0.16.1.tar.gz) = 466365 bytes
|
||||
SHA1 (patch-src_avprofile.c) = 1740714e00d22ed8cde08106a9e5f56d4c40abe7
|
||||
SHA1 (patch-src_stun.c) = 487faca256c839d5b15cea7169f3fa14844bb338
|
||||
SHA1 (patch-src_stun.c) = 031c56685acc8061fa66ee06487f1855e45bd672
|
||||
SHA1 (patch-src_tests_rtprecv.c) = 5b42382fcd7ebcaf189fdadea893df42457029dd
|
||||
|
|
|
@ -1,6 +1,9 @@
|
|||
$NetBSD: patch-src_stun.c,v 1.2 2012/06/25 11:49:10 joerg Exp $
|
||||
$NetBSD: patch-src_stun.c,v 1.3 2012/06/28 04:50:12 dholland Exp $
|
||||
|
||||
Fix build with gcc 4.6
|
||||
- Fix a wrong memset call.
|
||||
- Always seed with /dev/random on NetBSD instead of relying on a
|
||||
configure test.
|
||||
- Fix build with gcc 4.6
|
||||
|
||||
--- src/stun.c.orig 2009-06-16 10:49:48.000000000 +0000
|
||||
+++ src/stun.c
|
||||
|
@ -13,6 +16,15 @@ Fix build with gcc 4.6
|
|||
|
||||
if (sizeof(StunMsgHdr) > bufLen)
|
||||
{
|
||||
@@ -1185,7 +1185,7 @@ stunRand(void)
|
||||
read(fd,&tick,sizeof(tick));
|
||||
closesocket(fd);
|
||||
}
|
||||
-#elif defined(__linux) || defined(HAVE_DEV_RANDOM)
|
||||
+#elif defined(__linux) || defined(__NetBSD__) || defined(HAVE_DEV_RANDOM)
|
||||
{
|
||||
fd_set fdSet;
|
||||
int maxFd=0;
|
||||
@@ -1984,7 +1984,6 @@ stunSendTest( Socket myFd, StunAddress4
|
||||
|
||||
bool_t changePort=FALSE;
|
||||
|
|
Loading…
Reference in a new issue