inline linear2mulaw() and mulaw2linear().

with SunPro, inline functions can't call static functions unless they
are also inline.

fixes build on Solaris.
This commit is contained in:
grant 2004-06-12 01:37:39 +00:00
parent a64ef6e3d8
commit 7ee7f4c84e
2 changed files with 24 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.5 2004/03/01 15:56:58 adam Exp $
$NetBSD: distinfo,v 1.6 2004/06/12 01:37:39 grant Exp $
SHA1 (madplay-0.15.2b.tar.gz) = 29105eb27c1416aa33c8d1ab3404a8e5f0aecd3f
Size (madplay-0.15.2b.tar.gz) = 590929 bytes
SHA1 (patch-aa) = 0dd6ee05f9b0d58a88fe9b61f52bf847227c51a6
SHA1 (patch-ab) = 7af616781aa695e6be2c4a4cae23dafc5d056c4f

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ab,v 1.6 2004/06/12 01:37:39 grant Exp $
--- audio.c.orig 2004-01-23 20:41:31.000000000 +1100
+++ audio.c
@@ -959,7 +959,7 @@ unsigned int audio_pcm_s32be(unsigned ch
}
}
-static
+static inline
unsigned char linear2mulaw(mad_fixed_t sample)
{
unsigned int sign, mulaw;
@@ -1000,7 +1000,7 @@ unsigned char linear2mulaw(mad_fixed_t s
return mulaw;
}
-static
+static inline
mad_fixed_t mulaw2linear(unsigned char mulaw)
{
int sign, segment, mantissa, value;