Fix WMP9 playback time limit by not sending a Content-Length header.

This commit is contained in:
kim 2004-04-11 05:48:34 +00:00
parent ecb61286fe
commit 7f306ebf8a
3 changed files with 17 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.3 2004/01/12 03:54:28 kim Exp $
# $NetBSD: Makefile,v 1.4 2004/04/11 05:48:34 kim Exp $
#
DISTNAME= icecast-1.3.12
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.icecast.org/releases/

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.1.1.2 2004/01/11 16:59:34 kim Exp $
$NetBSD: distinfo,v 1.2 2004/04/11 05:48:34 kim Exp $
SHA1 (icecast-1.3.12.tar.gz) = bacb760390453718de536b85979ff3a9a73c7710
Size (icecast-1.3.12.tar.gz) = 269822 bytes
SHA1 (patch-aa) = 169202f563e4e2812d8d532264dcdb4f9ffc8df2
SHA1 (patch-ab) = de33a89e6078721a7e9c3a09515846752e76680e
SHA1 (patch-ac) = 4775c84b910f9b19134f66a57f5196b572daf3cc
SHA1 (patch-ad) = 787838025c33a2b84bc0dd20ac6442e5d8cc24c0

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1 2004/04/11 05:48:34 kim Exp $
--- src/client.c.orig 2001-08-01 20:56:47.000000000 -0400
+++ src/client.c 2004-04-11 01:41:01.000000000 -0400
@@ -476,6 +476,8 @@
return 1;
if (strstr(val, "RMA/1.0"))
return 1;
+ if (strstr(val, "NSPlayer/9"))
+ return 0;
if (strstr(val, "NSPlayer"))
return 1;
return 0;